PowerFlex-hanteringsplattform: LDAP-användare kan inte göra API-anrop
Summary: En LDAP-aktiverad användare får felmeddelandet "ingen roll tilldelad till användaren" när han eller hon gör API-anrop.
Symptoms
Scenario
En LDAP-användare kan logga in via användargränssnittet men kan inte göra API-anrop. Felmeddelande som visas på skärmbilden nedan: "Ingen roll tilldelad till användaren":
Påverkan
Det går inte att använda API med LDAP-användare.
Cause
Ett fel i programvarudesignen tillåter inte igenkänning av LDAP-användarrollen om användaren bara är en del av en grupproll.
När du använder enkel inloggning – en LDAP-användare är tilldelad till en LDAP-grupp och LDAP-gruppen är konfigurerad med en användarroll, misslyckas REST-inloggningskommandot på grund av "ingen roll tilldelad till användaren".
Resolution
Lösningen är att lägga till användaren i avsnittet Fjärranvändare/-grupper i användargränssnittet. Även om användaren redan finns i någon av grupperna i listan. Buggen uppstår när typanvändaren inte hittas för ett API-anrop.
I bilden nedan, även om användaren "xxxxx" är medlem i sio_admin-gruppen , kan användaren inte göra API-anrop förrän vi lägger till användaren här som en typ = användare.
Om användaren "xxxx" tas bort från det här avsnittet tillåts inte API-anrop. Användaren måste finnas med en Typ = Användare.
Additional Information
Berörd version
PFMP 4.x