PowerFlex-hanteringsplattform: LDAP-användare kan inte göra API-anrop

Summary: En LDAP-aktiverad användare får felmeddelandet "ingen roll tilldelad till användaren" när han eller hon gör API-anrop.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Scenario

En LDAP-användare kan logga in via användargränssnittet men kan inte göra API-anrop. Felmeddelande som visas på skärmbilden nedan: "Ingen roll tilldelad till användaren":
Ingen roll tilldelad till användarens skärmbild

Påverkan

Det går inte att använda API med LDAP-användare.

 

Cause

Ett fel i programvarudesignen tillåter inte igenkänning av LDAP-användarrollen om användaren bara är en del av en grupproll.

När du använder enkel inloggning – en LDAP-användare är tilldelad till en LDAP-grupp och LDAP-gruppen är konfigurerad med en användarroll, misslyckas REST-inloggningskommandot på grund av "ingen roll tilldelad till användaren".

 

Resolution

Lösningen är att lägga till användaren i avsnittet Fjärranvändare/-grupper i användargränssnittet. Även om användaren redan finns i någon av grupperna i listan. Buggen uppstår när typanvändaren inte hittas för ett API-anrop.

I bilden nedan, även om användaren "xxxxx" är medlem i sio_admin-gruppen , kan användaren inte göra API-anrop förrän vi lägger till användaren här som en typ = användare.

Om användaren "xxxx" tas bort från det här avsnittet tillåts inte API-anrop. Användaren måste finnas med en Typ = Användare.
Fjärranvändare/-grupper

 

Additional Information

Berörd version

PFMP 4.x

 

Affected Products

PowerFlex rack RCM Software
Article Properties
Article Number: 000280795
Article Type: Solution
Last Modified: 17 Feb 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.