Avamar: I backup incrementali SQL vengono promossi a backup completi in modo casuale a causa della mancata corrispondenza LSN

Summary: I backup incrementali SQL venivano promossi in modo casuale a backup completi nonostante fosse presente un backup completo recente riuscito.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

I backup incrementali SQL venivano promossi in modo casuale a backup completi su un SQL Server occupato con molte transazioni. Il meccanismo di rilevamento dei gap nel registro all'interno del plug-in SQL Avamar si attivava in modo errato, anche se la continuità LSN (Log Sequence Number) non veniva interrotta. 

 

I backup incrementali SQL Avamar hanno esito negativo in modo casuale con:

2025-02-05 07:01:16 avsql Info <15765>: A log gap was identified or a full backup was not found.
2025/02/05-07:01:16.98499 [avsql_assist]  ===> sqlconnect::~sqlconnect
2025/02/05-07:01:16.98499 [avsql_assist]  <=== sqlconnect::~sqlconnect
2025/02/05-07:01:16.98499 [avsql_assist]  <=== avsql_assist::snapup_check_timestamps
2025-02-05 07:01:16 avsql Warning <7420>: Forcing FULL backup for database 'sql1\GRS/GRSBLOBS' due to the following reason: A log gap was identified or a full backup was not found.

Cause

È stata generata una correzione per risolvere questo problema. Questo problema viene visualizzato quando l'algoritmo del plug-in SQL Avamar recupera l'ultimo LSN dal server SQL e non sempre ottiene l LSN più aggiornato. Questo comportamento causava promozioni impreviste a backup completi. 

Resolution

Le correzioni per questo problema sono disponibili nella pagina Driver e download di Avamar di Dell 

  1. Plug-in Avamar SQL versione 19.10.100.166
    1. Hotfix numero 338887 
  2. Plug-in Avamar SQL versione 19.12.100.186
    1. Numero di hotfix 338888  

Per istruzioni sul download di hotfix, consultare:

 Avamar: Come trovare e scaricare un hotfix, una patch, un pacchetto di installazione o aggiornamento di un prodotto dal sito web di supporto Dell 

Questi hotfix utilizzano un nuovo flag del plug-in SQL che deve essere aggiunto al file avsql.cmd o nel dataset.

  1. Per utilizzare questo nuovo flag in Avamar, attenersi alla seguente procedura:
    1. Individuare il file avsql.cmd: In genere, questo file si trova nella directory di installazione di Avamar Client.
    2. Modificare il file avsql.cmd: Aprire il file in un editor di testo con privilegi di amministratore.
    3. Aggiungere il flag riportato di seguito:
    4. Salvare e chiudere il file 
--latest-lsn-from-msdb=True

Quando questo flag è abilitato (True), garantisce che il numero LSN corretto venga recuperato da SQL Server per la convalida del "log gap".

Il flag precedente può anche essere aggiunto al dataset.

  1. Per l'interfaccia utente , consultare Avamar: Come fornire flag specializzati ai backup Avamar
  2. Per AUI
    1. Vai all'AUI
      1. Individuare Backup Policy.
      2. Selezionare una policy
      3. Cliccare su Edit.
    2. Passare alla pagina Dataset.
      1. Nella sezione Edit Dataset, abilitare l'interruttore "Turn on this toggle to edit dataset"
      2. Nella sezione Plugins:
        1. Selezionare un plug-in.
        2. Attivare l'interruttore Show Free Form.
    3. Aggiungere il flag richiesto utilizzando coppie chiave-valore. Ad esempio, per abilitare il blocco del periodo, utilizzare:
      1. Legenda: [avtar]"Flag"
      2. Valore: true
    4. Fare clic su Submit per salvare le modifiche al dataset.

 

Affected Products

Avamar Plug-in for SQL

Products

Avamar
Article Properties
Article Number: 000291727
Article Type: Solution
Last Modified: 05 Sept 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.