Avamar: Backups incrementais SQL sendo promovidos para completos aleatoriamente devido à disparidade de LSN

Summary: Os backups incrementais do SQL estavam sendo promovidos aleatoriamente para backups completos, apesar de um backup completo recente bem-sucedido estar presente.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Os backups incrementais do SQL estavam sendo promovidos aleatoriamente para backups completos em um SQL Server ocupado com muitas transações. O mecanismo de detecção de lacunas de log no plug-in Avamar SQL estava sendo acionado incorretamente, mesmo que a continuidade do número de sequência de logs (LSN) não estivesse interrompida. 

 

Os backups incrementais do Avamar SQL falhariam aleatoriamente com:

2025-02-05 07:01:16 avsql Info <15765>: A log gap was identified or a full backup was not found.
2025/02/05-07:01:16.98499 [avsql_assist]  ===> sqlconnect::~sqlconnect
2025/02/05-07:01:16.98499 [avsql_assist]  <=== sqlconnect::~sqlconnect
2025/02/05-07:01:16.98499 [avsql_assist]  <=== avsql_assist::snapup_check_timestamps
2025-02-05 07:01:16 avsql Warning <7420>: Forcing FULL backup for database 'sql1\GRS/GRSBLOBS' due to the following reason: A log gap was identified or a full backup was not found.

Cause

Uma correção foi gerada para resolver esse problema. Esse problema é exibido quando o algoritmo do plug-in SQL do Avamar recupera a última LSN do SQL Server e nem sempre obtém a LSN mais atualizada. Esse comportamento causou promoções inesperadas para backups completos. 

Resolution

As correções para esse problema podem ser encontradas na página da Dell Drivers e download do Avamar 

  1. Plug-in Avamar SQL versão 19.10.100.166
    1. Número do hotfix 338887 
  2. Plug-in Avamar SQL versão 19.12.100.186
    1. Número do hotfix 338888  

Para obter instruções de download de hotfixes, consulte:

 Avamar: Como encontrar e fazer download de um pacote de hotfix, patch, instalação ou upgrade de um produto no site de suporte da Dell 

Esses hotfixes usam um novo sinalizador de plug-in SQL que deve ser adicionado ao arquivo avsql.cmd ou no conjunto de dados.

  1. Para usar esse novo indicador no Avamar, siga estas etapas:
    1. Localize o arquivo avsql.cmd: Esse arquivo normalmente é encontrado no diretório de instalação do Avamar Client.
    2. Edite o arquivo avsql.cmd: Abra o arquivo em um editor de texto com privilégios administrativos.
    3. Adicione a bandeira abaixo:
    4. Salve e feche o arquivo 
--latest-lsn-from-msdb=True

Quando esse indicador é ativado (verdadeiro), ele garante que o número de LSN correto seja recuperado do SQL Server para validação de "lacuna de registro".

O indicador acima também pode ser adicionado ao conjunto de dados.

  1. Para IU, consulte Avamar: Como fornecer indicadores especializados para backups do Avamar
  2. Para AUI
    1. Vá para a AUI
      1. Localize a Política de backup.
      2. Selecione uma política
      3. Clique em Edit.
    2. Vá para a página Dataset.
      1. Na seção Edit Dataset, ative a opção "Turn on this toggle to edit dataset"
      2. Na seção Plugins:
        1. Selecione um plug-in.
        2. Ative a opção Mostrar formulário livre.
    3. Adicione o indicador necessário usando pares chave-valor. Por exemplo, para habilitar o bloqueio de período, use:
      1. Key: [avtar]"Flag"
      2. Valor: true
    4. Clique em Submit para salvar as alterações do conjunto de dados.

 

Affected Products

Avamar Plug-in for SQL

Products

Avamar
Article Properties
Article Number: 000291727
Article Type: Solution
Last Modified: 05 Sept 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.