Avamar. Инкрементные резервные копии SQL случайным образом повышаются до полного из-за несоответствия номеров LSN

Summary: Инкрементные резервные копии SQL случайным образом переводились в полные резервные копии, несмотря на недавнее успешное полное резервное копирование.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Инкрементные резервные копии SQL случайным образом переводились в полные резервные копии на занятом сервере SQL с большим количеством транзакций. Механизм обнаружения пропусков в журналах в подключаемом модуле SQL Avamar запускался неправильно, даже если непрерывность порядкового номера журнала (LSN) не была нарушена. 

 

Случайный сбой инкрементного резервного копирования Avamar SQL с ошибкой:

2025-02-05 07:01:16 avsql Info <15765>: A log gap was identified or a full backup was not found.
2025/02/05-07:01:16.98499 [avsql_assist]  ===> sqlconnect::~sqlconnect
2025/02/05-07:01:16.98499 [avsql_assist]  <=== sqlconnect::~sqlconnect
2025/02/05-07:01:16.98499 [avsql_assist]  <=== avsql_assist::snapup_check_timestamps
2025-02-05 07:01:16 avsql Warning <7420>: Forcing FULL backup for database 'sql1\GRS/GRSBLOBS' due to the following reason: A log gap was identified or a full backup was not found.

Cause

Для устранения этой проблемы было создано исправление. Эта проблема возникает, когда алгоритм подключаемого модуля SQL Avamar получает последний номер LSN с сервера SQL и не всегда получает самый последний номер LSN. Это приводило к непредвиденным повышениям до полных резервных копий. 

Resolution

Решения этой проблемы можно найти на странице Dell Драйверы и загружаемые материалы Avamar 

  1. Подключаемый модуль Avamar SQL версии 19.10.100.166
    1. Номер оперативного исправления 338887 
  2. Подключаемый модуль Avamar SQL версии 19.12.100.186
    1. Номер оперативного исправления 338888  

Инструкции по скачиванию исправлений см. в разделе:

 Avamar. Как найти и скачать пакет оперативного исправления, исправления, установки или модернизации продукта с веб-сайта технической поддержки Dell 

Эти исправления используют новый флаг подключаемого модуля SQL, который необходимо добавить в avsql.cmd файл или набор данных.

  1. Чтобы использовать этот новый флаг в Avamar, выполните следующие действия.
    1. Найдите файл avsql.cmd: Этот файл обычно находится в каталоге установки клиента Avamar.
    2. Отредактируйте файл avsql.cmd. Откройте файл в текстовом редакторе с правами администратора.
    3. Добавьте флаг ниже:
    4. Сохраните и закройте файл 
--latest-lsn-from-msdb=True

Если этот флаг включен (True), он гарантирует, что с сервера SQL будет получен правильный номер LSN для проверки «логарифмического разрыва».

Приведенный выше флаг также можно добавить в набор данных.

  1. Сведения о пользовательском интерфейсе см . в разделе Avamar. Как предоставить специализированные флаги для резервных копий Avamar
  2. Для AUI
    1. Перейдите в AUI
      1. Найдите Политика резервного копирования.
      2. Выберите политику
      3. Нажмите Edit.
    2. Перейдите на страницу Набор данных.
      1. В разделе Редактировать набор данных включите переключатель с надписью «Включить этот переключатель для редактирования набора данных»
      2. В разделе Плагины:
        1. Выберите подключаемый модуль.
        2. Включите параметр Показать свободную форму.
    3. Добавьте требуемый флаг, используя пары ключ-значение. Например, чтобы включить блокировку периода, используйте:
      1. Key: [avtar]"Flag"
      2. Значение: true
    4. Нажмите кнопку Отправить, чтобы сохранить изменения набора данных.

 

Affected Products

Avamar Plug-in for SQL

Products

Avamar
Article Properties
Article Number: 000291727
Article Type: Solution
Last Modified: 05 Sept 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.