File Explorer Not Responding in Windows 10
Summary: Having trouble with File Explorer not responding in Windows 10? Follow this guide to resolve issues by clearing history, resetting folders, and restoring default settings. Restart your computer to fix the problem. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Affected Operating Systems:
- Windows 10
Does Windows 10 File Explorer fail to respond, continues in a working loop and then the non-responding message appears?
Cause
This problem occurs because of certain applications downloaded to the computer that can cause some settings to be changed, causing FILE EXPLORER locking and slow computer performance. To resolve the issue, follow the steps below:
Resolution
- Click the Start button and type FILE EXPLORER OPTIONS:

- Click the GENERAL tab, in the Clear File Explorer History option click CLEAR, then click RESTORE DEFAULTS, and finally click APPLY.

- Now click the VIEW tab, select RESET FOLDERS, and then click YES. Then click RESTORE DEFAULTS, and then APPLY.

- In the SEARCH tab, click RESTORE DEFAULTS after this click APPLY.

- Once this is done, restart the computer, and the issue should be resolved.
Affected Products
Alienware, Inspiron, Legacy Desktop Models, OptiPlex, Vostro, XPS, G Series, G Series, Alienware, Inspiron, Latitude, Vostro, XPS, Legacy Laptop Models, Fixed Workstations, Mobile WorkstationsArticle Properties
Article Number: 000148462
Article Type: Solution
Last Modified: 17 Jul 2025
Version: 8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.