Avamar: Lista kopii zapasowych zajmuje dużo czasu po zastosowaniu poprawki 19.9 mcs 338748

Summary: Po zastosowaniu poprawki 19.9 Management Console Server (MCS) 338748 pobieranie kopii zapasowych zajmuje dużo czasu, a czasami przekracza limit czasu.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Upewnij się, że bieżąca wersja Avamar to 19.9 z poprawką 338748:

admin@avamar-server:~/>: mcserver.sh --version
  version:              19.9.0-78_HF338748
  build date:           Aug 22 2023 12:55:54
  PostgreSQL version:   postgres (PostgreSQL) 10.23
  db schema version:    19.8.0.1
  views schema version: 7.5.0.5
admin@avamar-server:~/>:

W poniższym przykładzie klient Avamar ma 14 lokalnych kopii zapasowych i 14 zdalnych kopii zapasowych.

Podczas pobierania kopii zapasowej w interfejsie użytkownika Avamar (AUI) lub interfejsie użytkownika administratora Avamar dziennik mcserver zawiera następujące komunikaty: 

getImmutableBackupStatus
getGovernanceModeStatus
admin@avamar-server:/usr/local/avamar/var/mc/server_log/>: grep "195983] com.avamar.mc.dpn.DPNProxyService.get" mcserver.log.0
12/21-04:43:55.00773 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getImmutableBackupStatus
12/21-04:43:55.00773 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getImmutableBackupStatus
12/21-04:43:55.00892 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getGovernanceModeStatus
12/21-04:43:55.00892 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getGovernanceModeStatus
...
...
...
12/21-04:43:59.00055 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getImmutableBackupStatus
12/21-04:43:59.00055 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getImmutableBackupStatus
12/21-04:43:59.00174 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getGovernanceModeStatus
12/21-04:43:59.00174 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getGovernanceModeStatus
admin@avamar-server:/usr/local/avamar/var/mc/server_log/>:

admin@avamar-server:/usr/local/avamar/var/mc/server_log/>: grep "195983] com.avamar.mc.dpn.DPNProxyService.get" mcserver.log.0 | wc -l
56
admin@avamar-server:/usr/local/avamar/var/mc/server_log/>:

W pewnym środowisku znaleziono 3898 zdarzeń:

admin@avamar-server:/usr/local/avamar/var/mc/server_log/>: grep "12556] com.avamar.mc.dpn.DPNProxyService.get" mcserver.log.1 | wc -l
3898
admin@avamar-server:/usr/local/avamar/var/mc/server_log/>:

Innym objawem, który może wystąpić, jest niepowodzenie tworzenia kopii zapasowych niektórych obrazów VMware z kodem błędu 30902 (Activity failed — klient otrzymał zlecenie pracy, ale nie potwierdził jego otrzymania).

Baza danych mcdb pokazuje błąd po zastosowaniu poprawki 338748 (w tym przykładzie po 2024-02-06):

avmar-mcdb=# select recorded_date,count(status_code_summary) from v_activities_2 where recorded_date >= '2023-01-01%' and status_code_summary like '%client was given a workorder but did not acknowledge its receipt%' group by recorded_date order by recorded_date asc;
recorded_date | count
---------------+-------
2024-02-06    |     2
2024-02-07    |     9
2024-02-08    |     2
2024-02-11    |     1
2024-02-12    |    10

Cause

Dział inżynieryjny uznał za problem wadę Avamar AVAMAR-39020 — po zastosowaniu HF338748 utworzenie listy kopii zapasowych w celu rozwiązania tego problemu zajmuje trochę czasu.

Resolution

Pobierz najnowszą poprawkę 19.9 MCS. Do tego dnia (30 maja) 338802 jest najnowsza wersja poprawki MCS.

Aby pobrać poprawkę, zapoznaj się z sekcją "Wyszukiwanie poprawki z jej numerem" w artykule Avamar: Wyszukiwanie i pobieranie poprawek, poprawek, pakietów uaktualnień lub uaktualnień produktu z witryny pomocy technicznej firmy Dell.

Affected Products

Avamar, Avamar Server
Article Properties
Article Number: 000220715
Article Type: Solution
Last Modified: 16 Dec 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.