Авамар: Резервний список займає багато часу після застосування гарячого виправлення 19.9 MCS 338748

Summary: Після застосування гарячого виправлення 19.9 Management Console Server (MCS) 338748, відновлення резервних копій займає багато часу, і іноді це закінчується.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Підтверджіть, що поточна версія Avamar — 19.9 з гарячим виправленням 338748:

admin@avamar-server:~/>: mcserver.sh --version
  version:              19.9.0-78_HF338748
  build date:           Aug 22 2023 12:55:54
  PostgreSQL version:   postgres (PostgreSQL) 10.23
  db schema version:    19.8.0.1
  views schema version: 7.5.0.5
admin@avamar-server:~/>:

У наступному прикладі клієнт Avamar має 14 локальних резервних копій і 14 віддалених резервних копій.

Під час резервного копіювання в інтерфейсі користувача Avamar (AUI) або інтерфейсі адміністратора Avamar лог mcserver показує такі повідомлення: 

getImmutableBackupStatus
getGovernanceModeStatus
admin@avamar-server:/usr/local/avamar/var/mc/server_log/>: grep "195983] com.avamar.mc.dpn.DPNProxyService.get" mcserver.log.0
12/21-04:43:55.00773 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getImmutableBackupStatus
12/21-04:43:55.00773 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getImmutableBackupStatus
12/21-04:43:55.00892 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getGovernanceModeStatus
12/21-04:43:55.00892 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getGovernanceModeStatus
...
...
...
12/21-04:43:59.00055 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getImmutableBackupStatus
12/21-04:43:59.00055 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getImmutableBackupStatus
12/21-04:43:59.00174 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getGovernanceModeStatus
12/21-04:43:59.00174 [RMI TCP Connection(7810)-192.168.1.28#195983] com.avamar.mc.dpn.DPNProxyService.getGovernanceModeStatus
admin@avamar-server:/usr/local/avamar/var/mc/server_log/>:

admin@avamar-server:/usr/local/avamar/var/mc/server_log/>: grep "195983] com.avamar.mc.dpn.DPNProxyService.get" mcserver.log.0 | wc -l
56
admin@avamar-server:/usr/local/avamar/var/mc/server_log/>:

У деяких умовах було виявлено 3898 подій:

admin@avamar-server:/usr/local/avamar/var/mc/server_log/>: grep "12556] com.avamar.mc.dpn.DPNProxyService.get" mcserver.log.1 | wc -l
3898
admin@avamar-server:/usr/local/avamar/var/mc/server_log/>:

Ще один симптом, який може виникнути, — це невдача деяких резервних копій образів VMware з кодом помилки 30902 (Активність не виконала — клієнт отримав робоче замовлення, але не підтвердив отримання).

MCDB показує помилку після застосування гарячого 338748 (у цьому прикладі після 06.02.2024):

avmar-mcdb=# select recorded_date,count(status_code_summary) from v_activities_2 where recorded_date >= '2023-01-01%' and status_code_summary like '%client was given a workorder but did not acknowledge its receipt%' group by recorded_date order by recorded_date asc;
recorded_date | count
---------------+-------
2024-02-06    |     2
2024-02-07    |     9
2024-02-08    |     2
2024-02-11    |     1
2024-02-12    |    10

Cause

Інженерія визначила як проблему, і дефект Avamar AVAMAR-39020 — після застосування HF338748 потрібно час, щоб відкрити резервну копію для вирішення цієї проблеми.

Resolution

Завантажте останній хотфікс 19.9 MCS. До цієї дати (30 травня) остання версія хотфіксу MCS залишається 338802.

Щоб завантажити хотфікс, дивіться розділ «Шукаю хотфікс з його номером» у статті Avamar: Як знайти та завантажити гарячий виправ, патч, пакет для встановлення або оновлення продукту з сайту підтримки Dell.

Affected Products

Avamar, Avamar Server
Article Properties
Article Number: 000220715
Article Type: Solution
Last Modified: 16 Dec 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.