NVE: OS Rollup epäonnistuu "Yksi tai useampi solmu ei suorita SLES:iä", kun /root-omistajuus vaihtuu

Summary: NetWorker Virtual Edition (NVE) -käyttöjärjestelmän koonti epäonnistuu ja ilmoittaa, että vähintään yksi solmu ei toimi SLES:ssä. Tiedoston /root omistajuus siirtyi toiselle käyttäjälle. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker Virtual Edition -koonti epäonnistuu, ja saat seuraavan virheilmoituksen /usr/local/avamar/var/avi/server_data/package_data/NvePlatformOsRollup_YYYY-R#-v#.avp_EPOCH_TIMESTAMP/workflow.log

YYYY-MM-DD HH:mm:SS (-TZ) 4107124 INFO: no output seen from "ssh -q -i /root/.ssh/rootid -x -q -o ConnectTimeout=5 -o PasswordAuthentication=no -o StrictHostKeyChecking=no -o GSSAPIAuthentication=no  root@127.0.0.1  uname -a"
YYYY-MM-DD HH:mm:SS (-TZ) 4107124 INFO: post: "ssh -q -i /root/.ssh/rootid -x -q -o ConnectTimeout=5 -o PasswordAuthentication=no -o StrictHostKeyChecking=no -o GSSAPIAuthentication=no  root@127.0.0.1  uname -a", exit status=255 (error)
YYYY-MM-DD HH:mm:SS (-TZ) 4107124 INFO: address=127.0.0.1 remote=ssh -q -i /root/.ssh/rootid -x -q -o ConnectTimeout=5 -o PasswordAuthentication=no -o StrictHostKeyChecking=no -o GSSAPIAuthentication=no  root@127.0.0.1  os=unknown version=unknown update=unknown arch=unknown
YYYY-MM-DD HH:mm:SS (-TZ) 47378741877400 INFO:  - One or more nodes are not running SLES succeeded

OsRollup-työnkulun lokit löytyvät Rollups package_data hakemistosta:

/usr/local/avamar/var/avi/server_data/package_data/NvePlatformOsRollup_YYYY-R#-v#.avp_EPOCH_TIMESTAMP/workflow.log

Cause

Omistusoikeus /root Varmuuskopioinnin järjestelmänvalvoja on muuttanut hakemistoa jossain vaiheessa. Se näyttää esimerkiksi:

nve:~ # ls -ld /root
drwx------   8 admin  root    4096 May 16 09:27 root

Käyttöoikeudet /root ovat sellaisia, että millään muulla käyttäjällä tai ryhmällä ei ole pääsyä hakemistoon, vain omistajalla (tässä tapauksessa järjestelmänvalvojalla) on.

Koonnin aikana suoritetaan seuraava komento:

ssh -q -i /root/.ssh/rootid -x -q -o ConnectTimeout=5 -o PasswordAuthentication=no -o StrictHostKeyChecking=no -o GSSAPIAuthentication=no root@127.0.0.1 uname -a

Se yrittää suorittaa as_root, mutta koska vain järjestelmänvalvojakäyttäjällä on käyttöoikeus, komento ei palauta mitään ja ohittaa ytimen päivityksen. Esimerkki:

nve:~ # ssh -q -i /root/.ssh/rootid -x -q -o ConnectTimeout=5 -o PasswordAuthentication=no -o StrictHostKeyChecking=no -o GSSAPIAuthentication=no root@127.0.0.1 uname -a
nve:~ # 

Aika /root on omistaja root:root että sen pitäisi palauttaa jotain:

nve:~ # ssh -q -i /root/.ssh/rootid -x -q -o ConnectTimeout=5 -o PasswordAuthentication=no -o StrictHostKeyChecking=no -o GSSAPIAuthentication=no root@127.0.0.1 uname -a
Linux nve 4.12.14-122.153-default #1 SMP Tue Mar 7 14:13:19 UTC 2023 (9f7af45) x86_64 x86_64 x86_64 GNU/Linux
nve:~ #

Jos /root jonka omistaa toinen käyttäjä, ssh Komento saada uname -a ei palauta mitään, jolloin työnkulku ilmoittaa käyttöjärjestelmän "tuntemattomaksi" ja ohittaa NVE:n käyttöjärjestelmäpakettipäivitykset.

HUOMAUTUS: Tämä ei ole ainoa syy tässä tietämyskannan artikkelissa kuvattuun ongelmaan, katso lisätietoja. Tämän artikkelin painopiste on ratkaisu tässä kuvattuun erityiseen syyhyn.

Resolution

Korjaa /root omistus:

sudo chown root:root /root

Palaa NVE:n asennuksenhallintaan ja yritä nykyistä tehtävää uudelleen.

HUOMAUTUS: Pääkäyttäjällä ja -ryhmällä on oltava /root hakemisto. Järjestelmän oletustiedostojen ja -asetusten muokkaaminen NVE:ssä voi aiheuttaa ongelmia koontien/päivitysten aikana, saattaa vioittaa NVE:tä ja edellyttää uudelleenkäyttöönottoa ja NetWorker Server Disaster Recoverya (nsrdr). Siksi ei ole suositeltavaa muuttaa järjestelmän oletustiedostoja tai -asetuksia.

Jos haluat sallia SSH-pääsyn root-käyttäjään, katso: NVE: SSH-root-käytön salliminen NetWorker Virtual Editionissa

Additional Information

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000225150
Article Type: Solution
Last Modified: 04 Dec 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.