NVE: OS-pakke mislykkes "En eller flere noder kører ikke SLES", når /root-ejerskabet ændres

Summary: En operativsystempakke til NetWorker Virtual Edition (NVE) mislykkes og rapporterer "En eller flere noder kører ikke SLES". Ejerskabet af /root blev ændret til en anden bruger.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker Virtual Edition-opdateringspakken mislykkes med følgende fejl rapporteret i /usr/local/avamar/var/avi/server_data/package_data/NvePlatformOsRollup_YYYY-R#-v#.avp_EPOCH_TIMESTAMP/workflow.log

YYYY-MM-DD HH:mm:SS (-TZ) 4107124 INFO: no output seen from "ssh -q -i /root/.ssh/rootid -x -q -o ConnectTimeout=5 -o PasswordAuthentication=no -o StrictHostKeyChecking=no -o GSSAPIAuthentication=no  root@127.0.0.1  uname -a"
YYYY-MM-DD HH:mm:SS (-TZ) 4107124 INFO: post: "ssh -q -i /root/.ssh/rootid -x -q -o ConnectTimeout=5 -o PasswordAuthentication=no -o StrictHostKeyChecking=no -o GSSAPIAuthentication=no  root@127.0.0.1  uname -a", exit status=255 (error)
YYYY-MM-DD HH:mm:SS (-TZ) 4107124 INFO: address=127.0.0.1 remote=ssh -q -i /root/.ssh/rootid -x -q -o ConnectTimeout=5 -o PasswordAuthentication=no -o StrictHostKeyChecking=no -o GSSAPIAuthentication=no  root@127.0.0.1  os=unknown version=unknown update=unknown arch=unknown
YYYY-MM-DD HH:mm:SS (-TZ) 47378741877400 INFO:  - One or more nodes are not running SLES succeeded

Du kan finde logfilerne for OsRollup-arbejdsgange under opdateringspakkerne package_data mappe:

/usr/local/avamar/var/avi/server_data/package_data/NvePlatformOsRollup_YYYY-R#-v#.avp_EPOCH_TIMESTAMP/workflow.log

Cause

Ejerskabet af /root Mappen blev ændret af backupadministratoren på et tidspunkt. For eksempel viser det:

nve:~ # ls -ld /root
drwx------   8 admin  root    4096 May 16 09:27 root

Tilladelserne til /root er som sådan, at ingen anden bruger eller gruppe har adgang til biblioteket, kun ejeren (i dette tilfælde admin) har.

Under opdateringspakken køres følgende kommando:

ssh -q -i /root/.ssh/rootid -x -q -o ConnectTimeout=5 -o PasswordAuthentication=no -o StrictHostKeyChecking=no -o GSSAPIAuthentication=no root@127.0.0.1 uname -a

Det forsøger at køre as_root, men da kun administratorbrugeren har adgang, returnerer kommandoen intet og springer kerneopdateringen over. F.eks.:

nve:~ # ssh -q -i /root/.ssh/rootid -x -q -o ConnectTimeout=5 -o PasswordAuthentication=no -o StrictHostKeyChecking=no -o GSSAPIAuthentication=no root@127.0.0.1 uname -a
nve:~ # 

Hvornår /root er ejet af root:root at det skal returnere noget som:

nve:~ # ssh -q -i /root/.ssh/rootid -x -q -o ConnectTimeout=5 -o PasswordAuthentication=no -o StrictHostKeyChecking=no -o GSSAPIAuthentication=no root@127.0.0.1 uname -a
Linux nve 4.12.14-122.153-default #1 SMP Tue Mar 7 14:13:19 UTC 2023 (9f7af45) x86_64 x86_64 x86_64 GNU/Linux
nve:~ #

Hvis /root ejes af en anden bruger, ssh kommando for at få uname -a returnerer intet, hvilket får arbejdsgangen til at rapportere operativsystemet som "ukendt" og springe NVE's OS-pakkeopdateringer over.

BEMÆRK: Dette er ikke den eneste årsag til den fejl, der er beskrevet i denne KB, se Yderligere oplysninger. Fokus i denne artikel er løsningen på den specifikke årsag, der er skitseret her.

Resolution

Ret /root ejerskab:

sudo chown root:root /root

Gå tilbage til NVE Installation Manager, og prøv den aktuelle opgave igen.

BEMÆRK: "Rod"-brugeren og -gruppen skal eje /root mappe. Ændring af standardsystemfiler og -indstillinger på NVE kan forårsage problemer under akkumuleringer/opgraderinger, potentielt ødelægge NVE og kræve geninstallation og NetWorker Server-genoprettelse efter nedbrud (nsrdr). Derfor anbefales det ikke at ændre standard systemfiler eller indstillinger.

For at tillade SSH-adgang til roden, se: NVE: Sådan tillader du SSH-rodadgang på en NetWorker Virtual Edition

Additional Information

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000225150
Article Type: Solution
Last Modified: 04 Dec 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.