NVE: NetWorker Installation Manager no muestra historial

Summary: Se puede acceder a NetWorker Virtual Edition (NVE) Installation Manager desde un navegador web; Sin embargo, la pestaña Historial no muestra ningún contenido.

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Symptoms

Hay varios síntomas, se puede observar una combinación o todos.

  • NetWorker Installation Manager aparece como "Avamar Installation Manager".
  • El intento de cargar un paquete de actualización de NVE (AVP) en el repositorio arroja un error "Sysinfo no válido".
  • NetWorker Installation Manager no muestra contenido en la pestaña History. 
    Administrador de instalación de NVE 

También puede recibir una alerta que dice "Server is not responding. You are now logged out of the Installation Manager" y se redirigen de nuevo a la página predeterminada.

NetWorker Server está operativo. No hay impacto en las operaciones de protección de datos, solo el administrador de instalación no muestra el historial de instalación de NVE.

Cause

El avidb se corrompió. Hay muchas causas potenciales para problemas de espacio, problemas de actualización y acciones del usuario que pueden provocar esto. El enfoque de este artículo de la base de conocimientos es recuperar la funcionalidad.

Resolution

  1. Abra una sesión de SSH en el NVE e inicie sesión como administrador y, a continuación, cambie a root: sudo su -
  2. Antes de continuar, asegúrese de que no se observen problemas de espacio en el NVE. El avidb se encuentra en el punto de montaje /space:

df -h

df -h /usr/local/avamar/var/avi/server_data

Si algún volumen está cerca del 100 % de la capacidad. Se debe recuperar espacio antes de recuperar avidb

  1. Valide si avidb Los respaldos están disponibles: mminfo -avot -q client=NVER-SERVER-NAME,name=/usr/local/avamar/var/avi/server_data
NOTA: Reemplace NVE-SERVER-NAME por el nombre del cliente de NetWorker del NVE. Por ejemplo, si el cliente NVE utiliza un nombre de dominio calificado (FQDN), úselo. Si el cliente NVE utiliza un nombre corto, úselo en su lugar. El nombre del cliente es visible desde NetWorker Management Console (NMC) o la interfaz de usuario web de NetWorker (NWUI) en Protection-Clients>.

Ejemplo del mensaje de salida:

azure-nve:~ # mminfo -avot -q client=azure-nve.local,name=/usr/local/avamar/var/avi/server_data
 volume        type   client           date     time         size ssid      fl   lvl name
....
azure_nve.local.dddefault.002 Data Domain azure-nve.local 11/09/25 17:30:05 2868 KB 3977319918 cb full /usr/local/avamar/var/avi/server_data
PRECAUCIÓN: Solo es posible recuperar avidb si está ejecutando trabajos de respaldo de Server Protection-NVE> Server. Esta es una política predeterminada en las NVE; Sin embargo, el administrador de respaldos debe mantener los respaldos y ponerlos a disposición. Sin estos respaldos, no es posible recuperar avidb.
  1. Detenga el proceso de avinstaller: avinstaller.pl --stop
  2. Asegúrese de que el proceso se haya detenido: avinstaller.pl --test
  3. Cambie el nombre del avidb actual si existe: mv /usr/local/avamar/var/avi/server_data/avidb /usr/local/avamar/avidb_$(date -I).bak
  4. Inicie sesión en NetWorker Management Console (NMC) o en la interfaz de usuario web de NetWorker (NWUI) para recuperar el avidb.
    1. Vaya a la pestaña Recuperar e inicie la recuperación.
    2. Ingrese el nombre del cliente NVE.
    3. Seleccione una fecha y, a continuación, seleccione la opción /space/avamar/var/avi/server_data/ y, a continuación, seleccione la carpeta avidb de NetWorker.
      Selección del saveset de avidb 
    NOTA: Asegúrese de seleccionar una fecha de "último trabajo conocida". Si no se conoce una fecha específica, seleccione una fecha anterior a cuando apareció el problema sospechoso. En este artículo puedes ver tanto /usr/local/avamar/var/avi/server_data/avidb y /space/avamar/var/avi/server_data/avidb Referencia. El NVE utiliza enlaces simbólicos y la ruta /usr se monta en /space.
    1. Seleccione las opciones para recuperar a la ruta original y sobrescribir el archivo existente:
      Sobrescribir archivo existente 
    2. Asigne un nombre e inicie el restaurador:

Restaurar Sistema

  1. Monitoree la restauración. La restauración debe mostrar que se realizó correctamente:

Sesión de restauración

  1. Inicie avinstaller: avinstaller.pl --start
  2. Asegúrese de que avinstaller esté ejecutando lo siguiente: avinstaller.pl --test
  3. Inicie sesión en la página web de NetWorker Installation Manager y vaya a la pestaña History. Se muestra el historial de actualización de NVE (hasta el punto de recuperación de avidb):

Administrador de instalación de NVE

NOTA: La pestaña History no mostrará ningún paquete que se haya instalado después de la fecha a partir de la cual el avidb se recuperó; Sin embargo, los paquetes que se han instalado correctamente no se eliminan. Si intenta instalar el paquete nuevamente, se mostrará "Ya instalado". El historial de actualización de NVE también se puede encontrar en /usr/local/avamar/var/avi/server_data/package_data/.

Additional Information

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000390175
Article Type: Solution
Last Modified: 13 Nov 2025
Version:  4
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