Tabela zdarzeń interfejsu użytkownika Avamar wyświetla błędy jądra związane z operacją uruchomienia ConnectEMC

Summary: Ten artykuł zawiera informacje na temat sytuacji, w których interfejs użytkownika Avamar wyświetla błędy jądra związane z uruchomieniem ConnectEMC.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Po zainstalowaniu przez użytkownika pakietu zbiorczego zabezpieczeń systemu operacyjnego 2021 R3 na serwerach Avamar w wersji 19.3 lub nowszej z systemem operacyjnym SLES12SP5 interfejs użytkownika Avamar wyświetla błędy jądra związane z niepowodzeniem uruchomienia ConnectEMC w tabeli Zdarzenia. Dzieje się tak, jeśli ustawienia poczty e-mail nie są skonfigurowane w urządzeniu.

W tabeli zdarzeń interfejsu użytkownika Avamar wyświetlane są błędy uruchamiania ConnectEMC, takie jak następujące:

kernel: [86242.549021] traps: connectemc[15298] general protection ip:f762cae7 sp:ffdd6b54 error:0 in libstdc++.so.6.0.29

 

Cause

Po uaktualnieniu urządzenia do wersji 2.7.2 węzły serwera Avamar mają zainstalowaną wersję SLES12 SP5 z pakietem zbiorczym zabezpieczeń systemu operacyjnego 2021 R3. Ze względu na zaktualizowane pliki binarne systemu operacyjnego ConnectEMC napotka problem z uruchomieniem, jeśli /opt/connectemc/ConnectEMC_config.xml plik konfiguracyjny ma puste wartości lub nawet puste spacje dla EmailSender i EmailServer Parametry.
Na przykład w przykładowym pliku poniżej: EmailSender i EmailServer nie są skonfigurowane z wartościami, co więcej, ma puste miejsce.

 

cat /opt/connectemc/ConnectEMC_config.xml
<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<ConnectEMCConfig SchemaVersion="1.1.0">

  <ConnectConfig Type="Email">
    <Retries>5</Retries>
    <Notification>Primary</Notification>
    <Timeout>300</Timeout>
    <Description>Avamar ConnectEMC Notification Email</Description>
    <BsafeEncrypt>yes</BsafeEncrypt>
    <IPProtocol>IPV4</IPProtocol>
    <EmailServer> </EmailServer>
    <EmailAddress>emailalert@emc.com</EmailAddress>
    <EmailSender> </EmailSender>
    <EmailFormat>ASCII</EmailFormat>
    <EmailSubject>Avamar ConnectEMC Notification Email</EmailSubject>
    <STARTTLS>no</STARTTLS>
    <IncludeCallHomeData>no</IncludeCallHomeData>

 

Stwierdzono, że jeśli ustawienia powiadomień e-mail nie są skonfigurowane na urządzeniu, EmailServer i EmailSender pola w ConnectEMC_config.xml plik konfiguracyjny na serwerze Avamar jest skonfigurowany z pojedynczymi pustymi spacjami dla obu pól.

 

Resolution

Skonfiguruj konfigurację connectemc, postępując według instrukcji administracyjnych Avamar LUB ręcznie wyzerowując ConnectEMC_config.xml plik konfiguracyjny (opróżnij plik konfiguracyjny) na serwerze Avamar.

 

  1. Skonfiguruj ustawienia powiadomień e-mail, postępując według instrukcji administracyjnych Avamar

Wykonaj szczegółowe czynności opisane w rozdziale "Monitorowanie serwera" w sekcji "ConnectEMC".

 

  1. Kroki zerowania konfiguracji (opróżnianie pliku konfiguracyjnego):

Jeśli nie chcesz konfigurować powiadomień e-mail, musisz ręcznie wyzerować ConnectEMC_config.xml plik konfiguracyjny (opróżnij plik konfiguracyjny) na serwerze Avamar, wykonując następujące czynności:

  1. Połącz się z Avamar za pomocą SSH z kontem administratora.
  2. Przełącz się na konto użytkownika root.
  3. Zmień nazwę bieżącego pliku konfiguracyjnego.
mv /opt/connectemc/ConnectEMC_config.xml /opt/connectemc/ConnectEMC_config.xml.orig

 

  1. Utwórz plik konfiguracyjny bez wartości.
touch /opt/connectemc/ConnectEMC_config.xml

 

  1. Sprawdź, czy plik konfiguracyjny jest pusty.
ls -latr /opt/connectemc/ConnectEMC_config.xml
-rw-rw-r-- 1 root admin 0 Feb  7 22:36 ConnectEMC_config.xml

 

  1. Uruchom ponownie usługę ConnectEMC przy użyciu następujących poleceń:
service connectemc stop
service connectemc start

 

Affected Products

Avamar, Avamar Server
Article Properties
Article Number: 000198174
Article Type: Solution
Last Modified: 10 Feb 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.