Le tableau des événements de l’interface utilisateur Avamar affiche les erreurs de noyau liées à l’opération de démarrage de ConnectEMC
Summary: Cet article fournit la résolution lorsque l’interface utilisateur Avamar affiche des erreurs de noyau liées à l’opération de démarrage de ConnectEMC.
Symptoms
Après qu’un utilisateur a installé 2021 R3 OS Security Rollup sur des serveurs Avamar exécutant la version 19.3 et versions ultérieures avec SLES12SP5 système d’exploitation, l’interface utilisateur Avamar affiche les erreurs de noyau liées à l’échec de l’opération de démarrage de ConnectEMC dans le tableau Événements. Cela se produit si les paramètres d’e-mail ne sont pas configurés dans l’appliance.
Le tableau des événements de l’interface utilisateur Avamar affiche les erreurs de démarrage de ConnectEMC comme suit :
kernel: [86242.549021] traps: connectemc[15298] general protection ip:f762cae7 sp:ffdd6b54 error:0 in libstdc++.so.6.0.29
Cause
Après une mise à niveau de l’utilisateur vers la version 2.7.2 de l’appliance, les nœuds de serveur Avamar sont équipés de SLES12 SP5 avec le rollup de sécurité du système d’exploitation R3 2021 installé. En raison des fichiers binaires du système d’exploitation mis à jour, ConnectEMC rencontre un problème de démarrage si le /opt/connectemc/ConnectEMC_config.xml le fichier de configuration a des valeurs vides ou même des espaces vides pour le EmailSender et EmailServer Paramètres.
Par exemple, dans l’exemple de fichier ci-dessous, le EmailSender et EmailServer ne sont pas configurés avec des valeurs, en outre, il dispose d’un espace vide.
cat /opt/connectemc/ConnectEMC_config.xml
<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<ConnectEMCConfig SchemaVersion="1.1.0">
<ConnectConfig Type="Email">
<Retries>5</Retries>
<Notification>Primary</Notification>
<Timeout>300</Timeout>
<Description>Avamar ConnectEMC Notification Email</Description>
<BsafeEncrypt>yes</BsafeEncrypt>
<IPProtocol>IPV4</IPProtocol>
<EmailServer> </EmailServer>
<EmailAddress>emailalert@emc.com</EmailAddress>
<EmailSender> </EmailSender>
<EmailFormat>ASCII</EmailFormat>
<EmailSubject>Avamar ConnectEMC Notification Email</EmailSubject>
<STARTTLS>no</STARTTLS>
<IncludeCallHomeData>no</IncludeCallHomeData>
Il est observé que si les paramètres de notification par e-mail ne sont pas configurés sur l’appliance, le EmailServer et EmailSender champs du ConnectEMC_config.xml le fichier de configuration sur le serveur Avamar est configuré avec des espaces vides uniques pour les deux champs.
Resolution
Configurez la configuration connectemc en suivant le guide d’administration Avamar OU en supprimant manuellement le ConnectEMC_config.xml fichier de configuration (vide le fichier de configuration) sur le serveur Avamar.
- Configurer les paramètres de notification par e-mail en suivant le guide d’administration Avamar
Suivez les étapes détaillées décrites dans le chapitre intitulé « Surveillance des serveurs » sous la section « ConnectEMC ».
- Étapes à suivre pour remettre à zéro la configuration (vider le fichier de configuration) :
Si vous ne souhaitez pas configurer les notifications par e-mail, vous devez supprimer manuellement le ConnectEMC_config.xml fichier de configuration (vide le fichier de configuration) sur le serveur Avamar en suivant les étapes ci-dessous :
- Connectez-vous à Avamar à l’aide de SSH avec un compte administrateur.
- Basculez vers le compte de l'utilisateur root.
- Renommez le fichier de configuration actuel.
mv /opt/connectemc/ConnectEMC_config.xml /opt/connectemc/ConnectEMC_config.xml.orig
- Créez un fichier de configuration qui ne contient aucune valeur.
touch /opt/connectemc/ConnectEMC_config.xml
- Vérifiez que le fichier de configuration est vide.
ls -latr /opt/connectemc/ConnectEMC_config.xml -rw-rw-r-- 1 root admin 0 Feb 7 22:36 ConnectEMC_config.xml
- Redémarrez le service ConnectEMC à l'aide des commandes suivantes :
service connectemc stop service connectemc start