NVP-vProxy: Il ripristino della macchina virtuale viene contrassegnato come riuscito, ma la macchina virtuale non si avvia con l'errore: Sistema operativo mancante

Summary: Il restore della macchina virtuale (VM) vProxy di NetWorker VMware Protection (NVP) è stato completato correttamente. La macchina virtuale ripristinata non si avvia con l'errore: Sistema operativo mancante ...

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Symptoms

La soluzione NetWorker VMware Protection (NVP) vProxy viene utilizzata per eseguire i backup delle VM. Una VM viene ripristinata utilizzando i metodi di accesso istantaneo o ripristino della macchina virtuale, il ripristino viene contrassegnato come riuscito. 

Tuttavia, quando viene visualizzata in VMware Infrastructure Client o vSphere Web Client, la macchina virtuale non utilizza la quantità di storage prevista. La VM ripristinata non si avvia all'accensione e mostra il seguente messaggio nella finestra della console VMware:

SISTEMA OPERATIVO MANCANTE
 
NetWorker vProxy, la console VMware e i registri non mostrano errori o avvisi. Il backup e il ripristino di questa macchina virtuale sono stati completati correttamente.

Lo stesso comportamento può essere osservato se viene eseguito un ripristino del disco virtuale. Anche se la macchina virtuale in cui è stato ripristinato il disco potrebbe continuare a funzionare, il disco ripristinato è danneggiato e inaccessibile.

Cause

Il saveset di backup usato per il ripristino è incompleto a causa di file CBT (Change Block Tracking) danneggiati per questa VM. Uno o più file CTK (Change Tracking) danneggiati non sono stati rimossi quando CBT è stato reimpostato.

Resolution

Il seguente articolo della Knowledge Base di VMware descrive come reimpostare il tracciamento dei blocchi modificati su una macchina virtuale.

Reimpostazione del tracciamento dei blocchi modificati per le macchine virtuali VMware vSphere (2139574)Questo link ipertestuale indirizza a un sito web esterno a Dell Technologies.

NOTA:  Una volta disabilitato CBT, accedere all host ESXi e verificare che non vi siano file CTK rimanenti nella cartella del datastore delle VM. Seguire quindi la procedura descritta nell'articolo della Knowledge Base per riabilitare CBT sulla VM.

Additional Information

Un problema simile può essere osservato se la macchina virtuale vProxy è stata spostata tramite vMotion da VMware Distributed Resource Scheduler (DRS) durante la sessione di ripristino: NetWorker: Il ripristino della macchina virtuale non viene completato e il disco della macchina virtuale viene rimosso o ripristinato come unità vuota

 

Durante una sessione di restore, i dischi della VM vengono collegati alla VM vProxy fino al completamento della sessione di ripristino. In questo scenario, durante il ripristino viene eseguito vMotion dalla macchina virtuale vProxy da parte delle impostazioni DRS di VMware. Quando la VM vProxy è vMotion, assume la proprietà di uno qualsiasi dei dischi ad essa collegati. La VM vProxy contiene più di due dischi; i dischi aggiuntivi collegati al vProxy appartengono alla VM a cui mancano i dischi dopo il restore. Si tratta di un comportamento previsto con VMware vMotion. L'articolo della KB precedente descrive come valutare e risolvere questo scenario.

Affected Products

NetWorker
Article Properties
Article Number: 000033987
Article Type: Solution
Last Modified: 12 Aug 2025
Version:  5
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