AppSync: Kan ikke kjøre serviceplan fordi den allerede pågår i en annen prosess.
Summary: Brukere kan av og til oppdage at en serviceplan ikke kjører med feilen: Kan ikke kjøre serviceplan DB47 fordi den allerede pågår i en annen prosess.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Når en bruker kjører en serviceplan, mottas følgende melding:
Server log:
Cannot run service plan DB47 because it is already in progress in another process
Utdata for AppSync-hendelse:
Application-Discovery TSK_000002 <server name> Cannot run service plan DB47 because it is already in progress in another process
02-07-2017 06:00:02.583 ERROR [ServicePlanBrokerCommandBean] Task Collision Object Found: <task> <id>6fd9f120-5b5e-4b0e-a130-8db604dce4a0</id> <lastModified>1486257365027</lastModified> <lastModifiedFormatted>Sun 02/05/2017 10:16:05 AM</lastModifiedFormatted> <collisionImmune>false</collisionImmune> <dsNames>DB47 </dsNames> <ids>68a77214-fdb2-4480-a976-57b1d928e0a6</ids> <numApps>1</numApps> <operation>mapping</operation> <phaseName>Application-Mapping</phaseName> <phaseType>mapping</phaseType> <phasepitId>c98ec955-09eb-4f3e-b7ae-9da121e4988f</phasepitId> <spId>e340e196-5dc0-4d1c-920c-a20d266b7308</spId> <spName>DB47</spName> </task> 02-07-2017 06:00:02.661 INFO [EventServiceBean] EVENT [TSK_000002]: Cannot run service plan DB47 because it is already in progress in another process(METADATA: TYPE-ERROR, TIME-2017-02-07
Cause
Det kan se ut til at en AppSync-jobb slutter å svare av flere årsaker, både internt i AppSync-serveren og eksternt.
Interne årsaker kan omfatte (men er ikke begrenset til) stor CPU-belastning (overstiger 85 %) mens en serviceplan kjører, eller en omstart av AppSync-serveren under kjøring av en serviceplan.
Eksterne årsaker kan omfatte (men igjen er de ikke begrenset til) et brukerskript slutter å svare, noe som fører til at AppSync-serviceplanen slutter å svare mens den venter på at skriptet skal fullføres. Eller en AppSync-klient kan slutte å svare eller svare tregt, noe som resulterer i at serviceplanen tilsynelatende slutter å svare.
Interne årsaker kan omfatte (men er ikke begrenset til) stor CPU-belastning (overstiger 85 %) mens en serviceplan kjører, eller en omstart av AppSync-serveren under kjøring av en serviceplan.
Eksterne årsaker kan omfatte (men igjen er de ikke begrenset til) et brukerskript slutter å svare, noe som fører til at AppSync-serviceplanen slutter å svare mens den venter på at skriptet skal fullføres. Eller en AppSync-klient kan slutte å svare eller svare tregt, noe som resulterer i at serviceplanen tilsynelatende slutter å svare.
Viktig merknad: Det bør iverksettes tiltak for å bekrefte årsaken til serviceplanen er utilgjengelig, og løse dette før du prøver løsningen nedenfor. Gjennomgang av AppSync-hendelser og Server.log kan indikere hvor en bestemt serviceplan er sluttet å svare. Hvis for eksempel en siste hendelse i en serviceplankjøring ser ut som i eksemplet nedenfor, kan det hende at et brukerskript slutter å svare. Hvis du stopper skriptet på verten som kjører det, kan AppSync Service-planen fullføres.
2021-01-22 11:17:24.655,Post-mount script,5d6fd237-81dd-4d4b-97d4-055c3280dfa7,RSC_000007,hostname,User script results: Elapsed: 00:00:00.01
Resolution
Omgåelse av problemet:
Metoden nedenfor er tilgjengelig for å løse problemet. Hvis du er usikker på om du vil utføre denne midlertidige løsningen, eller hvis denne midlertidige løsningen ikke løser problemet, kan du kontakte Dells kundestøtte for å få hjelp.
Metoden nedenfor er tilgjengelig for å løse problemet. Hvis du er usikker på om du vil utføre denne midlertidige løsningen, eller hvis denne midlertidige løsningen ikke løser problemet, kan du kontakte Dells kundestøtte for å få hjelp.
- Sjekk instrumentbordet i AppSync-brukergrensesnittet for å bekrefte at bare serviceplanen som har sluttet å svare, kjører.
- Stopp AppSync-servertjenesten.
- Stopp AppSync Datastore-tjenesten.
- Flytt innholdet i
C:\EMC\AppSync\jboss\standalone\tmp\vfstil en annen mappe (den kan slettes senere). - Forlat mappen
C:\EMC\AppSync\jboss\standalone\tmp\vfsIntakt, men tom. - Start Datastore-tjenesten.
- Start AppSync Server-tjenesten.
Article Properties
Article Number: 000057134
Article Type: Solution
Last Modified: 18 Sept 2025
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.