AppSync: Zaten başka bir işlemde devam ettiği için hizmet planı çalıştırılamıyor.

Summary: Kullanıcılar zaman zaman bir Servis Planının şu hatayla çalıştırılamadığını görebilir: Başka bir işlemde devam ettiği için DB47 hizmet planı çalıştırılamıyor.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Kullanıcı bir hizmet planı çalıştırdığında aşağıdaki ileti alınır:
Cannot run service plan DB47 because it is already in progress in another process
 
AppSync Olay çıktısı:
Application-Discovery    TSK_000002    <server name>    Cannot run service plan DB47 because it is already in progress in another process
 
Sunucu günlüğü:
02-07-2017 06:00:02.583 ERROR [ServicePlanBrokerCommandBean] Task Collision Object Found:
 <task>
    <id>6fd9f120-5b5e-4b0e-a130-8db604dce4a0</id>
    <lastModified>1486257365027</lastModified>
    <lastModifiedFormatted>Sun 02/05/2017 10:16:05 AM</lastModifiedFormatted>
    <collisionImmune>false</collisionImmune>
    <dsNames>DB47 </dsNames>
    <ids>68a77214-fdb2-4480-a976-57b1d928e0a6</ids>
    <numApps>1</numApps>
    <operation>mapping</operation>
    <phaseName>Application-Mapping</phaseName>
    <phaseType>mapping</phaseType>
    <phasepitId>c98ec955-09eb-4f3e-b7ae-9da121e4988f</phasepitId>
    <spId>e340e196-5dc0-4d1c-920c-a20d266b7308</spId>
    <spName>DB47</spName>
</task>
02-07-2017 06:00:02.661 INFO [EventServiceBean] EVENT [TSK_000002]: Cannot run service plan DB47 because it is already in progress in another process(METADATA: TYPE-ERROR, TIME-2017-02-07

Cause

Bir AppSync işi, hem AppSync sunucusunun dahili hem de harici birçok nedeni nedeniyle yanıt vermiyor gibi görünebilir.

Dahili nedenler arasında, bir servis planı çalışırken ağır CPU yükü (%85'in üzerinde) veya bir servis planı çalışırken AppSync sunucusunun yeniden başlatılması sayılabilir (%85'in üzerinde) ve bu sebepler arasında bunlarla sınırlı değildir.

Harici nedenler arasında bir kullanıcı komut dosyasının yanıt vermeyi durdurması ve komut dosyasının tamamlanmasını beklerken AppSync Servis Planının yanıt vermeyi durdurması sayılabilir (ancak yine bunlarla sınırlı değildir). Alternatif olarak, bir AppSync istemcisi yanıt vermeyi durdurabilir veya yavaş yanıt verebilir, bu da Servis Planının belirgin bir şekilde yanıt vermemesine neden olabilir. 
 
Önemli Not: Aşağıdaki Geçici Çözümü denemeden önce Servis Planının kullanılamaması nedenini doğrulamak ve sorunu çözmek için adımlar atılmalıdır. AppSync Olaylarını ve Server.log gözden geçirmek, belirli bir Servis Planının yanıt vermesinin nerede durduğunu gösterebilir. Örneğin, bir Servis Planı çalışmasındaki son olay aşağıdaki örnekteki gibi görünüyorsa, bir kullanıcı komut dosyası yanıt vermeyi durdurabilir. Komut dosyasını çalıştıran ana bilgisayarda durdurmak, AppSync Servis planının tamamlanmasına izin verebilir.
2021-01-22 11:17:24.655,Post-mount script,5d6fd237-81dd-4d4b-97d4-055c3280dfa7,RSC_000007,hostname,User script results: Elapsed: 00:00:00.01

Resolution

Geçici Çözüm:     
Sorunu çözmek için aşağıdaki yöntem kullanılabilir. Bu geçici çözümü uygulayıp uygulamadığınızdan emin değilseniz veya bu geçici çözüm sorunu çözmezse yardım için Dell Müşteri Desteği ile iletişime geçin.
  1. Yalnızca durdurulmuş yanıt veren servis planının çalıştığını doğrulamak için AppSync kullanıcı arayüzündeki Panoyu kontrol edin.
  2. AppSync sunucu hizmetini durdurun.
  3. AppSync Veri Deposu hizmetini durdurun.
  4. İçeriğini taşıyınC:\EMC\AppSync\jboss\standalone\tmp\vfs başka bir klasöre (daha sonra silinebilir).
  5. Klasörden ayrılma C:\EMC\AppSync\jboss\standalone\tmp\vfs sağlam ama boş.
  6. Veri deposu hizmetini başlatın.
  7. AppSync Sunucusu hizmetini başlatın.
Article Properties
Article Number: 000057134
Article Type: Solution
Last Modified: 18 Sept 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.