Kaby Lake Systems with USB Type-C DP Only (non-Thunderbolt) Connections Using WD15 or DS1000 May Have Blanking External Video
Summary: This article explains what to do if your Latitude system shows blank or flickering video on external monitors connected using a USB-C DisplayPort (DP) Adapter.
Symptoms
If you are using a Kaby Lake-based system with USB Type-C DisplayPort (non-Thunderbolt) connections and a WD15 or DS1000 dock, it may happen that your external monitors are blanking or flashing. This may only occur when a hardwired network connection is attached to the dock.
Cause
Current List of systems this might occur on
- Latitude 7x80 (non-Thunderbolt configuration)
- Latitude 5x80 (non-Thunderbolt configuration)
- Latitude 5289 and 7389
Resolution
Verify that the Firmware Update version 1.0.0.8 is installed. This firmware is not the solution to the problem but must be updated for Kaby Lake systems. It is available on the Drivers and Download Website of the applicable systems and the WD15 download section.
There are two options available as a solution for this problem. You can either download the latest Realtek USB GBE Ethernet Controller Firmware Utility from the Drivers and Download Website or follow the manual steps below. These two options disable Selective Suspend for the Ethernet Adapter.
Manual steps (Figure 1):
-
Open the Device Manager (right-click the Windows Button and click Device Manager)
-
Expand the category Network Adapters
-
Right-click the Realtek USB GbE Family Controller and select properties
-
Click the Advanced tab
-
Select "Selective suspend" in the menu and set the Value to "DISABLED."
-
Press OK and reboot the system.

Figure 1: Steps to disable Selective Suspend.