AppSync: Support for Oracle 18.x and 19.x

Summary: AppSync Oracle Support.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Oracle version replicated was: 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5, or 19.6.

AppSync fails to protect Oracle versions 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5, or 19.6.

AppSync event log:
 
ServicePlanName: PROD-ABCD,ApplicationType:oracle
Resource involved at discovery phase are:
Production host Name PROD Version :Red Hat Enterprise Linux 7.7
OracleDatabase : ABCD , RAC : true , ASM : true
OracleInstance : ABCD2 , Version : 19.6.0.0.0
 
Application discovery, Error occurred during the execution of service plan PROD-ABCD
Application discovery, There are no datasets eligible to be copied in the PROD-ABCD service plan.
Application discovery, Application discovery phase for ABCD completed with errors
Application discovery, During discovery, AppSync detected that the following database(s) were offline: ABCD. As a result, they will not be available for protection.

AppSync Server log:
 
02-20-2020 15:50:18.954 INFO ->>> String response: <ir_message ir_requestId="00000" ir_sessionId="00000" ir_status="0" ir_type="ArchwayRequest" master_id="0" phaseName="" pollMode="SYNC" taskId="0" timeToWait="0"><operation><agent>Oracle</agent><command>getDatabaseInstance</command><parameters><parameter><paramName>databaseId</paramName><paramValue>2673940419</paramValue></parameter>
<parameter><paramName>databaseName</paramName><paramValue>ABCD</paramValue></parameter><parameter><paramName>dbRole</paramName><paramValue>PRIMARY</paramValue></parameter></parameters><result return="0"/><responses><response><![CDATA[<instances><instance><oracleSid>ABCD2</oracleSid><oracleHome>/opt/oracle/db/dbhome/19.3.0</oracleHome><version>19.6.0.0.0</version><databaseName>ABCD</databaseName>
<databaseId>ABCD:123456789:ABCD</databaseId><online>true</online></instance></instances>]]></response></responses></operation><version>1.0</version></ir_message>

Cause

AppSync 3.9.0.0 does not support Oracle versions 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5, or 19.6.
AppSync 4.0.0.0 does not support Oracle versions 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5, or 19.6.

Resolution

AppSync 3.9.0.0 requires hotfix AppSync-patch-3.9.0.0_1278_R2 to support Oracle versions 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5, or 19.6.

AppSync 4.0.0.0 requires hotfix AppSync-patch-4.0.0.0_1553_R1 to support Oracle versions 18.5, 18.6, 18.7, 18.8, 18.9, 19.4, 19.5, or 19.6.

Note this article when calling in a service request to obtain the hotfix. Install the patch on the AppSync Server and push the Agent out to all the affected clients.

The AppSync hotfix applies to the following components:
  • AppSync Server
  •  AppSync host plug-in (AppSync hostplugin_linux and AppSync hostplugin_aix)
Note: The first run of the service plan after the hotfix is applied, may fail during application discovery.

If discovery fails for AppSync 3.9:
  1. Go to AppSync > Settings > Servers screen and select the server and run Rediscover. 
  2. Go to AppSync > Copy Management > Oracle screen.
  3. Click drop down next to Discover Databases. 
  4. Select on Server and select the host.
  5. Rerun the service plan.
If discovery fails for AppSync 4.0:
  1. Go to AppSync > Settings > Servers screen and select the server and run Rediscover. 
  2. Go to AppSync > Copy Management > Copies > Oracle screen.
  3. Drop down the MORE option and select Discover Databases. 
  4. Highlight the server and select "OK."
  5. Rerun the service plan.

Additional Information

Oracle 19.4, 19.5, and 19.6 require an Oracle fix to address a recovery issue:
 
The recovery issue is due to an Oracle bug that was fixed in the 19.3.0.0.0 release but later reintroduced in the 19.4.0.0.0 release of the product.

Contact Oracle Support regarding the following base bug number that should be used for obtaining patches to remediate the issue based on the OS platform currently in use:

Bug 30528704: 19C RMAN RECOVER DATABASE USE REDO LOG INSTEAD OF ARCHIVELOG AFTER APPLYING OCT DATABASE RU

See the following articles for more information regarding this Oracle related recovery issue:
 

Affected Products

AppSync

Products

AppSync
Article Properties
Article Number: 000170879
Article Type: Solution
Last Modified: 18 Sept 2025
Version:  4
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