Dell EMC Unity: Failed to get technical advisory with configured proxy (Yapılandırılmış proxy ile teknik danışmanlık alınamadı) (Kullanıcı Tarafından Düzeltilebilir)
Summary: Teknik danışmanlık alırken ortaya çıkan hatalar
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Symptoms
Unisphere'den teknik danışmanlık almaya çalışırken şu hata mesajı oluşur:
There was an error when retrieving catalog from Dell EMC through configured proxy (Error Code:0x6400bda)'
EMCSystemLogFile.log üzerinde şu görüntülenir:
2021-01-28T17:09:09.974Z" "xxx_spb@APM00123456789" "Neo_CEM" "17037" "local/admin" "WARN" "14:380012" :: "Failed to get technical advisory with configured proxy http://proxy.FQDN.com:8080." :: Category=User Component=EmcSupportServices TimeZone=UTC
The curl command to check connectivity to the Proxy server is failing:
# curl -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v
Hostname was NOT found in DNS cache
Could not resolve host: colu.emc.com
Closing connection 0
curl: (6) Could not resolve host: colu.emc.com
Adding the proxy server to the curl command succeeds.
# curl -x "http://<proxy.server.url>.com:8080" -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v
* Hostname was NOT found in DNS cache
* Trying 10.1.1.1... (proxy sunucusu IP'si)
* Connected to <proxy.server.url>.com (10.1.1.1) port 8080 (#0)
* Establish HTTP proxy tunnel to colu.emc.com:443
> CONNECT colu.emc.com:443 HTTP/1.1
> Host: colu.emc.com:443
> User-Agent: curl/7.37.0
> Proxy-Connection: Keep-Alive
<--snip-->
(sonucun tamamına Notlardan bakabilirsiniz)
There was an error when retrieving catalog from Dell EMC through configured proxy (Error Code:0x6400bda)'
EMCSystemLogFile.log üzerinde şu görüntülenir:
2021-01-28T17:09:09.974Z" "xxx_spb@APM00123456789" "Neo_CEM" "17037" "local/admin" "WARN" "14:380012" :: "Failed to get technical advisory with configured proxy http://proxy.FQDN.com:8080." :: Category=User Component=EmcSupportServices TimeZone=UTC
The curl command to check connectivity to the Proxy server is failing:
# curl -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v
Hostname was NOT found in DNS cache
Could not resolve host: colu.emc.com
Closing connection 0
curl: (6) Could not resolve host: colu.emc.com
Adding the proxy server to the curl command succeeds.
# curl -x "http://<proxy.server.url>.com:8080" -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v
* Hostname was NOT found in DNS cache
* Trying 10.1.1.1... (proxy sunucusu IP'si)
* Connected to <proxy.server.url>.com (10.1.1.1) port 8080 (#0)
* Establish HTTP proxy tunnel to colu.emc.com:443
> CONNECT colu.emc.com:443 HTTP/1.1
> Host: colu.emc.com:443
> User-Agent: curl/7.37.0
> Proxy-Connection: Keep-Alive
<--snip-->
(sonucun tamamına Notlardan bakabilirsiniz)
Cause
Böyle bir durumda müşteri, DNS sunucusuna doğrudan erişime izin vermez ve çıkış için yalnızca Proxy Sunucusu kullanır. Bu sorunun sebebi, colu.emc.com ve proxy sunucusu arasındaki bağlantının Unity ve proxy sunucusu arasındaki veri aktarımı tamamlanmadan önce kesilmiş olmasıdır. Bu, curl'ün bağlantıları işleme biçiminden kaynaklanıyor gibi görünüyor.
Resolution
Çözüm:
Bu sorunun çözümü, gelecekteki bir Dell EMC Unity OE sürümüne dahil edilecektir. Güncelleştirmeler için lütfen bu Knowledge Base makalesini izleyin.
Geçici çözüm:
Teknik danışmanlık almak için proxy sunucusunu kullanmayın veya bu sorunun çözümü olan kod yayınlanana kadar Unisphere için geçici bir atlama ayarlamayın.
Bu sorunun çözümü, gelecekteki bir Dell EMC Unity OE sürümüne dahil edilecektir. Güncelleştirmeler için lütfen bu Knowledge Base makalesini izleyin.
Geçici çözüm:
Teknik danışmanlık almak için proxy sunucusunu kullanmayın veya bu sorunun çözümü olan kod yayınlanana kadar Unisphere için geçici bir atlama ayarlamayın.
Additional Information
curl komutuna "proxy sunucusu URL'si"ni eklediğinizde komut şu şekilde devam eder:
# curl -x "http://<proxy.server.url>.com:8080" -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v
* Hostname was NOT found in DNS cache
* Trying 10.1.1.1... (proxy sunucusu IP'si)
* Connected to <proxy.server.url>.com (10.1.1.1) port 8080 (#0)
* Establish HTTP proxy tunnel to colu.emc.com:443
> CONNECT colu.emc.com:443 HTTP/1.1
> Host: colu.emc.com:443
> User-Agent: curl/7.37.0
> Proxy-Connection: Keep-Alive
>
< HTTP/1.1 200 Connection established
<
* Proxy replied OK to CONNECT request
* successfully set certificate verify locations:
* CAfile: none
CApath: /etc/ssl/certs/
* SSLv3, TLS handshake, Client hello (1):
* SSLv3, TLS handshake, Server hello (2):
* SSLv3, TLS handshake, Certificate (11):
* SSLv3, TLS handshake, Server key exchange (12):
* SSLv3, TLS handshake, Server finished (14):
* SSLv3, TLS handshake, Client key exchange (16):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSL connection using TLSv1.2 / ECDHE-RSA-AES256-GCM-SHA384
* Server certificate:
* subject: C=US; ST=Texas; L=Round Rock; O=Dell; CN=colu.emc.com
* start date: 2020-08-25 03:21:00 GMT
* expire date: 2022-08-25 03:21:00 GMT
* subjectAltName: colu.emc.com matched
* issuer: C=US; O=Entrust, Inc.; OU=See www.entrust.net/legal-terms; OU=(c) 2012 Entrust, Inc. - for authorized use only; CN=Entrust Certification Authority - L1K
* SSL certificate verify ok.
# curl -x "http://<proxy.server.url>.com:8080" -X POST https://colu.emc.com:443/soap/rpc -H "Content-Type: text/xml;charset=UTF-8" -H "SOAPAction:" -v
* Hostname was NOT found in DNS cache
* Trying 10.1.1.1... (proxy sunucusu IP'si)
* Connected to <proxy.server.url>.com (10.1.1.1) port 8080 (#0)
* Establish HTTP proxy tunnel to colu.emc.com:443
> CONNECT colu.emc.com:443 HTTP/1.1
> Host: colu.emc.com:443
> User-Agent: curl/7.37.0
> Proxy-Connection: Keep-Alive
>
< HTTP/1.1 200 Connection established
<
* Proxy replied OK to CONNECT request
* successfully set certificate verify locations:
* CAfile: none
CApath: /etc/ssl/certs/
* SSLv3, TLS handshake, Client hello (1):
* SSLv3, TLS handshake, Server hello (2):
* SSLv3, TLS handshake, Certificate (11):
* SSLv3, TLS handshake, Server key exchange (12):
* SSLv3, TLS handshake, Server finished (14):
* SSLv3, TLS handshake, Client key exchange (16):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSL connection using TLSv1.2 / ECDHE-RSA-AES256-GCM-SHA384
* Server certificate:
* subject: C=US; ST=Texas; L=Round Rock; O=Dell; CN=colu.emc.com
* start date: 2020-08-25 03:21:00 GMT
* expire date: 2022-08-25 03:21:00 GMT
* subjectAltName: colu.emc.com matched
* issuer: C=US; O=Entrust, Inc.; OU=See www.entrust.net/legal-terms; OU=(c) 2012 Entrust, Inc. - for authorized use only; CN=Entrust Certification Authority - L1K
* SSL certificate verify ok.
Affected Products
Dell EMC Unity FamilyArticle Properties
Article Number: 000182700
Article Type: Solution
Last Modified: 19 Aug 2021
Version: 3
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