PowerFlex: Urządzenia w stanie błędu podczas uaktualniania CloudLink za pomocą PFxM

Summary: Podczas uaktualniania CloudLink do PowerFlex Manager 3.8 mogą wystąpić problemy, które spowodują niepowodzenie uaktualnienia usługi.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Uaktualniana usługa zakończy się niepowodzeniem po uaktualnieniu węzła SDS. Węzeł SDS ma uaktualnionego agenta CloudLink, ale nadal będzie w trybie konserwacji. 

Cause

CloudLink 7.0, 7.02, 7.1.0, 7.1.1 nie dodaje wymaganego wyłącznika w /opt/emc/extra/pre_run.sh. W przypadku ręcznego dodania program PowerFlex Manager 3.8 usuwa czasomierz uśpienia podczas uaktualniania usługi w węzłach SDS.  Bez wyłącznika usługa PowerFlex jest uruchamiana przed odblokowaniem dysków przez CloudLink.  Powoduje to, że niektóre lub wszystkie dyski są w stanie błędu. 

Resolution

Ten problem został rozwiązany w programie PowerFlex Manager 3.8.3.   

Dostępna jest poprawka PowerFlex Manager 3.8.2 zapewniająca obecność wyłącznika czasowego. 

W przypadku programu PowerFlex Manager 3.8.0 i 3.8.1 użyj następującej metody, aby przeprowadzić uaktualnienia usług z szyfrowaniem CloudLink.

 

Uaktualnij zasób CloudLink z RCM do żądanej wersji. 

 1. Zaloguj się do programu PowerFlex Manager.

2. Przejdź do karty Resources i wybierz All Resources, a następnie wybierz CloudLink Center do uaktualnienia. Można uaktualnić tylko jeden węzeł klastra CloudLink Center. Pozostałe węzły są uaktualniane automatycznie.

3. Kliknij przycisk Aktualizuj zasoby.

4. Wybierz opcję Zezwalaj programowi PowerFlex Manager na wykonanie aktualizacji oprogramowania wewnętrznego i oprogramowania już teraz lub Schedule aktualizacje oprogramowania wewnętrznego i oprogramowania.

5. Kliknij przycisk Zastosuj i przycisk Tak, aby potwierdzić.

Automatyczne uaktualnienie wszystkich agentów.  

Zaloguj się do CloudLink Center

Każdy węzeł SDS będzie miał alarm wskazujący, że agent CloudLink nie został jeszcze uaktualniony.

Ustaw zasady uaktualniania agenta maszyny na wartość Automatycznie dla grupy maszyn zawierającej węzły SDS, które są uaktualniane (spowoduje to wyzwolenie uaktualnienia agenta CloudLink we wszystkich węzłach SDS): 

Akcje grup >> maszyn agentów > modyfikują uaktualnienie agenta maszyny grupy>.

Poczekaj kilka minut, aż CloudLink uaktualni wszystkie agenty CloudLink w węzłach SDS do nowej wersji. Upewnij się, że alarmy agenta CloudLink w węzłach SDS zostały usunięte.

Zaktualizuj plik /opt/emc/extra/pre_run.sh.

W każdym uaktualnionym węźle SDS sprawdź plik /opt/emc/extra/pre_run.sh.

Jeśli nie istnieje przy użyciu 'vi', utwórz plik za pomocą wszystkich poleceń pokazanych poniżej.

Jeśli istnieje, używając "vi", dodaj timer "uśpij 60", jak pokazano poniżej.

/opt/emc/extra/pre_run.sh:

#!/bin/bash -f

if [ -f /sbin/svm ]; then
  echo svm is installed $(date) >> /var/log/svm-sds
  /sbin/svmd -l /var/log/svmd.log -p /var/run/svmd.pid &
  end=$((SECONDS+300))
  sleep 60
  while [ $SECONDS -lt $end ]; do
    /sbin/svm unlocked > /dev/null && break
    sleep 5
  done
fi

  4. Zmień uprawnienia w pliku pre_run.sh "chmod 755 /opt/emc/extra/pre_run.sh"  

 Uruchom ponownie węzły i usuń błędy (opcjonalnie):

  • Przełącz węzeł SDS w tryb konserwacji chronionej.
  • Rejestrowanie używanych liter dysków (na przykład sda-sdk lub sdb — sdl)
  • Uruchom ponownie węzeł.
  • Po ponownym uruchomieniu upewnij się, że w interfejsie użytkownika PowerFlex nie ma błędów PowerFlex.   Jeśli tak, usuń błędy.
  • Sprawdź, czy plik /opt/emc/extra/pre_run.sh nadal zawiera licznik czasu "uśpij 60". Jeśli nie, dodaj minutnik "uśpij 60" i powtórz krok 3.   
  • Sprawdź kolejność liter dysków. Jeśli kolejność dysków została zmieniona, zresetuj dyski za pomocą poleceń scli:
scli --query_all_sds
scli --query_sds -sds_id   
scli --update_sds_original_paths -sds_id  

7. Jeśli przy pierwszym ponownym uruchomieniu wystąpiły błędy PowerFlex, powtórz kroki 3–6.

8. Wyłącz tryb konserwacji chronionej węzła.

9. Powtórz kroki 1–8 dla wszystkich pozostałych węzłów SDS, aby potwierdzić, że pre_run.sh jest prawidłowo skonfigurowany.   

  Rozpocznij uaktualnianie usługi

  • 1. Zinwentaryzuj wszystkie węzły w PFxM i potwierdź, że CloudLink jest zgodny z nowym RCM we wszystkich węzłach SDS.
  • 2. Przeprowadź uaktualnienie RCM w usłudze.

 

 W przypadku programu PowerFlex Manager 3.8.2 należy zastosować załączoną poprawkę przed uaktualnieniem usługi z szyfrowaniem CloudLink:

Przed rozpoczęciem uaktualniania RCM zastosuj poprawkę PowerFlex Manager 3.8.2:  

Wykonaj migawkę urządzenia PowerFlex Manager. (Po zakończeniu usuń migawkę).

Pobierz plik .zip dołączony do tej bazy wiedzy i rozpakuj go.   

Skopiuj plik Dell-VxFM-asm-deployer-3.8.2-52.noarch.rpm do katalogu /var/tmp na urządzeniu PowerFlex Manager.

SSH do urządzenia PowerFlex Manager.

Upewnij się, że na urządzeniu PFxM nie są uruchomione żadne zadania.

Uruchom następujące polecenia na urządzeniu PowerFlex Manager, aby zastosować poprawkę:

cd /var/tmp
sudo rpm -Fvh Dell-VxFM-asm-deployer-3.8.2-52.noarch.rpm
sudo shutdown -r now 

Można teraz przeprowadzić aktualizację RCM i po ponownym uruchomieniu węzłów na zaszyfrowanych dyskach nie powinny pojawić się żadne błędy SDS.   

Affected Products

PowerFlex rack

Products

PowerFlex custom node, PowerFlex appliance R650, PowerFlex appliance R6525, PowerFlex appliance R660, PowerFlex appliance R6625, Powerflex appliance R750, PowerFlex appliance R760, PowerFlex appliance R7625, PowerFlex custom node , PowerFlex custom node R650, PowerFlex custom node R6525, PowerFlex custom node R660, PowerFlex custom node R6625, PowerFlex custom node R750, PowerFlex custom node R760, PowerFlex custom node R7625, PowerFlex custom node R860, PowerFlex appliance R640, PowerFlex appliance R740XD, PowerFlex appliance R7525, PowerFlex appliance R840 ...
Article Properties
Article Number: 000202412
Article Type: Solution
Last Modified: 27 Nov 2025
Version:  11
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.