PowerFlex:在升級 CloudLink 與 PFxM 時裝置處於錯誤狀態

Summary: 使用 PowerFlex Manager 3.8 升級 CloudLink 時,可能會發生問題,導致服務升級失敗。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

升級服務將在 SDS 節點升級時失敗。SDS 節點已升級 CloudLink 代理程式,但仍將處於維護模式。 

Cause

CloudLink 7.0、7.02、7.1.0、7.1.1 不會在 /opt/emc/extra/pre_run.sh 中新增必要的睡眠定時器。如果是手動新增,PowerFlex Manager 3.8 會在 SDS 節點上執行服務升級時移除睡眠計時器。  若沒有睡眠計時器,PowerFlex 服務會在 CloudLink 解除鎖定磁碟機之前啟動。  這會導致部分或所有磁碟機處於錯誤狀態。 

Resolution

此問題已在 PowerFlex Manager 3.8.3 中修正。   

有一個 PowerFlex Manager 3.8.2 修補程式可確保睡眠定時器存在。 

若為 PowerFlex Manager 3.8.0 和 3.8.1,請使用下列方法執行具有 CloudLink 加密的服務升級。

 

使用 RCM 將 CloudLink 資源升級至所需的版本。 

 1.登入 PowerFlex Manager。

2.前往資源標籤並選取所有資源,然後選取要升級的 CloudLink Center。您只能升級 CloudLink Center 叢集的單一節點。其餘節點將自動升級。

3.按一下更新資源。

4.選擇允許 PowerFlex Manager 立即執行韌體和軟體更新,或排程韌體和軟體更新。

5.按一下套用,然後按一下是以確認。

自動升級所有代理程式。  

登入 CloudLink Center

SDS 節點都會各有警示,指出 CloudLink 代理程式尚未升級。

針對包含要升級的 SDS 節點的機器群組,將機器代理程式升級原則設定為自動 (這會在所有 SDS 節點上觸發 CloudLink 代理程式升級): 

代理 > 計算機組 > 操作 > 修改組 > 計算機代理升級。

等待幾分鐘,讓 CloudLink 將 SDS 節點上的所有 CloudLink 代理程式升級至新版本。確定已清除 SDS 節點上的 CloudLink 代理程式警示。

更新 /opt/emc/extra/pre_run.sh。

在每個已升級的 SDS 節點上,檢查 /opt/emc/extra/pre_run.sh。

如果無法使用「vi」,請使用下方顯示的所有命令建立檔案。

如果確實存在,請使用「vi」新增「睡眠 60」計時器,如下所示。

/opt/emc/extra/pre_run.sh:

#!/bin/bash -f

if [ -f /sbin/svm ]; then
  echo svm is installed $(date) >> /var/log/svm-sds
  /sbin/svmd -l /var/log/svmd.log -p /var/run/svmd.pid &
  end=$((SECONDS+300))
  sleep 60
  while [ $SECONDS -lt $end ]; do
    /sbin/svm unlocked > /dev/null && break
    sleep 5
  done
fi

  4.變更pre_run.sh檔案「chmod 755 /opt/emc/extra/pre_run.sh」上的權限  

 重新開機節點並清除錯誤 (選用):

  • 將 SDS 節點置於受保護的維護模式。
  • 記錄使用的磁碟機代號 (例如 sda-sdk 或 sdb - sdl)
  • 重新啟動節點。
  • 重新開機完成後,請確定 PowerFlex UI 中沒有 PowerFlex 錯誤。   如果有,請清除錯誤。
  • 檢查 /opt/emc/extra/pre_run.sh 是否仍包含「sleep 60」計時器。如果沒有,請新增「睡眠 60」計時器,然後從步驟 3 重複此步驟。   
  • 檢查磁碟機代號順序。如果磁碟機已重新訂購,請使用 scli 命令重設磁碟機:
scli --query_all_sds
scli --query_sds -sds_id   
scli --update_sds_original_paths -sds_id  

7.如果第一次重新開機時發生 PowerFlex 錯誤,請重複步驟 3-6。

8.將節點退出受保護的維護模式。

9.對所有其他 SDS 節點重複步驟 1-8,確認pre_run.sh設定正確。   

  開始服務升級

  • 1.清查 PFxM 中的所有節點,並確認 CloudLink 符合所有 SDS 節點上的新 RCM。
  • 2.在服務上執行 RCM 升級。

 

 若為 PowerFlex Manager 3.8.2,請在升級含 CloudLink 加密的服務之前套用附加的修補程式:

開始 RCM 升級之前,請先套用 PowerFlex Manager 3.8.2 修補程式:  

拍攝 PowerFlex Manager 裝置的快照。(完成後請移除快照。)

下載此 KB 附加的.zip檔案並解壓縮。   

將 Dell-VxFM-asm-deployer-3.8.2-52.noarch.rpm 檔案複製到 PowerFlex Manager 裝置上的 /var/tmp 目錄。

SSH 至 PowerFlex Manager 裝置。

確定 PFxM 上沒有任何工作正在執行中。

在 PowerFlex Manager 裝置上執行下列命令以套用修補程式:

cd /var/tmp
sudo rpm -Fvh Dell-VxFM-asm-deployer-3.8.2-52.noarch.rpm
sudo shutdown -r now 

現在可以執行 RCM 升級,而且當節點重新開機時,加密磁碟機上應該不會有任何 SDS 錯誤。   

Affected Products

PowerFlex rack

Products

PowerFlex custom node, PowerFlex appliance R650, PowerFlex appliance R6525, PowerFlex appliance R660, PowerFlex appliance R6625, Powerflex appliance R750, PowerFlex appliance R760, PowerFlex appliance R7625, PowerFlex custom node , PowerFlex custom node R650, PowerFlex custom node R6525, PowerFlex custom node R660, PowerFlex custom node R6625, PowerFlex custom node R750, PowerFlex custom node R760, PowerFlex custom node R7625, PowerFlex custom node R860, PowerFlex appliance R640, PowerFlex appliance R740XD, PowerFlex appliance R7525, PowerFlex appliance R840 ...
Article Properties
Article Number: 000202412
Article Type: Solution
Last Modified: 27 Nov 2025
Version:  11
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.