Fout in Cisco MDS-serie: protocolidentificatietekenreeks ontbreekt carriage return
Summary: Error on switch %DAEMON-3-SYSTEM_MSG: error:protocol identification string lack carriage return
Symptoms
Het zien van deze fouten in 'show logging log' :
2024 Nov 5 03:05:01 PSTIEBN5003 %DAEMON-3-SYSTEM_MSG: error: protocol identification string lack carriage return - dcos_sshd[20871]2024 Nov 5 03:05:03 PSTIEBN5003 %DAEMON-3-SYSTEM_MSG: error: protocol identification string lack carriage return - dcos_sshd[7528]2024 Nov 5 03:05:04 PSTIEBN5003 %DAEMON-3-SYSTEM_MSG: error: protocol identification string lack carriage return - dcos_sshd[7572]
Cause
Het probleem kan zich voordoen na de upgrade van MDS/Nexus-switches die worden beheerd door DCNM versie 11.3 of hoger.
De switch bevat de bug CSCvv24160.
https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvv24160
Resolution
De logboekberichten zelf zijn onschadelijk, maar ze kunnen uiteindelijk de logboeken vullen. Daarom verdient het wijzigen van het loggingniveau op de switch de voorkeur totdat DCNM kan worden geüpgraded naar de vaste versie.
Tijdelijke oplossing:
1. Voer de volgende configuraties uit op de switch: DAEMON 2
2 voor logboekregistratie. Verleng het DCNM-pollinginterval tot het maximum (15 minuten) om het aantal logboekvermeldingen te verminderen.
Om dit te implementeren navigeert u naar de pagina Web UI-beheer -> Servereigenschappen. Zoek het propertycdp.pollingInterval en verhoog de waarde naar een groter getal (standaard 300 seconden), bijvoorbeeld 600 of 900 seconden.
Oplossing: Upgrade naar NDFC 12.x
Additional Information
Het verlagen van het loggingniveau van een daemon van niveau 3 (Fout) naar niveau 2 (Kritiek), resulteert in minder logberichten die worden opgenomen. Alleen berichten die zijn geclassificeerd als "Kritiek" of ernstiger, worden geregistreerd. Hier volgt een kort overzicht van wat dit betekent:
Niveau 3 (fout): Registreert foutcondities, dit zijn problemen waardoor het systeem mogelijk nog steeds kan blijven werken, maar een probleem aangeven dat aandacht nodig heeft.
Niveau 2 (kritiek): Registreert kritieke omstandigheden, dit zijn ernstigere problemen die aanzienlijke problemen of systeemstoringen kunnen veroorzaken.
Door het logboekregistratieniveau in te stellen op 2, worden minder ernstige foutmeldingen verwijderd en worden alleen kritieke problemen vastgelegd, waardoor het volume van de logboeken mogelijk wordt verminderd en de nadruk wordt gelegd op de ernstigste problemen.