PowerStore: Nach einem Upgrade auf PowerStoreOS 4.1 auf Clustern mit drei oder mehr Appliances bleibt die Replikation der Managementdatenbank möglicherweise im asynchronen Modus

Summary: Nach einem Upgrade auf PowerStoreOS Version 4.1 auf einem Cluster mit drei oder mehr Appliances kann der Cluster die synchrone Replikation der internen Managementdatenbank möglicherweise nicht erneut aktivieren. In diesem Fall verbleibt die Replikation der Managementdatenbank auf dem betroffenen Cluster im asynchronen Modus. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Nach einem Upgrade auf Version 4.1 kehrt die interne Managementdatenbank nicht zur synchronen Replikation zurück und bleibt asynchron.

Hinweis: Dieses Problem wirkt sich nicht auf einzelne Appliance-Cluster oder Cluster mit zwei Appliances aus.

Diese Änderung sollte keine unmittelbaren Auswirkungen auf die Clusterfunktionalität oder auf Nutzerdaten haben, da Änderungen auf alle Appliances repliziert werden.

Eine potenzielle Datenintegritätsbedingung kann in der Managementdatenbank eines Clusters mit drei oder mehr Appliances nach einem Appliance-Failover-Ereignis (z. B. Herunterfahren auf Appliance-Ebene, Stromausfall auf Appliance-Ebene) ausgelöst werden.

Cause

Aufgrund eines Softwareproblems in Version 4.1 (oder höher) wird die Replikation der Managementdatenbank auf einem Cluster mit drei oder mehr Appliances nach Abschluss des Upgrades nicht auf die synchrone Replikation zurückgesetzt und bleibt asynchron.

Auswirkungen

Wenn die primäre Appliance abrupt ausfällt oder getrennt wird und ausstehende Managementbefehle vorhanden sind, die noch nicht an mindestens eine sekundäre Appliance gesendet wurden, kann eine Datenintegritätsbedingung in der Managementdatenbank des betroffenen Clusters ausgelöst werden.

Resolution

Dieses Problem wurde in PowerStoreOS v4.1.0.1 und v4.2 und höher behoben. 

 

Wenden Sie sich an den technischen Support von Dell , um zu bestätigen, dass dieses Problem aufgetreten ist. Lesen Sie diese Wissensdatenbank-Artikel-ID für eine schnellere Abwicklung.

 

Hinweis: Mit der Veröffentlichung des PowerStore Health Check-Pakets 4.1 wurde eine neue Integritätsprüfung vor dem Upgrade (Pre-Upgrade Health Check, PUHC) eingeführt, um Appliance-Cluster mit 3 oder 4 PowerStore-Appliances zu identifizieren.  Die neue Prüfung kennzeichnet solche Systeme und führt dazu, dass PUHC auf PowerStoreOS Version 4.1 fehlschlägt.

Bildschirm

Affected Products

PowerStore
Article Properties
Article Number: 000286668
Article Type: Solution
Last Modified: 25 Sept 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.