PowerStore: Etter en oppgradering til PowerStoreOS 4.1 på klynger med tre eller flere tilpassede verktøy, kan replikering av administrasjonsdatabasen forbli i asynkron modus

Summary: Etter en oppgradering til versjon 4.1 av PowerStoreOS på en klynge med tre eller flere tilpassede verktøy, kan det hende at klyngen ikke aktiverer synkron replikering av den interne administrasjonsdatabasen på nytt. I dette tilfellet forblir replikering av administrasjonsdatabasen på den berørte klyngen i asynkron modus. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Etter en oppgradering til versjon 4.1 går ikke den interne administrasjonsdatabasen tilbake til synkron replikering, men forblir asynkron.

Merk: Dette problemet påvirker ikke klynger for enkeltverktøy eller klynger med to tilpassede verktøy.

Denne endringen skal ikke ha noen umiddelbar innvirkning på klyngens funksjonalitet eller brukerdata, ettersom endringene replikeres til alle tilpassede verktøy.

En potensiell dataintegritetstilstand kan utløses i administrasjonsdatabasen til en klynge med tre eller flere apparater etter en failover-hendelse for et verktøy (for eksempel avslutning på apparatnivå og strømbrudd på apparatnivå).

Cause

På grunn av et programvareproblem i versjon 4.1 (eller nyere) går ikke administrasjonsdatabasereplikering på en klynge med tre eller flere apparater tilbake til synkron replikering etter fullført oppgradering, og forblir asynkron.

Innvirkning

Hvis det primære verktøyet brått svikter eller kobles fra, og hvis det er ventende administrasjonskommandoer som ennå ikke er sendt til minst ett sekundært tilpasset verktøy, kan en dataintegritetstilstand utløses i administrasjonsdatabasen til den berørte klyngen.

Resolution

Dette problemet er løst i PowerStoreOS v4.1.0.1 og v4.2 og nyere. 

 

Kontakt Dell teknisk støtte for å bekrefte at dette problemet har oppstått. Se denne kunnskapsbaseartikkel-ID-en for rask håndtering.

 

Merk: Med utgivelsen av PowerStore Health Check-pakke 4.1 ble en ny pre-upgrade Health Check (PUHC) introdusert for å identifisere apparatklynger med tre eller fire PowerStore-apparater.  Den nye kontrollen med flagg slike systemer og vil føre til at PUHC til PowerStoreOS versjon 4.1 mislykkes.

Skjermbilde for jobbdetaljer

Affected Products

PowerStore
Article Properties
Article Number: 000286668
Article Type: Solution
Last Modified: 25 Sept 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.