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Wrong Character Displayed Using Integrated Keyboard on a Dell Notebook

Summary: Learn how to resolve the issue where the wrong character is displayed using the integrated keyboard on a Dell laptop.

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Article Content


Symptoms

  1. Ensure that the Number Lock Key is set correctly.
    Notes:
    • The numeric keypad on a desktop keyboard is normally turned on. When it is off, no numbers appear when pressed. Press the Number Lock Key to switch the numeric keypad on and off.
    • For laptops that have a numeric keypad on the right side, it is normally turned on. When it is off, no numbers appear when the keys are pressed. Press the Number Lock Key to switch the numeric keypad on and off.
    • Some laptops simulate a numeric keypad by using dual-purpose keys. When the Number Lock Key is active, numbers appear instead of letters when pressed. Press the Number Lock Key to switch the numeric keypad on and off.


      See the Dell Knowledge Base article How to Obtain Manuals and Documentation for your Dell Product, for more information about where the Number Lock Key is.

  2. See the Microsoft Knowledge Base article Manage the input and display language settings in Windows, for information about ensuring that the keyboard language setting in Windows is correct. External Link
  3. Ensure that the BIOS for your computer is up to date. For information about how to download the BIOS, see the Dell Knowledge Base article Dell BIOS Updates.
  4. Using the SupportAssist application provides automatic computer updates and detects issues that will be resolved for you. Let us take the effort out of maintaining your Dell Computer or Tablet. For more information about SupportAssist, browse to the SupportAssist for PCs and tablets page.
  5. In some instances, this issue can be caused by devices that are connected to the computer.
    • Remove the computer from the dock, if Docked.
    • Remove all devices from the computer.
    • If the issue does not occur after removing all devices, attach one device at a time to find out which device is causing the issue.
  6. Check if the same happens when using an external keyboard.
    • Attach an external USB keyboard, if available, and test the suspect keys.
    • If the issue continues to occur when using an external keyboard, the issue may lie with either the Operating System or the Motherboard.
    • If the issue does not occur using an external keyboard, the issue may lie with the internal keyboard.
  7. To check if the issue is caused within the Operating System, test to see if the same issue occurs in Safe Mode.
    NOTE: For information about getting into Safe Mode, see Dell Knowledge Base article How to Boot into Safe Mode in Windows 11 or Windows 10.
  8. If none of the steps resolve the issue, run the Keyboard hardware test.

Cause

No Cause information is available.

Resolution

See the Symptom section for steps to help resolve the issue.

Article Properties


Affected Product

Laptops, Inspiron, Latitude, Vostro, XPS, Legacy Laptop Models

Last Published Date

28 Feb 2023

Version

5

Article Type

Solution