Data Domain: DD3300: After replacing a disk, the disk alert persists

Summary: After a disk replacement, the new disk information is not updated on the Data Domain Operating System (DDOS), and the alert remains.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Note: The DD3300 runs a modified version of the Data Domain (DD) Virtual Edition (DDVE) software.
 

Within the Data Domain Operating System (DDOS):

1. The new disk information is not updated:
# disk show hardware-detailed
Disk   Slot        Manufacturer/Model   Firmware   Serial No.         Capacity   Type       State  
       (pci/idx)                                                                                   
----   ---------   ------------------   --------   --------------   ----------   --------   --------
1.1    0           ST4000NM017A         CSJ7       WJG12JG9           3.64 TiB   SAS        In Use 
1.2    1           ST4000NM017A         CSJ7       WJG18M5C           3.64 TiB   SAS        In Use 
1.3    2           ST4000NM017A         CSJ7       WJG12HZN           3.64 TiB   SAS        In Use 
1.4    3           ST4000NM017A         CSJ7       WJG18M6X           3.64 TiB   SAS        In Use 
1.5    4           ST4000NM017A         CSJ7       WJG19CGX           3.64 TiB   SAS        In Use 
1.6    5           ST4000NM017A         CSJ7       WJG17136           3.64 TiB   SAS        In Use 
1.7    6           ST4000NM017A         CSJ7       WJG19B57           3.64 TiB   SAS        In Use 
1.8    7           ST4000NM017A         CSJ7       WJG19DQ3           3.64 TiB   SAS        In Use 
1.9    8           ST4000NM017A         CSJ7       WJG17YCG           3.64 TiB   SAS        In Use 
1.10   9           ST4000NM017A         CSJ7       WJG18MK0           3.64 TiB   SAS        Unknown  <<-- Old serial number
1.11   10          (absent)             (absent)   (absent)           (absent)   (absent)   Absent 
1.12   11          (absent)             (absent)   (absent)           (absent)   (absent)   Absent 
1.13   12          MZ7LH480HBHQ0D3      HG57       S5YJNE0N810008   447.13 GiB   SATA-SSD   Non-RAID 
 
2. The disk alert is not cleared:
Current Alerts
--------------
Id      Post Time                  Severity   Class             Object                                         Message                                                                    
-----   ------------------------   --------   ---------------   --------------------------------------------   ----------------------------------------------------------------------------
p0-24   Thu Dec 30 05:00:57 2021   CRITICAL   HardwareFailure   Enclosure=1:Disk=10:Cause=NA                   EVT-STORAGE-00031: Disk has a hardware fault and may need to be replaced.  
p0-25   Thu Dec 30 11:11:29 2021   WARNING    HardwareFailure   Enclosure=1:Disk=10:Cause=Predictive failure   EVT-STORAGE-00032: Disk has a recoverable fault but may need to be replaced.
-----   ------------------------   --------   ---------------   --------------------------------------------   ----------------------------------------------------------------------------
There are 2 active alerts.
 

Within the Integrated Dell Remote Access Controller (iDRAC):

The Events log MAY display the discovery of the disk replacement operation. However, the hardware change is not passed to DDVE.
 
iDRAC Events:
Timestamp           Record              Message
2022-02-04 11:47:06      7              The watchdog timer expired.
2022-01-07 22:12:46      6              Drive 9 is installed in disk drive bay 1.
2022-01-07 22:08:17      5              Drive 9 in disk drive bay 1 is operating normally.
2022-01-07 22:08:16      4              Drive 9 is removed from disk drive bay 1.
2021-12-30 11:41:02      3              Fault detected on drive 9 in disk drive bay 1.
2021-07-19 19:03:25      2              The watchdog timer expired.
 

On ESXi:

The PTAgent that listens to the iDRAC contains no evidence of the broken communication:
2022-01-07 23:40:01,173 INFO - DellPTAgent service [version: 1.9.1-59] found healthy 
2022-01-07 23:45:01,182 INFO - DellPTAgent service [version: 1.9.1-59] found healthy 
2022-01-07 23:50:01,182 INFO - DellPTAgent service [version: 1.9.1-59] found healthy 
2022-01-07 23:55:01,193 INFO - DellPTAgent service [version: 1.9.1-59] found healthy 
2022-01-08 00:00:01,223 INFO - DellPTAgent service [version: 1.9.1-59] found healthy 
2022-01-08 00:05:01,222 INFO - DellPTAgent service [version: 1.9.1-59] found healthy 
2022-01-08 00:10:01,262 INFO - DellPTAgent service [version: 1.9.1-59] found healthy 
2022-01-08 00:15:01,253 INFO - DellPTAgent service [version: 1.9.1-59] found healthy 

Cause

The iDRAC does not refresh its storage information.
 
The expectation for iDRAC has always been that it should be able to refresh its storage inventory and provide the latest and correct disk information to PTAgent (on ESXi) and vulcanmon (on DDOS) when a disk is removed or inserted.
 
Sometimes the iDRAC does not refresh, and the iDRAC must be manually reset.

Resolution

  1. Reset the iDRAC online using the UI.
  2. Perform a cold reset (aka "flea drain") per BMC Reset (aka Flea Drain) Procedure.
  3. Check and confirm that related alerts have cleared, and that disk hardware is displayed as expected.

Affected Products

Data Domain, DD3300 Appliance
Article Properties
Article Number: 000197080
Article Type: Solution
Last Modified: 18 Jun 2026
Version:  5
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