PowerFlex 4.x Create Node pool generates a 500 error

Summary: In trying to create a new node pool, there encountered a 500 error not allowing for its creation. The error appears to be due to no "admin" user being found.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Screenshot of the error:
pfxm error 

Cause

There was a psql pod failure, which may cause the deletion of the admin user.

Resolution

Restarting the asmmanager pod can solve some of the UI problems. 

  1.  ssh to the master node
  2.  Get the asmmanager pod named and ID
# kubectl get pods -n powerflex | grep asmm
 asmmanager-666798d4b9-hhsk6 1/1 Running 0 21h3. 

To restart the pod, delete the pod using the pod name and ID you get from the above command:

# kubectl delete -n powerflex asmmanager-666798d4b9-hhsk6
Article Properties
Article Number: 000202166
Article Type: Solution
Last Modified: 27 May 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.