사이버 복구: NetWorker DR이 실패하고 "Unable to set user privileges based on user token for SYSTEM..." 오류가 표시됩니다.
Summary: 사이버 복구: NetWorker DR이 오류 메시지와 함께 실패합니다. networker.server.vault에서 SYSTEM에 대한 사용자 토큰을 기반으로 사용자 권한을 설정할 수 없습니다. 보안 토큰을 검증하지 못했습니다.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
로그의 장애 지점은 nsrdr 명령이 부트스트랩 데이터를 복구한 후에 발생합니다. 그런 다음 REST를 사용하여 디바이스를 마운트 해제하려고 시도합니다. 자동화된 Cyber Recovery DR을 중단시키는 오류가 발생합니다.
다음은 Cyber Recovery 호스트의 'apps.log'에서 추출한 것입니다.
볼트 NetWorker Server의 렌더링된 데몬.로그에서 추출합니다.
Cyber Recovery Manager에서 오류 발생
다음은 Cyber Recovery 호스트의 'apps.log'에서 추출한 것입니다.
[2023-02-28 13:22:54.062] [INFO] [apps] [ddssh.go:718 CreateSSHClientConn()] : SSH connecting to 192.168.1.10:22
[2023-02-28 13:22:54.179] [INFO] [apps] [ddssh.go:317 RunSSHCmd()] : Running: 192.168.1.10:22 nsrdr -d 192.168.1.20_vault_dev_0 -B 2432563240 -a -A
[2023-02-28 13:28:14.608] [INFO] [apps] [RecoverNetWorkerApp.go:1278 NWUnmountDevices()] : Umounting devices from the vault before running DR procedure...
[2023-02-28 13:28:14.609] [INFO] [apps] [restapi_client.go:261 CallRESTAPI()] : Methods is :GET URL is:https://192.168.1.10:9090/nwrestapi/v2/datazone/devices
[2023-02-28 13:28:19.522] [INFO] [apps] [appsUtils.go:109 HandleNWResponse()] : REST status code :500
[2023-02-28 13:28:19.523] [ERROR] [apps] [appsUtils.go:123 HandleNWResponse()] : Error response is : {Message:Unable to set user privileges based on user token for SYSTEM on networker.server.vault: Failed to validate security token.
Status:{Code:500 Class:Server Error Reason:Internal Server Error}}
볼트 NetWorker Server의 렌더링된 데몬.로그에서 추출합니다.
28/02/2023 13:28:10 nsrd NSR info Disaster Recovery Notice: Bootstrap recovery from the backup 2432563240 is completed with the status Succeeded 28/02/2023 13:28:15 nsrd AUTHC critical Unable to set user privileges based on user token for SYSTEM on networker.server.vault: Failed to validate security token.
Cyber Recovery Manager에서 오류 발생
Cause
볼트 NetWorker Server의 시스템 토큰이 잘못되었습니다. 볼트 NetWorker Server의 NMC에 기본 상태(DR 실행 전)에 로그인하는 경우에도 오류가 발생합니다.
Resolution
- 실패한 NetWorker 애플리케이션 복구를 정리하여 볼트 NetWorker Server가 기본 상태가 되도록 합니다(아직 완료되지 않은 경우).
- 볼트에서 NetWorker를 제거합니다.
- '의 이름을 바꿉니다. \EMC NetWorker\nsr' 폴더를 '.. \EMC NetWorker\old.nsr' 및 '. \EMC NetWorker\Management' 폴더를 '.. \EMC NetWorker\old. 관리'.
- 볼트의 NetWorker를 동일한 위치에 재설치하고 동일한 버전을 사용하고 이전과 동일한 자격 증명을 사용합니다.
- NetWorker가 실행 중인지 확인합니다.
- Cyber Recovery에서 NetWorker 자산을 삭제하고 다시 생성합니다.
- DR을 다시 실행합니다.
Affected Products
PowerProtect Cyber Recovery, NetWorkerProducts
Cyber Recovery SeriesArticle Properties
Article Number: 000210780
Article Type: Solution
Last Modified: 19 Sept 2023
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.