VxRail : Échec de la mise en veille des snapshots avec erreur d’échec du script de mise en veille personnalisé

Summary: Une erreur de mise en veille se produit lors de la création d’un snapshot sur une machine virtuelle Windows Server 2022 s’exécutant sur VMware ESXi 7.0.3 avec VMware Tools 12.5.0.24276846. Le code d’erreur est 2 et le message d’erreur est « Custom quiesce script failed ». ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Le système d’exploitation invité a signalé une erreur lors de la mise en veille.

The error code was: 2
The error message was: Custom quiesce script failed
An error occurred while saving the snapshot: Failed to quiesce the virtual machine.
2025-03-25T05:30:21.089Z In(05)+ vmx - The error message was: 'VssSyncStart' operation failed: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. (0x80070422) 2025-03-25T21:55:50.072Z In(05)+ vmx - The error message was: 'VssSyncStart' operation failed: IDispatch error #8454 (0x80042306) 2025-03-25T22:07:19.477Z In(05)+ vmx - The error message was: 'VssSyncStart' operation failed: IDispatch error #8454 (0x80042306) 2025-03-27T21:33:16.379Z In(05)+ vmx - The error message was: 'VssSyncStart' operation failed: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. (0x80070422)

Voici quelques étapes à suivre pour résoudre cette erreur :

  • Vérifiez que la version de VMware Tools est à jour.
  • Recherchez dans les journaux d’événements toute erreur liée au processus de mise en veille. Dans ce cas, les journaux d’événements n’affichent aucune erreur.
  • Vérifiez que le service VSS (Volume Shadow Copy Service) est activé et en cours d’exécution sur le système d’exploitation invité. Le message d’erreur « VssSyncStart operation failed » indique que le service VSS n’est pas en cours d’exécution ou qu’il est désactivé.
  • Activez et démarrez le service VSS sur le système d’exploitation invité.
  • Vérifiez que le script de mise en veille personnalisé est correctement configuré et en cours d’exécution. Le message d’erreur « Custom quiesce script failed » indique que le script n’est pas en cours d’exécution ou est en cours d’échec.
  • Vérifiez que VMware Tools est correctement configuré et en cours d’exécution. Le message d’erreur « Le service ne peut pas être démarré, soit parce qu’il est désactivé, soit parce qu’aucun périphérique activé n’y est associé » indique que VMware Tools n’est pas en cours d’exécution ou n’est pas configuré correctement.
  • Vérifiez la configuration de VMware Tools et corrigez les problèmes éventuels si nécessaire.
# Example of a command to check the VSS service status
vssadmin list providers

# Example of a command to start the VSS service
net start vss

# Example of a command to check the VMware Tools configuration
vmware-toolbox-cmd -v

Cause

Ce problème se produit en raison d’un script personnalisé mal configuré.

Resolution

Pour résoudre ce problème, renommez le backupScripts.d afin que le script personnalisé ne soit pas utilisé.

  1. Connectez-vous à la machine virtuelle Windows qui rencontre le problème.
  2. Rendez-vous sur C:\Program Files\VMware\VMware Tools.
  3. Renommez le backupscripts.d dossier à backupscripts.old.
  4. Démarrer le service VSS (Volume Shadow Copy Service)
  5. Réessayez un snapshot.
Reportez-vous à la base de connaissances Broadcom La tentative de création d’un snapshot mis en veille d’une machine virtuelle Windows échoue avec l’erreur suivante : Échec de l’opération « VmBackupOnThaw » Ce lien hypertexte renvoie à un site Web extérieur à Dell Technologies.
Bien que cet article dispose d’anciennes versions d’ESXi, il s’applique également à ESXi 7.x et 8.x.

Affected Products

VxRail, VMware
Article Properties
Article Number: 000308265
Article Type: Solution
Last Modified: 08 Sept 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.