VxRail: Disattivazione delle istantanee non riuscita con errore di disattivazione personalizzata dello script non riuscito

Summary: Si verifica un errore di disattivazione durante la creazione della snapshot su una VM Windows 2022 Server in esecuzione su VMware ESXi 7.0.3 con VMware Tools 12.5.0.24276846. Il codice errore è 2 e il messaggio di errore è "Custom quiesce script failed". ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Il sistema operativo guest ha segnalato un errore durante la disattivazione.

The error code was: 2
The error message was: Custom quiesce script failed
An error occurred while saving the snapshot: Failed to quiesce the virtual machine.
2025-03-25T05:30:21.089Z In(05)+ vmx - The error message was: 'VssSyncStart' operation failed: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. (0x80070422) 2025-03-25T21:55:50.072Z In(05)+ vmx - The error message was: 'VssSyncStart' operation failed: IDispatch error #8454 (0x80042306) 2025-03-25T22:07:19.477Z In(05)+ vmx - The error message was: 'VssSyncStart' operation failed: IDispatch error #8454 (0x80042306) 2025-03-27T21:33:16.379Z In(05)+ vmx - The error message was: 'VssSyncStart' operation failed: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. (0x80070422)

Di seguito sono riportati alcuni passaggi da seguire per risolvere questo errore:

  • Verificare che la versione di VMware Tools sia aggiornata.
  • Controllare i registri eventi per verificare la presenza di eventuali errori relativi al processo di disattivazione. In questo caso, i registri eventi non mostrano alcun errore.
  • Verificare che il Servizio Copia Shadow del volume (VSS) sia abilitato e in esecuzione sul sistema operativo guest. Il messaggio di errore "VssSyncStart" operation failed indica che il servizio VSS non è in esecuzione o è disabilitato.
  • Abilitare e avviare il servizio VSS sul sistema operativo guest.
  • Verificare che lo script di disattivazione personalizzato sia configurato e in esecuzione. Il messaggio di errore "Custom quiesce script failed" indica che lo script non è in esecuzione o ha esito negativo.
  • Verificare che VMware Tools sia configurato e in esecuzione correttamente. Il messaggio di errore "The service cannot be started, either because it is disabled o because its have no enabled devices associated ed" indica che VMware Tools non è in esecuzione o non è configurato correttamente.
  • Controllare la configurazione di VMware Tools e correggere eventuali problemi, se necessario.
# Example of a command to check the VSS service status
vssadmin list providers

# Example of a command to start the VSS service
net start vss

# Example of a command to check the VMware Tools configuration
vmware-toolbox-cmd -v

Cause

Questo problema si verifica a causa di uno script personalizzato configurato in modo errato.

Resolution

Per risolvere questo problema, rinominare il file backupScripts.d in modo che lo script personalizzato non venga utilizzato.

  1. Accedere alla macchina virtuale Windows in cui si è verificato il problema.
  2. Accedere al C:\Program Files\VMware\VMware Tools.
  3. Rinominare il backupscripts.d cartella in backupscripts.old.
  4. Avvio del Servizio Copia Shadow del volume (VSS)
  5. Provare a eseguire nuovamente un'istantanea.
Vedere Broadcom KB Il tentativo di creare un'istantanea disattivata di una macchina virtuale Windows ha esito negativo con l'errore: Operazione 'VmBackupOnThaw' non riuscita Questo link ipertestuale indirizza a un sito web esterno a Dell Technologies.
Sebbene questo articolo disponga di versioni precedenti di ESXi, si applica anche a ESXi 7.x e 8.x.

Affected Products

VxRail, VMware
Article Properties
Article Number: 000308265
Article Type: Solution
Last Modified: 08 Sept 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.