PowerProtect: DPD Senkronizasyonunun devam ettiğini gösteren VM yedekleme hatası

Summary: Birkaç sanal makine (VM) Varlığı yedeklemesi, başarıyla tamamlandıktan sonra başarısız olmaya başladı. Hata ayrıntıları, vCenter görevinin "DPD Sync in progress" bilgisini veren bir TSDM hatasıyla başarısız olduğunu gösterir. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

PowerProtect Data Manager, vSphere ortamını Transparent Snapshot Data Mover (TSDM) çözümüyle korumak için kullanılır. Geçmişte başarıyla tamamlanan birkaç VM Varlığı yedeklemesi başarısız olmaya başladı. Hata ayrıntıları, vCenter görevinin 5 numaralı TSDM hatasıyla başarısız olduğunu gösterir.DPD Sync in progress." ABV0016 ve ABV0006 ayrıntılar şunları gösterir:

Ana bilgisayarın başarısız yedeklemesiyle ilgili hataların ayrıntılar iletişim kutusu
ABV0016: VM Direct engine 'localhost' is unable to back up the virtual machine 'my-vm-name' on vCenter 'my-vcernter-name' because of a vCenter API issue.

The VM Direct engine cannot complete the backup of this virtual machine because of a vCenter API operation did not complete successfully.

To troubleshoot this issue: 1) Verify that the vCenter can be reached. 2) If the vCenter is busy, wait for some activities to complete and then retry the operation. 3) Verify that the virtual machine exists on the vCenter.

Read Less

Unable to cleanup from earlier backup attempt.  Unable to cleanup session 'Backup:6755cb99-3de5-4731-8b6f-6c64bb809f0b' from virtual machine 'my-vm-name' (MORef = 'vm-241').  Unable to cancel TSDM / LWD snapshot.  The vCenter task for 'Cancel SDM Snapshot' completed with state 'error':  DPD Sync in progress.
ABV0006: VM Direct engine 'localhost' is unable to back up the virtual machine 'my-vm-name' on vCenter 'my-vcernter-name' because of a vCenter API issue.

The VM Direct engine cannot complete the backup of this virtual machine because of a vCenter API operation did not complete successfully.

To troubleshoot this issue: 1) Verify that the vCenter can be reached. 2) If the vCenter is busy, wait for some activities to complete and then retry the operation. 3) Verify that the virtual machine exists on the vCenter.

Read Less

vCenter task 'task-943698' failed:  VimFault: 'dp.vpx.fault.SnapshotInProgress.summary': DPD Snapshot in progress
Yedekleme oturumu aşağıdaki durum çıktılarını gösterebilir:
...
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]   },
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]   "Status": {
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     "State": "Failure",
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     "Description": "Backup is unsuccessful:  Unable to cleanup from earlier backup attempt.  Unable to cleanup session 'Backup:6755cb99-3de5-4731-8b6f-6c64bb809f0b' from virtual machine 'vm-vm-name' (MORef = 'vm-241').  Unable to cancel TSDM / LWD snapshot.  The vCenter task for 'Cancel SDM Snapshot' completed with state 'error':  DPD Sync in progress",
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     "Progress": 0,
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     "Error": {
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Text": "Unable to cleanup from earlier backup attempt.  Unable to cleanup session 'Backup:6755cb99-3de5-4731-8b6f-6c64bb809f0b' from virtual machine 'vm-vm-name' (MORef = 'vm-241').  Unable to cancel TSDM / LWD snapshot.  The vCenter task for 'Cancel SDM Snapshot' completed with state 'error':  DPD Sync in progress",
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Code": 0,
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Classifications": [],
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Retryable": false,
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Remedy": null
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     },
...
...
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]   },
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]   "Status": {
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     "State": "Failure",
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     "Description": "Backup is unsuccessful:  vCenter task 'task-943698' failed:  VimFault: 'dp.vpx.fault.SnapshotInProgress.summary': DPD Snapshot in progress, TSDM snapshot UUID = '52031978-18dd-444a-37fd-9c070de84cc5'",
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     "Progress": 0,
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     "Error": {
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Text": "vCenter task 'task-943698' failed:  VimFault: 'dp.vpx.fault.SnapshotInProgress.summary': DPD Snapshot in progress, TSDM snapshot UUID = '52031978-18dd-444a-37fd-9c070de84cc5'",
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Code": 0,
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Classifications": [],
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Retryable": false,
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Remedy": null
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     },
...

Cause

Etkilenen VM'de, dpd daemon'daki tutarsızlıklar nedeniyle TSDM yedekleme iş akışının iptal edemediği artık bir vSphere Snapshot Data Mover (SDM) görevi var. Artık görevin veya dpd tutarsızlığının nedeni belirlenememiştir.

Resolution

dpd daemon, ESXi ana bilgisayarında yeniden başlatılmalı ve etkilenen VM'de SDM özelliği devre dışı bırakılıp etkinleştirilmelidir. Dpd daemon'ı yeniden başlatmadan önce sanal makine yedeği olmadığından emin olun:

  • ESXi ana bilgisayarına bir SSH oturumu açın.
  • Dpd daemon'ı yeniden başlatın: /etc/init.d/dpd restart
[root@my-server ~]# ssh root@my-esx
The authenticity of host 'my-esx (192.168.9.111)' can't be established.
ECDSA key fingerprint is SHA256:LHQVSVzDSw7ezlDVG59nyGD+C/Ugcx/jaSLMbzsY18U.
This key is not known by any other names
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
Warning: Permanently added 'my-esx' (ECDSA) to the list of known hosts.
(root@my-esx) Password:
The time and date of this login have been sent to the system logs.

WARNING:
   All commands run on the ESXi shell are logged and may be included in
   support bundles. Do not provide passwords directly on the command line.
   Most tools can prompt for secrets or accept them from standard input.

VMware offers powerful and supported automation tools. Please
see https://developer.vmware.com for details.

The ESXi Shell can be disabled by an administrative user. See the
vSphere Security documentation for more information.
[root@my-esx:~] /etc/init.d/dpd restart
Restarting dpd: dpd stopped.
Setting the memory limit for dpd resource pool on this host to 320 MB
Setting max number of file descriptors to 32768
Setting MALLOC_ARENA_MAX to 20
success
[root@my-esx:~]

 

Etkilenen VM'de SDM'yi devre dışı bırakmak ve etkinleştirmek için kullanabileceğiniz yöntemlerden bazıları aşağıda verilmiştir.

1. Yöntem

Etkilenen VM varlığı koruma mekanizmasını değiştirin.

  1. PowerProtect Data Manager da bir tarayıcı oturumu açın ve bir yönetici hesabıyla kimlik doğrulaması yapın.
  2. Infrastructure>Assets >Virtual Machines konumuna gidin.
  3. Etkilenen sanal makineyi seçin.
  4. Diğer Eylemler>Koruma Mekanizması>VADP'ye Geçiş açılır menüsünü seçin.
  5. vSphere Web Client, sanal makinenin Basit Delta (LWD) filtresini devre dışı bırakması için bir görev gösterir.
  6. More Actions>Protection Mechanism>Migrate to Transparent Snapshots açılır menüsünü seçin.
  7. vSphere Web İstemcisi, LWD filtresini etkinleştirmek için sanal makinenin bir görevi gösterir.
  8. Bir yedekleme çalıştırın veya zamanlanmış yedekleme yürütme işlemini izleyin.

2. Yöntem

Etkilenen sanal makineyi Koruma İlkesi'nden kaldırıp ekleyin.

  1. PowerProtect Data Manager da bir tarayıcı oturumu açın ve bir yönetici hesabıyla kimlik doğrulaması yapın.
  2. Infrastructure>Assets >Virtual Machines konumuna gidin.
  3. Etkilenen sanal makineyi seçin.
  4. More Actions>Remove from Policy açılır menüsünü seçin.
  5. vSphere Web Client, sanal makinenin Basit Delta (LWD) filtresini devre dışı bırakması için bir görev gösterir.
  6. More ActionsAdd to Policy açılır menüsünü seçin ve Koruma Politikasına > eklemek için sihirbazı izleyin.
  7. vSphere Web İstemcisi, LWD filtresini etkinleştirmek için sanal makinenin bir görevi gösterir.
  8. Bir yedekleme çalıştırın veya zamanlanmış yedekleme yürütme işlemini izleyin.

3. Yöntem

The PowerProtect Data Manager vmconfig Etkilenen VM'nin SDM özellik ayarını değiştirmek için komut satırı yardımcı programı kullanılabilir.

  • SSH'yi yönetici hesabıyla kullanarak PowerProtect Data Manager Cihazı'nda oturum açın:
     ssh admin@my-ppdm-name
  • Kök kullanıcıya geçin:
    sudo su 
  • Ortam değişkenlerini yükleyin:
    source /opt/emc/vproxy/unit/vproxy.env
  • vProxy bin dizinine geçin:
    cd /opt/emc/vproxy/bin/
  • İnşa et vmconfig komutunu parantez içindeki bilgileri değiştirerek kullanın:
    • VM durumunu kontrol edin:
./vmconfig -v <vcenter-ip-fqdn> -u '<vcenter-user-name>' -p '<vcenter-user-pwd>' -l dns -k <VM DNS name> -c info
  • VM'de SDM'yi devre dışı bırakın:
./vmconfig -v <vcenter-ip-fqdn> -u '<vcenter-user-name>' -p '<vcenter-user-pwd>' -l dns -k <VM DNS name> -c disable-sdm
  • VM'de SDM'yi etkinleştirin:
./vmconfig -v <vcenter-ip-fqdn> -u '<vcenter-user-name>' -p '<vcenter-user-pwd>' -l dns -k <VM DNS name> -c enable-sdm
  • Sorunun çözüldüğünü onaylamak için bir PowerProtect Data Manager TSDM yedeklemesi çalıştırın.

Additional Information

Eşitleme işlemiyle tutarsızlıkları gidermeye yardımcı olmak için dpd daemon'ında VMware geliştirmeleri yapılmıştır. Ortamın ESXi 7.0 U3o (22348816), ESXi 8.0 Ub (21203435) veya daha yeni bir sürüm çalıştırdığından emin olun.
Article Properties
Article Number: 000210949
Article Type: Solution
Last Modified: 14 Mar 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.