PowerProtect: Selhání zálohování virtuálního počítače, což signalizuje, že probíhá synchronizace DPD

Summary: Několik záloh prostředků virtuálního počítače začalo po úspěšném dokončení selhávat. Podrobnosti o chybě indikují, že úloha vCenter selže a zobrazí se chyba TSDM "DPD Sync in Progress". ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Nástroj PowerProtect Data Manager slouží k ochraně prostředí vSphere pomocí řešení TSDM (Transparent Snapshot Data Mover). Několik záloh prostředků virtuálních počítačů začalo selhávat, i když se v minulosti úspěšně dokončily. V podrobnostech o selhání je uvedeno, že úloha vCenter selže a dojde k chybě TSDM s chybou "DPD Sync in progress." Podrobnosti ABV0016 a ABV0006 zobrazují:

Dialogové okno s podrobnostmi o chybách nebo selhání zálohování hostitele
ABV0016: VM Direct engine 'localhost' is unable to back up the virtual machine 'my-vm-name' on vCenter 'my-vcernter-name' because of a vCenter API issue.

The VM Direct engine cannot complete the backup of this virtual machine because of a vCenter API operation did not complete successfully.

To troubleshoot this issue: 1) Verify that the vCenter can be reached. 2) If the vCenter is busy, wait for some activities to complete and then retry the operation. 3) Verify that the virtual machine exists on the vCenter.

Read Less

Unable to cleanup from earlier backup attempt.  Unable to cleanup session 'Backup:6755cb99-3de5-4731-8b6f-6c64bb809f0b' from virtual machine 'my-vm-name' (MORef = 'vm-241').  Unable to cancel TSDM / LWD snapshot.  The vCenter task for 'Cancel SDM Snapshot' completed with state 'error':  DPD Sync in progress.
ABV0006: VM Direct engine 'localhost' is unable to back up the virtual machine 'my-vm-name' on vCenter 'my-vcernter-name' because of a vCenter API issue.

The VM Direct engine cannot complete the backup of this virtual machine because of a vCenter API operation did not complete successfully.

To troubleshoot this issue: 1) Verify that the vCenter can be reached. 2) If the vCenter is busy, wait for some activities to complete and then retry the operation. 3) Verify that the virtual machine exists on the vCenter.

Read Less

vCenter task 'task-943698' failed:  VimFault: 'dp.vpx.fault.SnapshotInProgress.summary': DPD Snapshot in progress
Relace zálohování může vykazovat následující stavové výstupy:
...
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]   },
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]   "Status": {
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     "State": "Failure",
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     "Description": "Backup is unsuccessful:  Unable to cleanup from earlier backup attempt.  Unable to cleanup session 'Backup:6755cb99-3de5-4731-8b6f-6c64bb809f0b' from virtual machine 'vm-vm-name' (MORef = 'vm-241').  Unable to cancel TSDM / LWD snapshot.  The vCenter task for 'Cancel SDM Snapshot' completed with state 'error':  DPD Sync in progress",
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     "Progress": 0,
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     "Error": {
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Text": "Unable to cleanup from earlier backup attempt.  Unable to cleanup session 'Backup:6755cb99-3de5-4731-8b6f-6c64bb809f0b' from virtual machine 'vm-vm-name' (MORef = 'vm-241').  Unable to cancel TSDM / LWD snapshot.  The vCenter task for 'Cancel SDM Snapshot' completed with state 'error':  DPD Sync in progress",
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Code": 0,
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Classifications": [],
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Retryable": false,
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Remedy": null
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     },
...
...
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]   },
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]   "Status": {
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     "State": "Failure",
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     "Description": "Backup is unsuccessful:  vCenter task 'task-943698' failed:  VimFault: 'dp.vpx.fault.SnapshotInProgress.summary': DPD Snapshot in progress, TSDM snapshot UUID = '52031978-18dd-444a-37fd-9c070de84cc5'",
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     "Progress": 0,
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     "Error": {
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Text": "vCenter task 'task-943698' failed:  VimFault: 'dp.vpx.fault.SnapshotInProgress.summary': DPD Snapshot in progress, TSDM snapshot UUID = '52031978-18dd-444a-37fd-9c070de84cc5'",
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Code": 0,
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Classifications": [],
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Retryable": false,
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Remedy": null
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     },
...

Cause

Dotčený virtuální počítač má osamocenou úlohu vSphere Snapshot Data Mover (SDM), kterou pracovní postup zálohování TSDM nemůže zrušit kvůli nekonzistenci v démonovi dpd . Důvod osamoceného úkolu nebo nekonzistence dpd zůstává neidentifikovaný.

Resolution

Daemon dpd by měl být restartován na hostiteli ESXi a funkce SDM by měla být zakázána a povolena na dotčeném virtuálním počítači. Před restartováním daemona dpd se ujistěte, že nejsou k dispozici žádné zálohy virtuálního počítače:

  • Otevřete relaci SSH k hostiteli ESXi.
  • Restartujte daemona dpd : /etc/init.d/dpd restart
[root@my-server ~]# ssh root@my-esx
The authenticity of host 'my-esx (192.168.9.111)' can't be established.
ECDSA key fingerprint is SHA256:LHQVSVzDSw7ezlDVG59nyGD+C/Ugcx/jaSLMbzsY18U.
This key is not known by any other names
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
Warning: Permanently added 'my-esx' (ECDSA) to the list of known hosts.
(root@my-esx) Password:
The time and date of this login have been sent to the system logs.

WARNING:
   All commands run on the ESXi shell are logged and may be included in
   support bundles. Do not provide passwords directly on the command line.
   Most tools can prompt for secrets or accept them from standard input.

VMware offers powerful and supported automation tools. Please
see https://developer.vmware.com for details.

The ESXi Shell can be disabled by an administrative user. See the
vSphere Security documentation for more information.
[root@my-esx:~] /etc/init.d/dpd restart
Restarting dpd: dpd stopped.
Setting the memory limit for dpd resource pool on this host to 320 MB
Setting max number of file descriptors to 32768
Setting MALLOC_ARENA_MAX to 20
success
[root@my-esx:~]

 

Tady jsou některé z dostupných metod, jak zakázat a povolit SDM na dotčeném virtuálním počítači.

1. způsob

Změňte ovlivněný mechanismus ochrany prostředků virtuálního počítače.

  1. Otevřete relaci prohlížeče v PowerProtect Data Manager a ověřte se pomocí účtu správce.
  2. Přejděte na Infrastructure>Assets >Virtual Machines.
  3. Vyberte dotčený virtuální počítač.
  4. Vyberte rozevírací nabídku Další akce>Ochranný mechanismus>Migrace do VADP.
  5. Webový klient vSphere zobrazí úlohu pro virtuální počítač k zakázání filtru Lightweight Delta (LWD).
  6. Vyberte rozevírací nabídku Další akce>Ochranný mechanismus>Migrace na transparentní snímky.
  7. Webový klient vSphere zobrazí úlohu pro virtuální počítač k povolení filtru LWD.
  8. Spusťte zálohu nebo sledujte plánované spuštění zálohy.

2. způsob

Odeberte a přidejte ovlivněný virtuální počítač ze zásady ochrany.

  1. Otevřete relaci prohlížeče v PowerProtect Data Manager a ověřte se pomocí účtu správce.
  2. Přejděte na Infrastructure>Assets >Virtual Machines.
  3. Vyberte dotčený virtuální počítač.
  4. Vyberte rozevírací seznam Další akce>Remove from Policy.
  5. Webový klient vSphere zobrazí úlohu pro virtuální počítač k zakázání filtru Lightweight Delta (LWD).
  6. Vyberte rozevírací seznam Další akce>Přidat k zásadám a postupujte podle průvodce pro přidání do zásad ochrany.
  7. Webový klient vSphere zobrazí úlohu pro virtuální počítač k povolení filtru LWD.
  8. Spusťte zálohu nebo sledujte plánované spuštění zálohy.

Způsob 3

Nástroj PowerProtect Data Manager vmconfig Nástroj příkazového řádku lze použít ke změně nastavení funkce SDM pro dotčený virtuální počítač.

  • Přihlaste se do zařízení PowerProtect Data Manager pomocí SSH s účtem správce:
     ssh admin@my-ppdm-name
  • Změna na uživatele root:
    sudo su 
  • Načtěte proměnné prostředí:
    source /opt/emc/vproxy/unit/vproxy.env
  • Změňte adresář na bin vProxy:
    cd /opt/emc/vproxy/bin/
  • Sestavte vmconfig nahrazením informací v hranatých závorkách:
    • Zkontrolujte stav virtuálního počítače:
./vmconfig -v <vcenter-ip-fqdn> -u '<vcenter-user-name>' -p '<vcenter-user-pwd>' -l dns -k <VM DNS name> -c info
  • Zakažte SDM na virtuálním počítači:
./vmconfig -v <vcenter-ip-fqdn> -u '<vcenter-user-name>' -p '<vcenter-user-pwd>' -l dns -k <VM DNS name> -c disable-sdm
  • Povolte SDM na virtuálním počítači:
./vmconfig -v <vcenter-ip-fqdn> -u '<vcenter-user-name>' -p '<vcenter-user-pwd>' -l dns -k <VM DNS name> -c enable-sdm
  • Spusťte zálohování PowerProtect Data Manager TSDM a ověřte, zda je problém vyřešen.

Additional Information

V démonovi dpd došlo k vylepšení VMware, která pomáhají vyřešit nekonzistence při operaci synchronizace. Ujistěte se, že v prostředí běží ESXi 7.0 U3o (22348816), ESXi 8.0 Ub (21203435) nebo novější verze.
Article Properties
Article Number: 000210949
Article Type: Solution
Last Modified: 14 Mar 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.