PowerProtect: Mislukte VM-back-up wat aangeeft dat er een DPD-synchronisatie wordt uitgevoerd

Summary: Enkele back-ups van virtuele machines (VM's) van assets begonnen te mislukken nadat ze met succes waren voltooid. De foutdetails geven aan dat de vCenter-taak mislukt met een TSDM-fout die aangeeft dat DPD Sync bezig is. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

De PowerProtect Data Manager wordt gebruikt om de vSphere-omgeving te beschermen met de Transparent Snapshot Data Mover (TSDM)-oplossing. Enkele back-ups van VM-assets begonnen te mislukken, terwijl ze in het verleden met succes werden voltooid. De foutdetails geven aan dat de vCenter-taak mislukt met een TSDM-fout die aangeeft "DPD Sync in progress." De ABV0016 en ABV0006 details laten zien:

Details dialoogvenster met fouten van mislukte back-up van host
ABV0016: VM Direct engine 'localhost' is unable to back up the virtual machine 'my-vm-name' on vCenter 'my-vcernter-name' because of a vCenter API issue.

The VM Direct engine cannot complete the backup of this virtual machine because of a vCenter API operation did not complete successfully.

To troubleshoot this issue: 1) Verify that the vCenter can be reached. 2) If the vCenter is busy, wait for some activities to complete and then retry the operation. 3) Verify that the virtual machine exists on the vCenter.

Read Less

Unable to cleanup from earlier backup attempt.  Unable to cleanup session 'Backup:6755cb99-3de5-4731-8b6f-6c64bb809f0b' from virtual machine 'my-vm-name' (MORef = 'vm-241').  Unable to cancel TSDM / LWD snapshot.  The vCenter task for 'Cancel SDM Snapshot' completed with state 'error':  DPD Sync in progress.
ABV0006: VM Direct engine 'localhost' is unable to back up the virtual machine 'my-vm-name' on vCenter 'my-vcernter-name' because of a vCenter API issue.

The VM Direct engine cannot complete the backup of this virtual machine because of a vCenter API operation did not complete successfully.

To troubleshoot this issue: 1) Verify that the vCenter can be reached. 2) If the vCenter is busy, wait for some activities to complete and then retry the operation. 3) Verify that the virtual machine exists on the vCenter.

Read Less

vCenter task 'task-943698' failed:  VimFault: 'dp.vpx.fault.SnapshotInProgress.summary': DPD Snapshot in progress
De back-upsessie kan de volgende statusuitgangen weergeven:
...
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]   },
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]   "Status": {
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     "State": "Failure",
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     "Description": "Backup is unsuccessful:  Unable to cleanup from earlier backup attempt.  Unable to cleanup session 'Backup:6755cb99-3de5-4731-8b6f-6c64bb809f0b' from virtual machine 'vm-vm-name' (MORef = 'vm-241').  Unable to cancel TSDM / LWD snapshot.  The vCenter task for 'Cancel SDM Snapshot' completed with state 'error':  DPD Sync in progress",
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     "Progress": 0,
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     "Error": {
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Text": "Unable to cleanup from earlier backup attempt.  Unable to cleanup session 'Backup:6755cb99-3de5-4731-8b6f-6c64bb809f0b' from virtual machine 'vm-vm-name' (MORef = 'vm-241').  Unable to cancel TSDM / LWD snapshot.  The vCenter task for 'Cancel SDM Snapshot' completed with state 'error':  DPD Sync in progress",
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Code": 0,
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Classifications": [],
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Retryable": false,
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]       "Remedy": null
YYYY-MM-DD HH:MM:SS INFO:   [acae20b6ae1ca9c8;aac63ea8d0fb1d9e]     },
...
...
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]   },
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]   "Status": {
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     "State": "Failure",
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     "Description": "Backup is unsuccessful:  vCenter task 'task-943698' failed:  VimFault: 'dp.vpx.fault.SnapshotInProgress.summary': DPD Snapshot in progress, TSDM snapshot UUID = '52031978-18dd-444a-37fd-9c070de84cc5'",
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     "Progress": 0,
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     "Error": {
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Text": "vCenter task 'task-943698' failed:  VimFault: 'dp.vpx.fault.SnapshotInProgress.summary': DPD Snapshot in progress, TSDM snapshot UUID = '52031978-18dd-444a-37fd-9c070de84cc5'",
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Code": 0,
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Classifications": [],
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Retryable": false,
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]       "Remedy": null
YYYY-MM-DD HH:MM:SS INFO:   [a3f45e322add25ec;bb6e18b9d1e8178c]     },
...

Cause

De getroffen VM heeft een zwevende vSphere Snapshot Data Mover (SDM)-taak die de TSDM-back-upworkflow niet kan annuleren vanwege inconsistenties in de dpd-daemon . De reden voor de verweesde taak of dpd-inconsistentie blijft onbekend.

Resolution

De dpd-daemon moet opnieuw worden gestart op de ESXi-host en de SDM-functie moet worden uitgeschakeld en ingeschakeld op de betreffende VM. Zorg ervoor dat er geen back-ups van virtuele machines zijn voordat u de dpd-daemon opnieuw opstart:

  • Open een ssh-sessie naar de ESXi-host.
  • Start de dpd-daemon opnieuw op: /etc/init.d/dpd restart
[root@my-server ~]# ssh root@my-esx
The authenticity of host 'my-esx (192.168.9.111)' can't be established.
ECDSA key fingerprint is SHA256:LHQVSVzDSw7ezlDVG59nyGD+C/Ugcx/jaSLMbzsY18U.
This key is not known by any other names
Are you sure you want to continue connecting (yes/no/[fingerprint])? yes
Warning: Permanently added 'my-esx' (ECDSA) to the list of known hosts.
(root@my-esx) Password:
The time and date of this login have been sent to the system logs.

WARNING:
   All commands run on the ESXi shell are logged and may be included in
   support bundles. Do not provide passwords directly on the command line.
   Most tools can prompt for secrets or accept them from standard input.

VMware offers powerful and supported automation tools. Please
see https://developer.vmware.com for details.

The ESXi Shell can be disabled by an administrative user. See the
vSphere Security documentation for more information.
[root@my-esx:~] /etc/init.d/dpd restart
Restarting dpd: dpd stopped.
Setting the memory limit for dpd resource pool on this host to 320 MB
Setting max number of file descriptors to 32768
Setting MALLOC_ARENA_MAX to 20
success
[root@my-esx:~]

 

Hier zijn enkele van de beschikbare methoden om de SDM op de betreffende VM uit en in te schakelen.

Methode 1

Wijzig het beschermingsmechanisme voor de betreffende VM-activa.

  1. Open een browsersessie voor PowerProtect Data Manager en verifieer met een beheerdersaccount.
  2. Ga naar Infrastructuur>, Assets >, Virtuele machines.
  3. Selecteer de betreffende virtuele machine.
  4. Selecteer de vervolgkeuzelijst More Actions>Protection Mechanism>Migrate to VADP.
  5. De vSphere Web Client toont een taak voor de virtuele machine om het Lightweight Delta (LWD)-filter uit te schakelen.
  6. Selecteer de vervolgkeuzelijst Meer acties>Beschermingsmechanisme>migreren naar transparante snapshots.
  7. De vSphere Web Client toont een taak voor de virtuele machine om het LWD-filter in te schakelen.
  8. Een back-up uitvoeren of de geplande uitvoering van de back-up controleren.

Methode 2

Verwijder de betreffende VM en voeg deze toe aan het beveiligingsbeleid.

  1. Open een browsersessie voor PowerProtect Data Manager en verifieer met een beheerdersaccount.
  2. Ga naar Infrastructuur>, Assets >, Virtuele machines.
  3. Selecteer de betreffende virtuele machine.
  4. Selecteer de vervolgkeuzelijst Meer acties>Verwijderen uit beleid.
  5. De vSphere Web Client toont een taak voor de virtuele machine om het Lightweight Delta (LWD)-filter uit te schakelen.
  6. Selecteer de vervolgkeuzelijst Meer acties>toevoegen aan beleid en volg de wizard om toe te voegen aan het beveiligingsbeleid.
  7. De vSphere Web Client toont een taak voor de virtuele machine om het LWD-filter in te schakelen.
  8. Een back-up uitvoeren of de geplande uitvoering van de back-up controleren.

Methode 3

De PowerProtect Data Manager vmconfig Opdrachtregelhulpprogramma kan worden gebruikt om de SDM-functie-instelling voor de betreffende VM te wijzigen.

  • Meld u aan bij PowerProtect Data Manager Appliance met SSH met het beheerdersaccount:
     ssh admin@my-ppdm-name
  • Verander naar de rootgebruiker:
    sudo su 
  • Laad de omgevingsvariabelen:
    source /opt/emc/vproxy/unit/vproxy.env
  • Ga naar de vProxy bin-directory:
    cd /opt/emc/vproxy/bin/
  • Bouw de vmconfig opdracht door de informatie tussen haakjes te vervangen:
    • Controleer de VM-status:
./vmconfig -v <vcenter-ip-fqdn> -u '<vcenter-user-name>' -p '<vcenter-user-pwd>' -l dns -k <VM DNS name> -c info
  • Schakel SDM uit op de VM:
./vmconfig -v <vcenter-ip-fqdn> -u '<vcenter-user-name>' -p '<vcenter-user-pwd>' -l dns -k <VM DNS name> -c disable-sdm
  • Schakel SDM in op de VM:
./vmconfig -v <vcenter-ip-fqdn> -u '<vcenter-user-name>' -p '<vcenter-user-pwd>' -l dns -k <VM DNS name> -c enable-sdm
  • Voer een PowerProtect Data Manager TSDM-back-up uit om te bevestigen dat het probleem is opgelost.

Additional Information

Er zijn VMware-verbeteringen in de dpd-daemon om inconsistenties met de synchronisatiebewerking op te lossen. Zorg ervoor dat in de omgeving ESXi 7.0 U3o (22348816), ESXi 8.0 Ub (21203435) of een nieuwere release wordt uitgevoerd.
Article Properties
Article Number: 000210949
Article Type: Solution
Last Modified: 14 Mar 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.