OpenManage Enterprise:4.0 遷移失敗,並顯示「無法解密備份歸檔」

Summary: 在某些遷移案例中,OpenManage Enterprise 4.0 目標匯入作業可能會失敗,並在遷移期間出現錯誤「無法解密備份歸檔」。使用下列文章可協助進行故障診斷此狀況,以及解決故障的各種方法。

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Symptoms

從目標開始「遷移入」後不久,匯入似乎突然停止,並顯示登入畫面。

重新登入 Web 使用者介面後,會顯示下列黃色橫幅: 
Last Import job failed. Click on view logs for details.
上次匯入工作失敗橫幅
 
按一下 檢視記錄 連結,會帶出匯入工作的詳細資料,並出現下列錯誤:
Unable to decrypt the backup file. Please check the provided encryption passphrase.
Failed to perform import task. 
匯入工作失敗詳細資料,顯示解密錯誤

Cause

存在以下幾種情況,其中遷移導入操作可能會因解密錯誤而失敗。它們如下:
  • 案例 1:匯出檔案之間的雜湊比較失敗
  • 案例 2:在「遷移入」操作期間使用了不正確的密碼片語

Resolution

若要進一步瞭解可能導致解密錯誤的原因,請先從 OpenManage Enterprise 4.0 版 (目標) Web 介面下載主控台記錄套裝。

  1. 瀏覽至 監控 ->故障診斷 ->記錄
  2. 按一下「產生記錄」 按鈕,並等待記錄收集工作完成。
  3. 記錄套裝可用後,按一下「 下載記錄」,然後將壓縮檔案儲存至本機位置。
  4. 解壓縮 主控台記錄套裝
  5. 解壓縮完成後,請瀏覽至。\backuprestoreservice 資料夾,然後開啟 ome_encryption_decryption.log

案例 1:雜湊比較失敗:

隨著 ome_encryption_decryption 記錄檔開啟,如果來源裝置和目標裝置之間的備份檔案檢查總和不相符,則會顯示下列錯誤。

2024.01.05-21:20:09 ome_backup_encryption - error: Hash comparison failed 

如果記錄中出現此錯誤,請 將目標裝置更新為版本 4.0.1,然後重試遷移。

 

案例 2:在「遷移入」作業期間使用了不正確的密碼片語:

隨著 ome_encryption_decryption 記錄檔開啟,如果在目標裝置上輸入不正確的密碼片語,則會顯示下列錯誤。

2024.01.25-15:44:02 ome_backup_encryption - Decryption command result -> 2 

此密碼片語用於來源備份檔案加密期間。目標裝置上必須使用相同的密碼片語來解密備份檔案。 

  1. 在來源裝置中,瀏覽至 備份-還原 ->遷移 - 移出,然後 展開 步驟 4
  2. 按一下 「中止遷移」 連結以取消遷移,並將來源裝置回到 「就緒」 狀態。
  3. 步驟 3 重新啟動遷移操作,並確保源設備上使用的密碼與在目標設備上為“遷移入”操作輸入的密碼相同。  

在目標裝置上遷移期間成功解密來源檔會顯示 結果代碼 0:

2024.01.05-21:20:09 ome_backup_encryption - Decryption command result -> 0

Affected Products

Dell EMC OpenManage Enterprise

Products

C Series, Modular Infrastructure, Rack Servers, Tower Servers, XE Servers, XR Servers, OEM Server Solutions
Article Properties
Article Number: 000221490
Article Type: Solution
Last Modified: 06 May 2025
Version:  3
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