Known issues, environmental and system requirements, and installation or update considerations that are associated with these patch releases are the same as the parent release. For more information, see the Dell PowerProtect Data Domain Operating System, PowerProtect Data Domain Virtual Edition, PowerProtect DD Management Center, DD BoostFS, and DD Boost OpenStorage (OST) 8.3.0.15 Release Notes (Requires Dell Online Support login).
Release Revision History
| Release |
Description |
| 8.3.1.50 |
- Initial release of 8.3.1.50 (September 2026)
|
| 8.3.1.45 |
- Initial release of 8.3.1.45 (August 2026)
|
| 8.3.1.40 |
- Initial release of 8.3.1.40 (June 2026)
|
| 8.3.1.30 |
- Initial release of 8.3.1.30 (April 2026)
|
| 8.3.1.20 |
- Initial release of 8.3.1.20 (December 2025)
|
| 8.3.1.10 |
- Initial release of 8.3.1.10 (September 2025)
|
| 8.3.1.0 |
- Initial release of 8.3.1.0 (June 2025)
|
8.3.1.50 Release (September 2026)
Associated Build Versions
- DDOS Build: 8.3.1.50
- DDVE Build: 8.3.1.50
- DDMC Build: 8.3.1.50
- BoostFS Build: 8.3.1.50
- OST Build: 8.3.1.50
DDOS Cloud
| Fixed Issue |
Description |
| DDOSCFD-19282 |
Fixed an issue where a race condition between the Garbage Collection (GC) copy phase and the Object Existence Check (OEC) caused false alerts for missing objects in the cloud tier. |
| DDOSCFD-32842 |
Fixed an issue where restore operations using NetWorker for SAP MaxDB and HANA backups stored on DDVE in ATOS AWS experienced significantly poor throughput. |
PDD09I-1959
|
Fixed an issue where Data Domain High Availability (DDHA) systems were unable to integrate successfully with Dell AIOps. |
DDOS File System
| Fixed Issue |
Description |
| DDOSCFD-26606 |
Fixed an issue in DDOS 7.10 where index corruption occurred, resulting in a fatal error: "ddr/index/ss_index_mbuf.c: ssim_load_bucket_thread: 3197: Fatal Error." |
| DDOSCFD-27907 |
Fixed an issue where searching a LNS full key with a CHILDID greater than 4 billion in a LNS upgraded btree on an old format Interior (INT) page caused a system PANIC. |
DDOSCFD-28990
|
Fixed an issue where the B-Tree implementation inconsistently handled empty pages across intermediate page levels, leading to a keyspace gap between intermediate pages (INT2, INT3). |
DDOSCFD-31088
|
Fixed an issue where DS60 LCCs retained an outdated Init String image despite having up-to-date expander firmware and FPGA images. |
DDOSCFD-31193
|
Fixed an issue where importing an HTTPS certificate via a PKCS12 file with a password different from the system passphrase resulted in the imported certificate not being applied to Apache. |
DDOSCFD-31714
|
Fixed an issue on DM5500 where the Data Domain File System (DDFS) failed to start after a disk replacement. |
DDOSCFD-31854
|
Fixed an issue where DP4400 DDVE was going down repeatedly. |
DDOSCFD-31956
|
Fixed an issue where the alert "EVT-ICD-00001: Coredump analysis settings may have changed during upgrade" was consistently generated after every Data Domain upgrade. |
DDOSCFD-32459
|
Fixed an issue where running the sfs_dump -i command on a CyberSense or Cyber Recovery system caused a DDFS panic, resulting in an unexpected system restart. |
DDOSCFD-32986
|
Fixed an issue where SNMP queries from Avamar to a Data Domain system were intermittent, with disk-related queries taking longer than 30 seconds to respond. |
PDD05D-1113
|
Fixed an issue where Active Directory (AD) users were unable to log in to the Data Domain system in a multi-domain forest environment when the Global Catalog (GC) was hosted on a child domain. |
DDOS Network
| Fixed Issue |
Description |
PDD09I-2005
|
Fixed an issue on DD3300 where the filesystem went down due to the /ddr/ext partition becoming full. |
PDD16B-688
|
Fixed an issue where firmware-level LLDP on Intel network interfaces caused NETDEV WATCHDOG timeout (tx_timeout) errors when the interface was added to a bond. |
PDD16B-766
|
Fixed an issue where the net filter output was truncated when copying protocol and port information. |
DDOS Platform
| Fixed Issue |
Description |
| DDOSCFD-32306 |
Fixed an issue where upgrading DDOS from version 8.6.1.10 to 8.6.1.20 on the DD3300 platform failed with the error: "System upgrade failure: An internal error occurred." |
PDD09I-2047
|
Fixed an issue where the Data Domain system continued to send Autosupport notifications to Elysium after upgrading DDOS to version 8.3, despite the Autosupport setting being explicitly disabled (support_notify = false). |
PDDDF-8218
|
Fixed an issue where Data Domain High Availability (DDHA) systems entered a degraded state after a DDOS upgrade. |
8.3.1.45 Release (August 2026)
Associated Build Versions
- DDOS Build: 8.3.1.45-1260667
- DDVE Build: 8.3.1.45-1260667
- DDMC Build: 8.3.1.45-1260667
- BoostFS Build: 8.3.1.40-1247028
- OST Build: 8.3.1.40-1246152
DDOS Platform
| Fixed Issue |
Description |
| DDOSCFD-32306 |
Fixed an issue where upgrading DDOS from version 8.6.1.10 to 8.6.1.20 on the DD3300 platform failed with the error: "System upgrade failure: An internal error occurred." The upgrade now completes successfully without interruption. |
8.3.1.40 Release (June 2026)
Associated Build Versions
- DDOS Build: 8.3.1.40-1247360
- DDVE Build: 8.3.1.40-1247360
- DDMC Build: 8.3.1.40-1247360
- BoostFS Build: 8.3.1.40-1247028
- OST Build: 8.3.1.40-1246152
DDOS Cloud
| Fixed Issue |
Description |
| DDOSCFD-30100 |
Fixed an issue where the file system detected missing cloud data and reported a cloud corruption alert. |
DDOS File System
| Fixed Issue |
Description |
| DDOSCFD-30310 |
Fixed an issue causing the file system to restart with a PANIC due to high read counts on the Data Domain. |
| DDOSCFD-30800 |
Fixed an issue that caused a file system error, resulting in a panic alert and a system restart. |
| PDD09I-1254 |
Fixed an issue where the clock moved backwards and caused the file system to go offline due to a manual NTP sync. |
DDOS General
| Fixed Issue |
Description |
| DDOSCFD-28221 |
Fixed an issue where upgrading the DDOS caused SupportAssist to be removed from the configuration and could not be reconfigured later. |
| PDD09I-1246 |
Fixed an issue where SupportAssist failed during upgrades from ConnectEMC. |
| PDD09I-1300 |
Fixed an issue where the SupportAssist configuration disabled the second gateway after the OS upgrade. |
DDOS Network
| Fixed Issue |
Description |
| DDOSCFD-30211 |
Fixed an issue causing the DM5510 installation to fail with error code CONN0064 during the configuration phase. |
| DDOSCFD-30358 |
Fixed an issue where the ethMd speed did not match the actual speed. |
| DDOSCFD-30653 |
Fixed an issue where the routes were missing from the route table after the upgrade. |
| PDD05D-1044 |
Fixed an issue where intermittent access problems caused CIFS and NFS shares and services on the DD to crash. |
DDOS Platform
| Fixed Issue |
Description |
| DDOSCFD-29432 |
Fixed an issue where memory corruption occurred when routing table output titles exceeded the max array increment position, causing issues when many routes were added. |
| DDOSCFD-29891 |
Fixed an issue where "net filter delete all" failed to remove custom rules after deleting default rules. |
| DDOSCFD-30096 |
Fixed an issue where the command net filter show seq-id-list all caused the DDSH client to become unresponsive when presented with a long client list. |
| DDOSCFD-30662 |
Fixed an issue where PEM was unresponsive to SMS queries. |
| PDD09I-1446 |
Fixed an issue where historical alerts could not be filtered in the DDSM WebUI. |
DDOS Storage
| Fixed Issue |
Description |
| DDOSCFD-30290 |
Fixed an issue causing a deadlock during management and I/O operations on the same disk group |
| PDD09G-1377 |
Fixed an issue causing a kernel panic due to an out-of-memory (OOM) crash |
8.3.1.30 Release (April 2026)
Associated Build Versions
- DDOS Build: 8.3.1.30-1226406
- DDVE Build: 8.3.1.30-1226406
- DDMC Build: 8.3.1.30-1226406
DDOS Cloud
| Fixed Issue |
Description |
| DDOSCFD-29408 |
Fixed an issue where a panic occurred when the max length verification failed. |
DDOS File system
| Fixed Issue |
Description |
| DDOSCFD-26997 |
Fixed an issue where the DD FS becomes unresponsive when attempting to perform a CR recovery. |
| DDOSCFD-29161 |
Fixed an issue with a write stream leak that occurred during attribute "btree" thrashing. |
| DDOSCFD-29826 |
Fixed an issue that created DDFS single panic due to divide error. |
DDOS General
| Fixed Issue |
Description |
| DDOSCFD-29639 |
Fixed an issue where the UI encountered a TypeError when attempting to read a null property, causing an error. |
| PDD09I-1262 |
Fixed an issue where the DD REST API was failing to add hosts for Service Logs. |
DDOS Platform
| Fixed Issue |
Description |
| PDD09I-1225 |
Fixed an issue where false alerts were being generated about failed connectivity to the Secure Remote Services gateway when SupportAssist was configured. |
DDOS Replication
| Fixed Issue |
Description |
| DDOSCFD-27285 |
Fixed an issue where the destination DD returns failures during Guaranteed Replication. |
8.3.1.20 Release (December 2025)
Associated Build Versions
- DDOS Build: 8.3.1.20-1208918
- DDVE Build: 8.3.1.20-1208918
- DDMC Build: 8.3.1.20-1208918
- BoostFS Build: 8.3.1.20-1206809
- OST Build: 8.3.1.20-1206696
DDOS Cloud
| Fixed Issue |
Description |
| DDOSCFD-23184 |
Fixed an issue where cloud garbage collection failed on upgraded DD systems due to inconsistent object formats. |
DDOS File system
| Fixed Issue |
Description |
| DDOSCFD-28266 |
Fixed an issue where a panic occurred when attempting to create a hard link to a snapshot. |
| PDD05D-555 |
Fixed an issue where the sync password on AD failed during AD join operation. |
DDOS General
| Fixed Issue |
Description |
| CPE08A-410 |
Fixed an issue where multiple disk failures occurred after upgrading the LCC FW due to a timing issue. |
DDOS Network
| Fixed Issue |
Description |
| PDD09I-842 |
Fixed an issue where SNMPv3 traps failed to work after upgrading DDOS. |
DDOS Security
| Fixed Issue |
Description |
| DDOSCFD-25422 |
Fixed an issue where changing the passphrase would cause the UI to restart and trigger an alert when using self-signed certificates. |
| DDOSCFD-28978 |
Fixed an issue where the MFA troubleshooting user was unable to log in to the DD UI due to insufficient privileges. |
| PDD09I-893 |
Fixed an issue where the autosupport command allowed sending sensitive information to an external email address. |
| PDD09I-899 |
Fixed an issue where FD leaks occurred. |
| PDD09I-900 |
Fixed an issue in SupportAssist |
DD Boost
| Fixed Issue |
Description |
| DDOSCFD-27672 |
Fixed an issue where Data DomainBoost Avamar backup failures occurred due to SSL certificate and encryption issues between Avamar and Data Domain, requiring certificate regeneration. |
DDMC
| Fixed Issue |
Description |
| PDD09I-901 |
Fixed an issue where the PowerProtect DD Management Center graphs were not updating as expected on the Data Domain platform. |
DDVE
| Fixed Issue |
Description |
| DDOSCFD-28546 |
Fixed object‑storage authorization failures caused by truncation of the Azure OAuth2.0 access token on Dell Data Domain Virtual Edition (DDVE) instances running in Azure |
8.3.1.10 Release (September 2025)
Associated Build Versions
- DDOS Build: 8.3.1.10-1194895
- DDVE Build: 8.3.1.10-1194895
- DDMC Build: 8.3.1.10-1194895
- BoostFS Build: 8.3.1.10-1192891
- OST Build: 8.3.1.10-1192791
DDOS
Unsupported Feature
| Feature |
Description |
| ConnectEMC |
ConnectEMC is no longer supported and has been replaced by SupportAssist. For more details on using the SupportAssist user interface, refer to the DD Operating System Administration Guide. |
DDOS File system
| Fixed Issue |
Description |
| DDOSCFD-24993 |
Fixed an issue where backups to PDC Data Domain DD9900 were slow, resulting in a performance issue. |
| DDOSCFD-26935 |
Fixed an issue where no disk failure alert EVT-STORAGE-00002 was being posted if a DD_RAID_WRITE_ERROR was encountered. DD_RAID_READ_ERRORs were not impacted. |
| DDOSCFD-27532 |
Fixed an issue where a file system panic occurred due to running out of memory in the cache element pool. |
DDOS General
| Fixed Issue |
Description |
| DDOSCFD-26030 |
Fixed an issue where backup operations failed due to the application running out of memory. |
| CPE08B-293 |
Fixed an issue where the health score dropped by 20 points, displaying an error message. |
| CPE08H-328 |
Fixed an issue where some endpoints remained offline after a DD reboot or failover, even when the physical port was online. |
| CPE08H-333 |
SCSITGTD now monitors and recovers offline FC ports during HA standby node bootup. |
DDOS Network
| Fixed Issue |
Description |
| DDOSCFD-26340 |
Removed support for the CBC cipher on port 3013, as part of an effort to eliminate weak SSL cipher suites. |
| DDOSCFD-25286 |
Fixed an issue where the initiator was not populating when directly connected to a DD FC port. |
| PDD05D-370 |
Fixed an issue where Kerberos authentication failed when joining Active Directory machines upgraded to Windows 2025 with PowerProtect DD. |
| PDD05D-375 |
Fixed an issue where the Standby Node lost connection to AD after the machine account password was changed. |
| PDD09I-447 |
Fixed an issue where SNMP traps fail after DDOS upgrade. |
DDOS Platform
| Fixed Issue |
Description |
| DDOSCFD-26395 |
Fixed an issue where no alert was generated when a disk failure occurred. |
| DDOSCFD-23041 |
Resolved a boot issue on DD3300 after upgrade or reboot |
| PDD09I-300 |
Fixed an issue where there was a kernel panic due to memory leaks. |
DDOS Security
| Fixed Issue |
Description |
| PDD06D-445 |
Fixed an issue where different error messages were displayed when a user provided an invalid username or password. |
| PDD06D-448 |
Fixed an issue where an inconsistent response time was observed on the login page on user search. |
| PDD09F-530 |
Fixed an issue where an integer wraparound in the elicense update command could cause a heap overflow. |
| PDD09I-452 |
Resolved an issue where the PIN used for SCG was being logged during configuration through the user interface. |
DDMC
Unsupported Feature
| Feature |
Description |
| Smart Scale |
The Smart Scale feature is not supported in this release and has been officially deprecated. NOTE: There is no upgrade path available to reenable or access this feature in future versions. |
8.3.1.0 Release (June 2025)
Associated Build Versions
- DDOS Build: 8.3.1.0-1175411
- DDVE Build: 8.3.1.0-1175411
- DDMC Build: 8.3.1.0-1175411
DDOS Cloud
| Fixed Issue |
Description |
| DDOSCFD-24896 |
Resolved an issue where data was deleted due to the timestamp being set to a garbage value. |
| PDD02C-125 |
Fixed an issue where migration compatibility checks did not compare the source and destination cloud capacity. |
DDOS File system
| Fixed Issue |
Description |
| DDOSCFD-21785 |
Resolved an issue where there was a file system panic and restart. |
| DDOSCFD-24404 |
Fixed an issue where the total number of used streams is over the Data Domain total streams. |
| DDOSCFD-25498 |
Fixed an issue where RAID PANIC occurred due to total failure of HU DG. |
DDOS General
| Fixed Issue |
Description |
| DDOSCFD-23619 |
Fixed an issue where the '@' character was not supported in the user interface. |
| DDOSCFD-25226 |
Resolved an issue where there was a kernel panic due to slow disk. |
| DDOSCFD-25396 |
Resolved an issue where the PowerProtect DD Management Center user interface showed all replication contexts in error state. |
| DDOS-286484 |
Resolved an issue where the storage page was unable to load the content. |
| DDOS-288108 |
Resolved an issue where the "date" field was missing in mails. |
| DDOS-289341 |
Resolved an issue where SupportAssist registration was failing due to Direct Dell Backend URL not being accessible. |
| DDOS-289531 |
Fixed an issue where alerts about exceeding file system licensed capacity appeared after upgrading to version 5.19.0.0. |
| DDOS-290018 |
Fixed an issue where there was a wrong URL link in Configure SupportAssist. |
| DDOS-290314 |
Resolved an issue where the notification method was set to mail after upgrade. |
| DDOS-290378 |
Fixed an issue where remote support was disabled after upgrade. |
DDOS Network
| Fixed Issue |
Description |
| DDOSCFD-24480 |
Resolved an issue wherein user could not disable DD Boost using REST API limited-admin user token. |
| DDOSCFD-25302 |
Fixed an issue where the External LAN Heartbeat status on HA appliances was displaying "not ok." |
DDOS Platform
| Fixed Issue |
Description |
| DDOS-290263 |
Resolved an issue where disk failure alerts were not sent to CloudIQ. |
DDOS Replication
| Fixed Issue |
Description |
| DDOSCFD-22521 |
Fixed an issue where the migration precheck failed to validate if the destination storage is less than the source storage. |
| DDOSCFD-24320 |
Fixed an issue where the replication break all command did not require security officer credentials, even when retention lock compliance mode was on. |
| DDOSCFD-25510 |
Fixed an issue where the system displayed an inaccurate replication status due to mismatched source and destination replication IDs. |
DDOS Security
| Fixed Issue |
Description |
| DDOSCFD-24775 |
Fixed an issue where after upgrading the DDOS, the value of the server port was reset to the default value. |
| DDOSCFD-25454 |
Fixed an issue where there was a DDOS upgrade failure from 8.1.0.011 to 8.3.0.15 due to missing /ddvar/certificates |
| DDOSCFD-25609 |
Fixed an issue where AD users could not log in to the Data Domain CLI or SSH. |
| DDOSCFD-26086 |
Resolved an issue where the PIN used for SCG was being logged during configuration through the user interface. |