DPA: Mancata riuscita delle data collection di Data Domain con il messaggio "Impossibile aprire la sessione SNMP per l'host"

Summary: Data Protection Advisor (DPA): Errore delle data collection di Data Domain con il messaggio "Failed to open SNMP session for host".

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Quando si tenta di rilevare un Data Domain (DD), con DPA viene restituito il seguente messaggio di errore:
 

failed to open SNMP session for host



Quando si esegue la richiesta di raccolta, nel debug dall'interfaccia utente vengono restituite le seguenti informazioni nel dpaagent.log:
 

DBG1    12723.12723    20190724:144105             com.snmp - aapiSNMPOpen(): Overriding SNMP timeout to 10 seconds
DBG1    12723.12723    20190724:144105             com.snmp - aapiSNMPOpen(): Failed to open SNMP session for host 'dd01.emc.lab', errno 0, snmp_error 'Unknown host (host_name)'
DBG1    12723.12723    20190724:144105         agent.mod.dd - perf_snmp(): aapiSNMPOpen() failed 

Cause

L'agent DPA non è in grado di risolvere il nome host DD, pertanto non è in grado di connettersi al servizio SNMP su DD.

Resolution

Per confermare che la risoluzione dei nomi è il problema, il comando nslookup può essere eseguito sul server dell'agent utilizzando l FQDN DD. Se l'indirizzo IP non viene restituito, ciò conferma che il problema è la risoluzione dei nomi. 

Esistono due modi per risolvere i problemi di risoluzione dei nomi. 

1. Creare il record A nel server DNS in modo che l'FQDN venga risolto correttamente. 

2. Aggiungere il DD al file hosts sul server dell'agent e verificare che il sistema operativo sia stato abilitato per controllare il file host e il DNS.

Per ulteriori dettagli o informazioni, contattare il Supporto Dell .
 

Article Properties
Article Number: 000168511
Article Type: Solution
Last Modified: 23 Jun 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.