AppSync : LDAP Configuration Fails org.jboss.resteasy.client.exception.ResteasyInternalServerErrorException : Erreur de serveur interne HTTP 500

Summary: Après avoir renseigné tous les paramètres et cliqué sur le bouton Apply, un message d’erreur s’affiche au bout de 4 à 5 minutes lors de la configuration d’un nouveau LDAP dans AppSync. Le processeur et la RAM restent élevés. Message d’erreur reçu en cas d’échec de la configuration LDAP : org.jboss.resteasy.client.exception.ResteasyInternalServerErrorException : Erreur de serveur interne HTTP 500 ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

À partir du fichier log du serveur AppSync :
<Date-time> INFO [default task-8] [com.emc.archway.services.iamservice.KeycloakService] [AppSync server] [] b98e9897-2f9d-4e0f-8f03-f2c3cbc8a190->>> LDAP group sync status is 19999 imported groups, 0 updated groups, 0 removed groups using mapper AppSync LDAP Group Mapper
Ensuite, nous voyons l’erreur :
<Date-time> ERROR [default task-2] [org.jboss.as.ejb3.invocation] [AppSync server] [] WFLYEJB0034: Jakarta Enterprise Beans Invocation failed on component KeycloakService for method public abstract com.emc.archway.securityInterface.LDAP com.emc.archway.securityInterface.IAMService.getLDAPAuthority(com.emc.archway.context.ExecutionContext,java.util.UUID) throws com.emc.archway.errorMessages.ResourceNotFound: javax.ejb.EJBException: org.jboss.resteasy.client.exception.ResteasyInternalServerErrorException: HTTP 500 Internal Server Error

Cause

La limite est de 20 000 groupes et 19 999 groupes en sont affichés.

Resolution

Modifiez le chemin de recherche des groupes AppSync afin qu’AppSync n’examine pas d’autres groupes, puis réessayez d’ajouter les paramètres. Le problème est résolu en réduisant le chemin de recherche des utilisateurs et des groupes.

Affected Products

AppSync

Products

Data Backup & Protection Software
Article Properties
Article Number: 000228907
Article Type: Solution
Last Modified: 10 Sep 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.