AppSync:LDAP 配置失败 org.jboss.resteasy.client.exception.ResteasyInternalServerErrorException:HTTP 500 内部服务器错误

Summary: 在 AppSync 中配置新 LDAP 时,填写所有参数并单击应用按钮后,4-5 分钟后会收到错误消息。CPU 和 RAM 仍然很高。 LDAP 配置失败时收到错误消息:org.jboss.resteasy.client.exception.ResteasyInternalServerErrorException:HTTP 500 内部服务器错误

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

在 AppSync 服务器日志中:
<Date-time> INFO [default task-8] [com.emc.archway.services.iamservice.KeycloakService] [AppSync server] [] b98e9897-2f9d-4e0f-8f03-f2c3cbc8a190->>> LDAP group sync status is 19999 imported groups, 0 updated groups, 0 removed groups using mapper AppSync LDAP Group Mapper
然后我们看到错误:
<Date-time> ERROR [default task-2] [org.jboss.as.ejb3.invocation] [AppSync server] [] WFLYEJB0034: Jakarta Enterprise Beans Invocation failed on component KeycloakService for method public abstract com.emc.archway.securityInterface.LDAP com.emc.archway.securityInterface.IAMService.getLDAPAuthority(com.emc.archway.context.ExecutionContext,java.util.UUID) throws com.emc.archway.errorMessages.ResourceNotFound: javax.ejb.EJBException: org.jboss.resteasy.client.exception.ResteasyInternalServerErrorException: HTTP 500 Internal Server Error

Cause

限制为 20,000 个组,显示 19,999 个组。

Resolution

修改 AppSync 组的搜索路径,以便 AppSync 不会查看其他组,然后重试添加设置。通过减少用户和组搜索路径可解决此问题。

Affected Products

AppSync

Products

Data Backup & Protection Software
Article Properties
Article Number: 000228907
Article Type: Solution
Last Modified: 10 Sep 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.