NetWorker: Il backup ha esito negativo con: Impossibile creare un canale di sessione con nsrexecd sul client name dell host per eseguire il comando 'savefs ....
Summary: Il backup ha esito negativo con Unable to create session channel with nsrexecd on host client-name per eseguire il comando 'savefs -s server-name -c client-name -g
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Symptoms
Il backup basato su client NetWorker ha esito negativo con:
Unable to create session channel with nsrexecd on host client-name to execute command 'savefs -s server-name -c client-name'
Cause
Si è verificato un problema di comunicazione tra il server e il client.
Resolution
Passaggi iniziali:
- Verificare che nsrexecd sia in esecuzione sul client.
-
Linux: ps -ef | grep nsrexecd Windows: tasklist | findstr nsrexecd
-
- Se i servizi client non sono in esecuzione, avviarli e monitorare eventuali problemi del servizio:
-
Linux: systemctl start networker Windows: net start nsrexecd
-
- I problemi di avvio del servizio possono essere monitorati nel file di daemon.raw del client:
-
Linux: /nsr/logs/daemon.raw Windows: C:\Program Files\EMC NetWorker\nsr\logs\daemon.raw
- Modo d'uso nsr_render_log: NetWorker: Come utilizzare nsr_render_log (in inglese)
- Come abilitare il rendering dei log in tempo reale: NetWorker: Come eseguire automaticamente il rendering di daemon.raw a daemon.log in tempo reale
-
- Verificare che la risoluzione dei nomi funzioni correttamente sia dal server che dal client NetWorker utilizzando nslookup. L FQDN, il nome breve e l'IP dovrebbero essere restituiti correttamente.
Risoluzione dei problemi di connettività:
- Verificare che nsradmin sia in grado di connettersi dal server al client e viceversa:
nsradmin -p nsrexecd -s client-nameDove "client-name" è il nome host del client come definito nella configurazione di NetWorker.
- Controllare l'intervallo di porte sul server e sul client con nsrports per verificare che corrispondano. L'intervallo predefinito di porte dei servizi utilizzato da NetWorker è 7937-9936.
- Sul server NetWorker, verificare quali porte/processi sono visibili dal client:
nsrrprcinfo -p client-nameDove "client-name" è il nome host del client come definito nella configurazione di NetWorker.
PS C:\Windows\system32> nsrrpcinfo -p winsrvr2k16.emclab.local
PROGRAM VERSION PROTOCOL PORT SERVICE
100000 2 tcp 7938 nsrportmapper Port Mapper
100000 2 udp 7938 nsrportmapper Port Mapper
390436 1 tcp 8655 nsrexecd GSS Authentication
390435 1 tcp 9220 nsrexecd Resource Mirror
390113 1 tcp 7937 nsrexecd Remote Execution
390440 1 tcp 9500 nsrexecd_nsrfa Remote File Access
Le porte vengono assegnate dinamicamente in base all'intervallo di porte configurato.
- Verificare se sul client è in esecuzione un firewall software e, in caso affermativo, che l'intervallo di porte includa le porte NetWorker:
- Linux:
firewall-cmd --list-all
Una configurazione tipica, con le porte NetWorker predefinite:
- Linux:
# firewall-cmd --list-all
public (active)
target: %%REJECT%%
icmp-block-inversion: no
interfaces: ens3
sources:
services:
ports: 7937-9936/tcp
protocols:
forward: no
masquerade: no
forward-ports:
source-ports:
icmp-blocks:
rich rules:
rule family="ipv4" source ipset="jump-servers" service name="ssh" accept
Tuttavia, una configurazione del firewall configurata in modo errato potrebbe essere simile alla seguente:
# firewall-cmd --list-all
public (active)
target: %%REJECT%%
icmp-block-inversion: yes
interfaces: ens3
sources:
services:
ports: 7936-7996/tcp
protocols:
forward: no
masquerade: no
forward-ports:
source-ports:
icmp-blocks: echo-reply echo-request
rich rules:
rule family="ipv4" source ipset="jump-servers" service name="ssh" accept
Windows:
Aprire Windows Defender Firewall con sicurezza avanzata ed esaminare le regole in entrata e in uscita. Verificare la presenza di eventuali regole che bloccano o limitano l'intervallo di porte di NetWorker (come mostrato con nsrports). La colonna Porta locale visualizza l'intervallo di porte a cui viene applicata la regola.
NOTA: L'amministratore del sistema operativo deve essere incaricato di esaminare eventuali impostazioni aggiuntive del sistema operativo o software che potrebbero bloccare la comunicazione. Se non vengono rilevate configurazioni a livello di sistema operativo, la comunicazione potrebbe essere bloccata da un dispositivo di rete. L'amministratore di rete deve inoltre essere incaricato di esaminare eventuali configurazioni di rete potenziali che potrebbero bloccare la comunicazione.
- Se possibile, si consiglia di utilizzare l'intervallo di porte predefinito (7937-9936). L'intervallo di porte può essere impostato utilizzando il comando nsrports:
nsrports -S 7937-9936
Affected Products
NetWorker Family, NetWorkerArticle Properties
Article Number: 000207523
Article Type: Solution
Last Modified: 20 Apr 2023
Version: 4
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