AppSync: Appsync-backup.bat i fejlfindingstilstand Mit stop med at svare med besked: Kunne ikke oprette Keycloak-bibliotek
Summary: Appsync-backup.bat i fejlfindingstilstand holder muligvis op med at svare med en meddelelse: Kunne ikke oprette tastaturbibliotek: C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Enhver funktion, der udfører en AppSync-databasesikkerhedskopiering, holder muligvis op med at reagere, hvis nogen af disse mapper findes på det drev, produktet bruger til installation.
Kører appsync-backup.bat fra <mappen install dir>\backup-assistant i fejlretningstilstand som:
Holder op med at svare med følgende fejl, hvis det antages, at "C" var installationsdrevet:
\EMC\AppSync\jboss\datastore\data\AppSync_Lockbox \EMC\AppSync\jboss\datastore\data\AppSync_Keycloak \EMC\AppSync\jboss\datastore\data\configFiles \EMC\AppSync\jboss\datastore\data\AppSync_Ese \EMC\AppSync\jboss\datastore\data\AppSync_LIC
appsync-backup -d
Failed to create keycloak directory :C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak
Cause
Appsync-backup.bat, der køres på en database, der ikke havde en matrix, der er defineret, og som er kendt for at holde op med at reagere for AppSync 4.4 og nyere, lader følgende mapper være på plads (forudsat at installationsdrevet er C:):
Dette medfører, at efterfølgende kørsler af appsync-backup.bat-hjælpeprogrammet, selv når de køres iboende under opgraderinger, holder op med at reagere. Kørsel manuelt i fejlretningstilstand viser dog fejlen:
C:\EMC\AppSync\jboss\datastore\data\AppSync_Lockbox C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak C:\EMC\AppSync\jboss\datastore\data\configFiles C:\EMC\AppSync\jboss\datastore\data\AppSync_Ese C:\EMC\AppSync\jboss\datastore\data\AppSync_LIC
Failed to create keycloak directory :C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak
Resolution
Slet følgende mapper:
C:\EMC\AppSync\jboss\datastore\data\AppSync_Lockbox C:\EMC\AppSync\jboss\datastore\data\AppSync_Keycloak C:\EMC\AppSync\jboss\datastore\data\configFiles C:\EMC\AppSync\jboss\datastore\data\AppSync_Ese C:\EMC\AppSync\jboss\datastore\data\AppSync_LIC
Products
AppSyncArticle Properties
Article Number: 000200777
Article Type: Solution
Last Modified: 14 May 2026
Version: 7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.