NetWorker: Backup fails with "Signal 11 error PATH_MAX/FILE_MAX exceeded"

Summary: Signal 11 error occurs when PATH_MAX/FILE_MAX exceeds OS limits

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • Linux client backup fails with "Signal 11 error PATH_MAX/FILE_MAX exceeded"
  • Issue is client side. All commands below are to be ran on client with the
  • To find offending files and paths, gather the OS limits and search for paths and filenames that exceed the OS limits.
    Make note of the PATH of the save set giving the error, and use in commands below in place of PATH
  • Verify the maximum length of path and file on that path
  • Log in to target client with Super User rights and run:
getconf PATH_MAX PATH
getconf NAME_MAX PATH
 
Example:
getconf PATH_MAX /share/collection_1/
   4096
  • Next, find the offending paths and files with the following commands
ls -R | grep ":" | awk 'length>4096'
find . -type d | awk 'length>4096'
ls -l | grep `^d' | awk 'length>4096'
NOTE: Modify command to match your system limits.

Cause

The save set held a directory that exceeded the set PATH_MAX value and/or FILE_MAX.

This causes a memory error.

Resolution

Option 1: Use directives to exclude the path. See the Types of Directives section of the NetWorker Administration Guide. NetWorker Guides are available through: Support for NetWorker | Manuals & Documents 
Option 2: Rename or reorganize the file paths to meet the requirements of operating system PATH_MAX and FILE_MAX settings.

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000283916
Article Type: Solution
Last Modified: 07 Jan 2026
Version:  1
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