Dell Unity: DataStore Full: VMware ESXI Datastore usage does not match Unity Pool usage

Summary: Dell Unity: DataStore Full :: VMware ESXI Datastore usage does not match Unity Pool usage (User Correctable)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Datastore Usage does not match Unity Pool usage.
Datastore is near or at 100% full, causing Data Unavailability.
Datastore is thinly Provisioned from Unity.
Expected production usage does not account for the full Datastore.

 

Cause

Host is running ESXi 5.5 Update 1a 2014-04-19 1746018 (Potentially other ESXi versions from 5.5 to 6.5 could experience this, confirm with VMware Support)
List of ESXi Versions https://kb.vmware.com/s/article/2143832

Since usable space does not match between VMware and Unity, the zeroed space reclamation feature should be investigated from the VMware side. Reference the following VMware KB article for reclaiming space in ESXi 5.5:
https://kb.vmware.com/s/article/2057513

vSphere 5.5 introduced a new command in the esxcli namespace that allows deleted blocks to be reclaimed on thin provisioned LUNs that support the VAAI UNMAP primitive. In this instance, the ESXi host was not reclaiming the deleted blocks, thus filling the datastore.

 

Resolution

Engage VMware, quote VMware Knowledge Base Article 2057513 (https://kb.vmware.com/s/article/2057513)

Run a zero space reclaim from the ESXi host, this may alleviate the full the Datastore.

 

Affected Products

Dell EMC Unity Family

Products

Dell EMC Unity Family, VMware ESXi
Article Properties
Article Number: 000051971
Article Type: Solution
Last Modified: 22 Oct 2025
Version:  5
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