SourceOne Email Management: SourceOne is unable to run scheduled activities
Summary: SourceOne is unable to run scheduled activities with error EnumServicesStatusEx FAILED. Error 234
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Symptoms
In order to avoid the errors stated above, the buffer size will be dynamically increased as per EnumServicesStatusEx needs. It will make until 10 attempts to provide the correct size buffer before it gets the error.
When SourceOne scheduled activities reach their start time,the ExJobScheduler can not create the Jobid and therefore no activity is created for SourceOne workers.
Under ExJobScheduler.exe.log you can see the following error:
Module: ExSchedCallback.cpp(71)
Function: wmain
EnumServicesStatusEx FAILED. Error 234
When SourceOne scheduled activities reach their start time,the ExJobScheduler can not create the Jobid and therefore no activity is created for SourceOne workers.
Under ExJobScheduler.exe.log you can see the following error:
Module: ExSchedCallback.cpp(71)
Function: wmain
EnumServicesStatusEx FAILED. Error 234
Cause
The cause of this issue is related to the buffer size used to get services status, this job is carried out by the function EnumServicesStatusEx. As the buffer size is not enough you will get the error EnumServicesStatusEx FAILED. Error 234. In fact Error 234 means ERROR_MORE_DATA, the data size EnumServicesStatusEx is receiving is higher than the buffer can handle.
Resolution
This issue is resolved in Hotfix Bundles (HFBs) or Service Pack versions on or higher than 7.28.0040. (7.8. Initial release)
Hotfix Bundles and Service Pack kits are available for download via https://https://www.dell.com/support, Select 'Drivers and Downloads' to access the required software
* Please note, Hotfixes are only available for the most current patch or Service Pack versions of the product that were available when this problem was resolved.
** Please note that it is always recommended to upgrade to the latest version of the SourceOne release, service pack and Hot Fix Bundle to ensure all currently resolved issues will be fixed including the issue as stated above
Hotfix Bundles and Service Pack kits are available for download via https://https://www.dell.com/support, Select 'Drivers and Downloads' to access the required software
* Please note, Hotfixes are only available for the most current patch or Service Pack versions of the product that were available when this problem was resolved.
** Please note that it is always recommended to upgrade to the latest version of the SourceOne release, service pack and Hot Fix Bundle to ensure all currently resolved issues will be fixed including the issue as stated above
Affected Products
SourceOne Email ManagementProducts
SourceOne, SourceOne Email ManagementArticle Properties
Article Number: 000055334
Article Type: Solution
Last Modified: 14 May 2025
Version: 3
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