VNX: File Options Grayed Out in Unisphere
Summary: File Options Grayed Out in Unisphere.
Symptoms
VNX File options grayed out in Unisphere.
Cause
Security was broke due to bad passwords given to sysadmin and nasadmin. Sysadmin and nasadmin account should not contain special characters like:# ! ( ) $ : < > | \
Resolution
Create a global or administrator user "tempadmin," with password "sysadmin"
(It is recommended to use "\" before the special character used in the password)
# /nasmcd/sbin/naviseccli -User sysadmin -Password oldpassword -scope 0 -h SPA Security -adduser -user tempadmin -password sysadmin -scope 0 -role administrator -type system WARNING: You are about to create user : tempadmin Proceed?(y/n) y
Verify that the temporary user account is created:
# /nasmcd/sbin/naviseccli -h spa -user tempadmin -password sysadmin -scope 0 security -list Username: tempadmin Role: administrator Scope: global Username: sysadmin Role: administrator Scope: global
Remove the sysadmin account.
# /nasmcd/sbin/naviseccli -User tempadmin -Password sysadmin -scope 0 -h SPA Security -rmuser -user sysadmin -scope 0
Update Control Station array security cache files using nas_storage, using the array administrator username, and the current user password (as set on the array):
# nas_storage l id acl name serial_number 1 0 XXXXXXXXXXXX XXXXXXXXXXX # nas_storage -modify id=<CLARiiON ID> -security Enter the Global CLARiiON account information Username: tempadmin Password: ********* Retype your response to validate Password: ********* Setting security information for XXXXXXXXXXXXX done
Log in to the Unisphere with tempadmin account and confirm that the File options are up.
Re-create the sysadmin account
# /nasmcd/sbin/naviseccli -User tempadmin -Password sysadmin -scope 0 -h SPA Security -adduser -user sysadmin -password sysadmin -scope 0 -role administrator -type system
Remove the tempadmin account.
# /nasmcd/sbin/naviseccli -User sysadmin -Password sysadmin -scope 0 -h SPB Security -rmuser -user tempadmin -scope 0
Verify that the Tempadmin user was successfully removed.
# /nasmcd/sbin/naviseccli -h spa -user sysadmin -password sysadmin -scope 0 security -list Username: sysadmin Role: administrator Scope: global
To change the password for the sysadmin account, login to Unisphere with sysadmin/sysadmin.
- Select the array from the list
- Go to Settings->Global User
- Click sysadmin from the Users list and click Modify
- Enter the new password and confirm and click OK.
- Logout and re-login with the modified sysadmin password