NetWorker NMC 從版本 9.2.X 更新至版本 19.X 後,Postgres DB 無法成功遷移至版本 11。
Summary: NetWorker NMC 從版本 9.2.X 更新至版本 19.X 後,Postgres DB 無法成功遷移至版本 11。目標是取得 NMC 版本 19.X + Postgres 11。
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Symptoms
NMC 升級在記錄中的下列位置發生將 Postgres 從版本 9.2 遷移至版本 11 的問題。
來自“pg_upgrade_server.log”。
command: "/opt/lgtonmc/postgres/9.2/bin/pg_ctl" -w -l "pg_upgrade_server.log" -D "/nsr/nmc/nmcdb/pgdata" -o "-p 5432 -c autovacuum=off -c autovacuum_freeze_max_age=2000000000 -c listen_addresses='' -c unix_socket_permissions=0700" start >> "pg_upgrade_server.log" 2>&1 pg_ctl: another server might be running; trying to start server anyway waiting for server to start....FATAL: could not open lock file "/tmp/.s.PGSQL.5432.lock": Permission denied stopped waiting pg_ctl: could not start server Examine the log output. From "install.log".
Performing Consistency Checks on Old Live Server ------------------------------------------------ Checking cluster versions ok could not open file "/nsr/nmc/nmcdb/pgdata/postmaster.pid": No such file or directory Failure, exiting 107558:gstdbinit: The binary '/opt/lgtonmc/postgres_latest/bin/pg_upgrade' did not launch or complete successfully 186994:gstdbinit: pg_upgrade --check failed Upgrade to Postgres 11 Failed. Failover to 9.2 binaries so that db can start
Cause
這是極少數極端情況,其中某些程序在檔案「/tmp/.s.PGSQL.5432.lock」上有鎖定。
Resolution
若要解決此問題,我們需要停止 NMC 服務,然後重新執行「nmc_config」指令檔,以手動遷移 Postgres:/opt/lgtonmc/bin/nmc_config
以下是成功執行後該指令檔的相關輸出結果。(如果遇到相同的問題,在再次執行此指令檔之前可能需要重新開機)。
以下是成功執行後該指令檔的相關輸出結果。(如果遇到相同的問題,在再次執行此指令檔之前可能需要重新開機)。
Postgres 9.2 database detected. It will be migrated to Postgres 11 It may take a while to upgrade..... Migration to Postgres 11 Successful. The installation completed successfully.
Additional Information
本內容已翻譯為 15 種語言:
| https://downloads.dell.com/TranslatedPDF/CS_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/DA_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/DE_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/ES-XL_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/FI_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/FR_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/IT_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/JA_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/KO_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/NL_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/NO-NO_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/PL_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/PT-BR_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/RU_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/SV_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/TR_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/ZH-CN_KB540106.pdf |
Affected Products
NetWorker Management ConsoleProducts
NetWorker, NetWorker Series, NetWorker Management ConsoleArticle Properties
Article Number: 000170938
Article Type: Solution
Last Modified: 23 Sept 2024
Version: 4
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