NetWorker NMC 从版本 9.2.X 更新到版本 19.X 后,Postgres 数据库无法成功迁移到版本 11。

Summary: NetWorker NMC 从版本 9.2.X 更新到版本 19.X 后,Postgres 数据库无法成功迁移到版本 11。目标是获取 NMC 版本 19.X + Postgres 11。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



在日志中的以下时间点,NMC 升级遇到将 Postgres 从版本 9.2 迁移到版本 11 的问题。

来自“pg_upgrade_server.log”。
command: "/opt/lgtonmc/postgres/9.2/bin/pg_ctl" -w -l "pg_upgrade_server.log" -D "/nsr/nmc/nmcdb/pgdata" -o "-p 5432 -c autovacuum=off -c autovacuum_freeze_max_age=2000000000  -c listen_addresses='' -c unix_socket_permissions=0700" start >> "pg_upgrade_server.log" 2>&1
        pg_ctl: another server might be running; trying to start server anyway
        waiting for server to start....FATAL:  could not open lock file "/tmp/.s.PGSQL.5432.lock": Permission denied
         stopped waiting
        pg_ctl: could not start server
        Examine the log output.

From "install.log".
Performing Consistency Checks on Old Live Server
        ------------------------------------------------
        Checking cluster versions                                   ok
        could not open file "/nsr/nmc/nmcdb/pgdata/postmaster.pid": No such file or directory
        Failure, exiting
        107558:gstdbinit: The binary '/opt/lgtonmc/postgres_latest/bin/pg_upgrade' did not launch or complete successfully
        186994:gstdbinit: pg_upgrade --check failed 
        Upgrade to Postgres 11 Failed. Failover to 9.2 binaries so that db can start

Cause

这是一种罕见的极端情况,某些进程对文件“/tmp/.s.PGSQL.5432.lock”有锁定。

Resolution

要解决此问题,我们需要停止 NMC 服务并重新运行“nmc_config”脚本以手动迁移 Postgres:/opt/lgtonmc/bin/nmc_config

以下是成功执行后该脚本的相关输出。(如果遇到相同的问题,可能需要重新启动,然后才能再次运行此脚本)。
 
Postgres 9.2 database detected. It will be migrated to Postgres 11
It may take a while to upgrade.....
Migration to Postgres 11 Successful.
The installation completed successfully.

 

Additional Information

此内容已翻译成 15 种语言: 
https://downloads.dell.com/TranslatedPDF/CS_KB540106.pdf
https://downloads.dell.com/TranslatedPDF/DA_KB540106.pdf
https://downloads.dell.com/TranslatedPDF/DE_KB540106.pdf
https://downloads.dell.com/TranslatedPDF/ES-XL_KB540106.pdf
https://downloads.dell.com/TranslatedPDF/FI_KB540106.pdf
https://downloads.dell.com/TranslatedPDF/FR_KB540106.pdf
https://downloads.dell.com/TranslatedPDF/IT_KB540106.pdf
https://downloads.dell.com/TranslatedPDF/JA_KB540106.pdf
https://downloads.dell.com/TranslatedPDF/KO_KB540106.pdf
https://downloads.dell.com/TranslatedPDF/NL_KB540106.pdf
https://downloads.dell.com/TranslatedPDF/NO-NO_KB540106.pdf
https://downloads.dell.com/TranslatedPDF/PL_KB540106.pdf
https://downloads.dell.com/TranslatedPDF/PT-BR_KB540106.pdf
https://downloads.dell.com/TranslatedPDF/RU_KB540106.pdf
https://downloads.dell.com/TranslatedPDF/SV_KB540106.pdf
https://downloads.dell.com/TranslatedPDF/TR_KB540106.pdf
https://downloads.dell.com/TranslatedPDF/ZH-CN_KB540106.pdf

Affected Products

NetWorker Management Console

Products

NetWorker, NetWorker Series, NetWorker Management Console
Article Properties
Article Number: 000170938
Article Type: Solution
Last Modified: 23 Sept 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.