NetWorker NMCをバージョン9.2.Xからバージョン19.Xにアップデートした後、Postgres DBがバージョン11に正常に移行されません。
Summary: NetWorker NMCをバージョン9.2.Xからバージョン19.Xにアップデートした後、Postgres DBがバージョン11に正常に移行されません。目的は、NMCバージョン19.X + Postgres 11を取得することです。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
ログの次のポイントで、NMCアップグレードでPostgresをバージョン9.2からバージョン11に移行する際に問題が発生しました。
「pg_upgrade_server.log」から。
command: "/opt/lgtonmc/postgres/9.2/bin/pg_ctl" -w -l "pg_upgrade_server.log" -D "/nsr/nmc/nmcdb/pgdata" -o "-p 5432 -c autovacuum=off -c autovacuum_freeze_max_age=2000000000 -c listen_addresses='' -c unix_socket_permissions=0700" start >> "pg_upgrade_server.log" 2>&1 pg_ctl: another server might be running; trying to start server anyway waiting for server to start....FATAL: could not open lock file "/tmp/.s.PGSQL.5432.lock": Permission denied stopped waiting pg_ctl: could not start server Examine the log output. From "install.log".
Performing Consistency Checks on Old Live Server ------------------------------------------------ Checking cluster versions ok could not open file "/nsr/nmc/nmcdb/pgdata/postmaster.pid": No such file or directory Failure, exiting 107558:gstdbinit: The binary '/opt/lgtonmc/postgres_latest/bin/pg_upgrade' did not launch or complete successfully 186994:gstdbinit: pg_upgrade --check failed Upgrade to Postgres 11 Failed. Failover to 9.2 binaries so that db can start
Cause
これは、まれなまれなケースですが、一部のプロセスでファイル "/tmp/.s.PGSQL.5432.lock" がロックされています。
Resolution
この問題を解決するには、NMCサービスを停止し、「nmc_config」スクリプトを再実行してPostgresを手動で移行する必要があります。/opt/lgtonmc/bin/nmc_config
以下は、正常に実行された後のスクリプトからの関連する出力です。(同じ問題が発生した場合は、このスクリプトを再度実行する前に再起動が必要になる場合があります)。
以下は、正常に実行された後のスクリプトからの関連する出力です。(同じ問題が発生した場合は、このスクリプトを再度実行する前に再起動が必要になる場合があります)。
Postgres 9.2 database detected. It will be migrated to Postgres 11 It may take a while to upgrade..... Migration to Postgres 11 Successful. The installation completed successfully.
Additional Information
このコンテンツは15言語に翻訳されています。
| https://downloads.dell.com/TranslatedPDF/CS_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/DA_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/DE_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/ES-XL_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/FI_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/FR_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/IT_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/JA_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/KO_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/NL_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/NO-NO_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/PL_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/PT-BR_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/RU_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/SV_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/TR_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/ZH-CN_KB540106.pdf |
Affected Products
NetWorker Management ConsoleProducts
NetWorker, NetWorker Series, NetWorker Management ConsoleArticle Properties
Article Number: 000170938
Article Type: Solution
Last Modified: 23 Sept 2024
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.