NetWorker NMC를 버전 9.2.X에서 버전 19.X로 업데이트한 후 Postgres DB가 버전 11로 마이그레이션되지 않습니다.
Summary: NetWorker NMC를 버전 9.2.X에서 버전 19.X로 업데이트한 후 Postgres DB가 버전 11로 마이그레이션되지 않습니다. 목표는 NMC 버전 19.X + Postgres 11을 얻는 것입니다.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
NMC를 업그레이드할 때 로그의 다음 지점에서 Postgres를 버전 9.2에서 버전 11로 마이그레이션하는 데 문제가 발생합니다.
"pg_upgrade_server.log"에서.
command: "/opt/lgtonmc/postgres/9.2/bin/pg_ctl" -w -l "pg_upgrade_server.log" -D "/nsr/nmc/nmcdb/pgdata" -o "-p 5432 -c autovacuum=off -c autovacuum_freeze_max_age=2000000000 -c listen_addresses='' -c unix_socket_permissions=0700" start >> "pg_upgrade_server.log" 2>&1 pg_ctl: another server might be running; trying to start server anyway waiting for server to start....FATAL: could not open lock file "/tmp/.s.PGSQL.5432.lock": Permission denied stopped waiting pg_ctl: could not start server Examine the log output. From "install.log".
Performing Consistency Checks on Old Live Server ------------------------------------------------ Checking cluster versions ok could not open file "/nsr/nmc/nmcdb/pgdata/postmaster.pid": No such file or directory Failure, exiting 107558:gstdbinit: The binary '/opt/lgtonmc/postgres_latest/bin/pg_upgrade' did not launch or complete successfully 186994:gstdbinit: pg_upgrade --check failed Upgrade to Postgres 11 Failed. Failover to 9.2 binaries so that db can start
Cause
이것은 일부 프로세스가 "/tmp/.s.PGSQL.5432.lock" 파일에 대한 잠금이 있는 드문 경우입니다.
Resolution
이 문제를 해결하려면 NMC 서비스를 중지하고 "nmc_config" 스크립트를 다시 실행하여 Postgres를 수동으로 마이그레이션해야 합니다. /opt/lgtonmc/bin/nmc_config
다음은 성공적으로 실행된 후 해당 스크립트의 관련 출력입니다. (동일한 문제가 발생하는 경우 이 스크립트를 다시 실행하기 전에 재부팅해야 할 수 있습니다.)
다음은 성공적으로 실행된 후 해당 스크립트의 관련 출력입니다. (동일한 문제가 발생하는 경우 이 스크립트를 다시 실행하기 전에 재부팅해야 할 수 있습니다.)
Postgres 9.2 database detected. It will be migrated to Postgres 11 It may take a while to upgrade..... Migration to Postgres 11 Successful. The installation completed successfully.
Additional Information
이 콘텐츠는 15개 언어로 번역되어 있습니다.
| https://downloads.dell.com/TranslatedPDF/CS_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/DA_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/DE_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/ES-XL_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/FI_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/FR_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/IT_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/JA_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/KO_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/NL_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/NO-NO_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/PL_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/PT-BR_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/RU_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/SV_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/TR_KB540106.pdf |
| https://downloads.dell.com/TranslatedPDF/ZH-CN_KB540106.pdf |
Affected Products
NetWorker Management ConsoleProducts
NetWorker, NetWorker Series, NetWorker Management ConsoleArticle Properties
Article Number: 000170938
Article Type: Solution
Last Modified: 23 Sept 2024
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.