ECS xDoctor: RAP141: ARP Failure for One or More Nodes

Summary: Address Resolution Protocol (ARP) is either stuck or not responding in a timely manner from a single node or many notes. xDoctor 81 and later reports this issue as RAP141. The issue is detected automatically as part of preupgrade health checks. Run the check manually before an expansion or any node reboot. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Command to invoke the check manually:

Command:

# sudo xdoctor --rap=RAP141
Example:
admin@ecsnode1:> sudo xdoctor --rap=RAP141
2022-04-18 15:36:38,596: xDoctor_4.8-81.1 - INFO    : Initializing xDoctor v4.8-81.1 ...
2022-04-18 15:36:39,808: xDoctor_4.8-81.1 - INFO    : Removing orphaned session - session_1650295889.523
2022-04-18 15:36:39,809: xDoctor_4.8-81.1 - INFO    : Starting xDoctor session_1650296198.425 ... (SYSTEM)

xDoctor Reports RAP141 when ARP is either stuck or not responding in a timely manner.
ERROR - ARP failure for one or more nodes
-----------------------------------------
Node      = 169.254.1.17
Extra     = {'169.2XX.1.17': ['r6n4->r6n5: private.4']}
RAP       = RAP141
Solution  = KB 183702
Timestamp = 2022-04-08_181107
PSNT      = FNMXXXXXXXXXXX @ 4.8-81.0

Cause

This issue is often caused by network loops in the user's systems looping traffic to the ECS switches and can be a symptom of RAP142. See article ECS: xDoctor: RAP142: Port mismatch found between the OS and HW layer of one or more switches.

Resolution

Reach out to Dell Support referring to this KB to review further.

Affected Products

ECS Appliance, ECS Appliance Gen 3

Products

ECS, ECS Appliance Hardware Gen3 EX300, ECS Appliance Hardware Gen3 EX3000, ECS Appliance Hardware Gen3 EX500, ECS Appliance Hardware Series
Article Properties
Article Number: 000183702
Article Type: Solution
Last Modified: 08 Oct 2025
Version:  19
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