PowerMax: SRDF SRA-konfigurationsproblemer med duplikerede enheds-id er i VMware SRM-beskyttelsesgrupper

Summary: Hvis to systemenheder i to forskellige systempar har det samme enheds-id, f.eks. 0003A, kan VMware ikke identificere beskyttelsesgruppen for ét par korrekt. For eksempel har array A og array B par til array C og muligvis array D. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Dette eksempel er taget fra et laboratorium:

Hvis to systemenheder i to forskellige systempar har det samme enheds-id, f.eks. 0003A, kan VMware ikke identificere beskyttelsesgruppen korrekt for et par.

For eksempel tre arrays (selvom de kunne have fire), A, B og C. De har konfigurerede par mellem A og C og B og C. Ved tilfældighed har et sæt par fra hver det samme enheds-id på A og C: 

Par fra A til C: 0003A 001B8
Par fra B til C: 0003A 000F0

Disse er uafhængige par, og SRDF SRA har ikke noget problem med at genkende dem som vist nedenfor:
Array-par 

Når du har oprettet beskyttelsesgruppen for hvert parsæt, skal du gennemse hvert enkelt og se efter parrene. En af beskyttelsesgrupperne genkender ikke enhedsparrene, eller nogle gange viser den det forkerte par.

Beskyttelsesgruppe 

Cause

Årsagen til problemet ser ud til at være VMware SRM-kode. Den er afhængig af enheds-id'et i stedet for at bruge NAA (eller WWN), som er unik på hvert system.

Resolution

Den aktuelle løsning er at gemme VM'erne fra et af de par, der er blevet krænket, til et nyt par og derefter fjerne parret fra brug i VMware. Med omhyggelig planlægning kan duplikat-id'er undgås.

VMware har anerkendt problemet, og rettelsen vil være i SRM 8.6. Den aktuelle udgivelsesdato for dette er juni 2022, men kan ændres. De har angivet, at de kan levere backports til SRM 8.4/8.5 efter det.

Affected Products

Symmetrix, VMAX, PowerMax 2000, PowerMax 2500, PowerMax 8000, PowerMax 8500, VMware
Article Properties
Article Number: 000195144
Article Type: Solution
Last Modified: 13 Mar 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.