NetWorker: AD-gebruiker kan zich niet aanmelden via VCUI-interface, maar slaagt in Management Console.
Summary: Externe autoriteit (AD/LDAP)-gebruiker kan zich niet aanmelden bij de vCenter User (web)Interface (VCUI). Het bericht 'Ongeldige gebruikersnaam of wachtwoord' wordt weergegeven.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- Active Directory (AD) / LDAP is geïntegreerd met de NetWorker authenticatieservice (authc).
- De External Authority Resource is geconfigureerd met behulp van de 'standaard'-tenant:
- Gebruikers van externe autoriteit kunnen zich aanmelden bij de NetWorker Management Console (NMC), netWorker Web User Interface (NWUI), Data Protection Restore Web Interface (FLR/SQL restores).
- Wanneer u zich aanmeldt bij de gebruikersinterface van vCenter: https:// NetWorker-Server-Address:9090/vcui, wordt de volgende fout weergegeven:
Cause
De localhost_access_log van de NetWorker server. date.txt rapporteert:
Wanneer de standaard tenant wordt gebruikt, wordt dit bijvoorbeeld weergegeven als 'default\domain\username'.
Linux: /nsr/authc/logs/localhost_access_log. date.txt
Windows: .. \Program Files\EMC NetWorker\nsr\authc-server\tomcat\logs\localhost_access_log. date.txt
Vcui.log van de NetWorker server meldt:
Windows: .. \Program Files\EMC NetWorker\nsr\authc-server\tomcat\logs\localhost_access_log. date.txt
NWSERVERIP - - [DD/MMM/YYYY:HH:MM:SS -TZ] "GET /nwrestapi/v3/internal/users/domain%255Cusername HTTP/1.1" 404 478
VCUICLIENTIP - - [DD/MMM/YYYY:HH:MM:SS -TZ] "POST /vcui/api/login HTTP/1.1" 401 135
Linux: /nsr/authc/logs/vcui.log
Windows: .. \Program Files\EMC NetWorker\nsr\authc-server\tomcat\logs\vcui.log
De aanmelding voor de externe gebruiker is opgegeven met behulp van de indeling "domein\gebruikersnaam". Dit is de methode die wordt gebruikt in de NMC, NWUI en Data Protection Restore Client wanneer de externe autoriteit is geconfigureerd met behulp van de 'standaard'-tenant. Voor de VCUI moet de tenant echter worden opgegeven: "tenant\domain\username".
Windows: .. \Program Files\EMC NetWorker\nsr\authc-server\tomcat\logs\vcui.log
YYYY-MM-DD HH:MM:SS [https-jsse-nio-9090-exec-4] INFO c.e.n.c.n.i.NwRestApiBase.buildWebResourceFromUri 171 - Call NW: [https://NetWorker-ServerAddress:9090/nwrestapi/v3/internal/users/domain%255Cusername]
YYYY-MM-DD HH:MM:SS [https-jsse-nio-9090-exec-4] INFO c.e.n.c.n.impl.GlobalApi.validateAdminLogin 46 - Got response.
YYYY-MM-DD HH:MM:SS [https-jsse-nio-9090-exec-4] ERROR c.e.n.c.n.impl.GlobalApi.validateAdminLogin 118 - Get internal user information failed. Response Status Family = CLIENT_ERROR does not equal SUCCESSFUL
YYYY-MM-DD HH:MM:SS [https-jsse-nio-9090-exec-4] ERROR c.e.n.c.n.impl.GlobalApi.validateAdminLogin 122 - Admin status was not able to be determined for given user and group.
YYYY-MM-DD HH:MM:SS [https-jsse-nio-9090-exec-4] ERROR c.d.e.n.s.AuthenticationServiceImpl.assertValidNetWorkerLogin 82 - NetWorker login failed for administrator
Wanneer de standaard tenant wordt gebruikt, wordt dit bijvoorbeeld weergegeven als 'default\domain\username'.
Resolution
Wanneer u zich aanmeldt bij de vCenter User Interface (VCUI) als een externe autoriteit (AD of LDAP)-gebruiker, geeft u de tenant\domain\gebruikersnaam op.
De geslaagde verificatieaanvraag wordt vastgelegd in vcui.log:
De geslaagde verificatieaanvraag wordt vastgelegd in vcui.log:
YYYY-MM-DD HH:MM:SS [https-jsse-nio-9090-exec-3] INFO c.e.n.c.n.i.NwRestApiBase.buildWebResourceFromUri 171 - Call NW: [https://NetWorker-Server-Address:9090/nwrestapi/v3/internal/users/default%255Cdomain%255Cusername]
YYYY-MM-DD HH:MM:SS [https-jsse-nio-9090-exec-3] INFO c.e.n.c.n.impl.GlobalApi.validateAdminLogin 46 - Got response.
Affected Products
NetWorkerProducts
NetWorker Family, NetWorker SeriesArticle Properties
Article Number: 000204190
Article Type: Solution
Last Modified: 21 Mar 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.